summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Hixson <mujo@sdf.org>2023-02-28 19:40:27 -0800
committerSam James <sam@gentoo.org>2023-03-19 03:10:57 +0000
commit677c2f992c31a0b3e36a8c4c9647092ab2adcf02 (patch)
treed02944913e6c67b2b11dc4fefa2c71d4654e1a5c /app-editors
parentsci-calculators/bc-gh: bump to 6.5.0 (diff)
downloadgentoo-677c2f992c31a0b3e36a8c4c9647092ab2adcf02.tar.gz
gentoo-677c2f992c31a0b3e36a8c4c9647092ab2adcf02.tar.bz2
gentoo-677c2f992c31a0b3e36a8c4c9647092ab2adcf02.zip
app-editors/kakoune: Fix gcc13 build bug #895264
Closes: https://bugs.gentoo.org/895264 Signed-off-by: Ian Hixson <mujo@sdf.org> Closes: https://github.com/gentoo/gentoo/pull/29867 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/kakoune/files/kakoune-2022.10.31-gcc13.patch29
-rw-r--r--app-editors/kakoune/kakoune-2022.10.31.ebuild6
2 files changed, 34 insertions, 1 deletions
diff --git a/app-editors/kakoune/files/kakoune-2022.10.31-gcc13.patch b/app-editors/kakoune/files/kakoune-2022.10.31-gcc13.patch
new file mode 100644
index 000000000000..6c093bcdb2eb
--- /dev/null
+++ b/app-editors/kakoune/files/kakoune-2022.10.31-gcc13.patch
@@ -0,0 +1,29 @@
+https://bugs.gentoo.org/895264
+https://github.com/mawww/kakoune/issues/4854
+
+diff --git a/src/keys.hh b/src/keys.hh
+index 0af1a5a8..ccafe336 100644
+--- a/src/keys.hh
++++ b/src/keys.hh
+@@ -9,6 +9,8 @@
+ #include "unicode.hh"
+ #include "vector.hh"
+
++#include <cstdint>
++
+ namespace Kakoune
+ {
+
+diff --git a/src/ranked_match.hh b/src/ranked_match.hh
+index ec7fe626..62d6b8f0 100644
+--- a/src/ranked_match.hh
++++ b/src/ranked_match.hh
+@@ -4,6 +4,8 @@
+ #include "string.hh"
+ #include "meta.hh"
+
++#include <cstdint>
++
+ namespace Kakoune
+ {
+
diff --git a/app-editors/kakoune/kakoune-2022.10.31.ebuild b/app-editors/kakoune/kakoune-2022.10.31.ebuild
index 2e6ad9d352ed..9293c946c84a 100644
--- a/app-editors/kakoune/kakoune-2022.10.31.ebuild
+++ b/app-editors/kakoune/kakoune-2022.10.31.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2020-2022 Gentoo Authors
+# Copyright 2020-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -15,6 +15,10 @@ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
BDEPEND="virtual/pkgconfig"
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc13.patch
+)
+
src_prepare() {
sed -i '/CXXFLAGS += -O3/d' src/Makefile || die
default