summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-02-22 21:55:37 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2024-02-22 21:59:06 +0200
commit61a45bd6e06d22065233e3b0c7ff5b9cfdf5239f (patch)
treeb0664c7f883328cdd76f62bdb08be6bb897956f0 /app-editors
parentsys-fs/multipath-tools: Revbump, fix segfault (bug #925189) (diff)
downloadgentoo-61a45bd6e06d22065233e3b0c7ff5b9cfdf5239f.tar.gz
gentoo-61a45bd6e06d22065233e3b0c7ff5b9cfdf5239f.tar.bz2
gentoo-61a45bd6e06d22065233e3b0c7ff5b9cfdf5239f.zip
app-editors/featherpad: add 1.5.0
This release dropped support for qt5 builds, meaning starting from now only qt6 builds are possible. Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/featherpad/Manifest1
-rw-r--r--app-editors/featherpad/featherpad-1.5.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/app-editors/featherpad/Manifest b/app-editors/featherpad/Manifest
index ad56b66d6c44..365933d74e9e 100644
--- a/app-editors/featherpad/Manifest
+++ b/app-editors/featherpad/Manifest
@@ -1,2 +1,3 @@
DIST featherpad-1.4.0.tar.gz 1105701 BLAKE2B 31311a9862f64554d57bc6c0688e5ec551a331f6f016b0bd3ab53225afd050347cc6758199ad17ebb5d7aba44b88a971f1e754d8ccd925369e09ed6639eb0131 SHA512 eb3f13dbad799d3a55a8c048a94c2acb2b9286775e75aec482f475c792e2b74078fc4d5cc43def8ba7b4f592ecb5b684c5890629edca5a488ccac336021cb7e8
DIST featherpad-1.4.1.tar.gz 1109511 BLAKE2B 127f0b18252ac020d6f66e315090968825e7a67309e3b5d66b8f119975f91b273973c9ac1b8a8c1bd46d2eece43df649eddb7b838d79fee0f5ddc2d4caae3fb2 SHA512 485d6e731ad5927bb6fd4499536d45b40319eff5bfd8a9b1cd9acc063dcb5fb35ced033e2e5aafa60c6bb87426fb1cb95fe5d78ffb5a2f361702d23320508ef8
+DIST featherpad-1.5.0.tar.gz 1087068 BLAKE2B aef468f426c9c635624fe16f8180647a9f62a12c98d654dfb340758ff524e629341469ec3f37cfe8a481def99ba6c99672aa31c49b03226e2e895dce11e9b5e6 SHA512 984d1fba0e4bcb1eda8c2dd3bee34cf2ee0ba5604dd2c9328cc67531099b8a806e8ab79020510049eb788764cf0ad4486c128eefb43d9ab1ccdc4a3c06c48497
diff --git a/app-editors/featherpad/featherpad-1.5.0.ebuild b/app-editors/featherpad/featherpad-1.5.0.ebuild
new file mode 100644
index 000000000000..229b5bbfe620
--- /dev/null
+++ b/app-editors/featherpad/featherpad-1.5.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg
+
+DESCRIPTION="Lightweight Qt5 Plain-Text Editor for Linux"
+HOMEPAGE="https://github.com/tsujan/FeatherPad"
+SRC_URI="https://github.com/tsujan/FeatherPad/archive/V${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/FeatherPad-${PV}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+X"
+
+RDEPEND="
+ app-text/hunspell:=
+ dev-qt/qtbase:6[cups,dbus,gui,widgets]
+ dev-qt/qtsvg:6
+ X? ( x11-libs/libX11 )
+"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )
+"
+BDEPEND="dev-qt/qttools:6[linguist]"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITHOUT_X11=$(usex !X)
+ )
+ cmake_src_configure
+}