summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2018-06-03 14:48:43 +0200
committerUlrich Müller <ulm@gentoo.org>2018-06-03 14:51:03 +0200
commit600032df2bbad6b36e3fb41966fbd6a84dd809cc (patch)
treedf4fd171003525f1d2bd3bd7046726672cb7208b /app-editors
parentapp-editors/nano: Removed old. (diff)
downloadgentoo-600032df2bbad6b36e3fb41966fbd6a84dd809cc.tar.gz
gentoo-600032df2bbad6b36e3fb41966fbd6a84dd809cc.tar.bz2
gentoo-600032df2bbad6b36e3fb41966fbd6a84dd809cc.zip
app-editors/mg: Version bump.
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/mg/Manifest1
-rw-r--r--app-editors/mg/mg-20180408.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/app-editors/mg/Manifest b/app-editors/mg/Manifest
index 395ef497fccd..a25162831d45 100644
--- a/app-editors/mg/Manifest
+++ b/app-editors/mg/Manifest
@@ -1,2 +1,3 @@
DIST mg-20170828.tar.gz 141028 BLAKE2B a0243ee05f86161f1a9448ec92c8cf14362a60dd3643ad49f79fdd6c2ffe56f51415321eb6f3d7b78c1ca6eab9cb91380cdb63f699359080011d6801feaedd04 SHA512 1ea16b1dd5e9e08abf9fcf0889130b4f39d36872bb64df85470a9ced1db87c0eecb18cc6e8c3c5a04f9049d58ef4492d5a88cf3502ec3351abccb7bddfb90c14
DIST mg-20171014.tar.gz 141045 BLAKE2B a5b3bda6ff3b6416093069b471762687c2279737aa05b297ccd3077aff195cf52831566768613a81dcc977a27ac5ffd6e8a1874aa1010b6d90f4c678b6825cee SHA512 d55818308421aa523fb30b6e4725bb122f37637a822fabafeba9f9da3b97fd7f6af6431fce3015c969d0e656a48e89ed49b790deefc69fbdbb7e257f8a1aeb56
+DIST mg-20180408.tar.gz 141988 BLAKE2B db7da46fb0160acf8695f05234ed0c8e9a45e4239dc3abd433ddfb8b66e2b1aa550ffc4b409486a8990881d791ed73269a8ab78f6846cd4f0bee67761c11d281 SHA512 25fceb18fcbe63010e7a2e107aa5c30356938be2e04ff48869a12b5018dbb83bcf4dc70b03674713516616037247952a51454a28ca418cdc7b020d1f415f8701
diff --git a/app-editors/mg/mg-20180408.ebuild b/app-editors/mg/mg-20180408.ebuild
new file mode 100644
index 000000000000..963154791f8c
--- /dev/null
+++ b/app-editors/mg/mg-20180408.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="MicroGnuEmacs, a port from the BSDs"
+HOMEPAGE="https://homepage.boetes.org/software/mg/"
+SRC_URI="https://github.com/hboetes/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="livecd"
+
+RDEPEND="sys-libs/ncurses:0
+ !elibc_FreeBSD? ( >=dev-libs/libbsd-0.7.0 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ # fix path to tutorial in man page
+ sed -i -e "s:doc/mg/:doc/${PF}/:" mg.1 || die
+ eapply_user
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+ dobin mg
+ doman mg.1
+ dodoc README tutorial
+ # don't compress the tutorial, otherwise mg cannot open it
+ docompress -x /usr/share/doc/${PF}/tutorial
+}
+
+pkg_postinst() {
+ if use livecd; then
+ [[ -e ${EROOT}/usr/bin/emacs ]] || ln -s mg "${EROOT}"/usr/bin/emacs
+ fi
+}