summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHaelwenn (lanodan) Monnier <contact@hacktivis.me>2017-10-26 00:57:28 +0200
committerMichał Górny <mgorny@gentoo.org>2018-02-09 17:36:10 +0100
commite081e240b3e713c8512f38d125c50fbbe250b6d2 (patch)
tree6546c62853b77cab0020ce76ff10d26665e5b952 /app-editors/vis/vis-0.3.ebuild
parentsys-devel/clang-runtime: Bump to 6.0.0rc2 (diff)
downloadgentoo-e081e240b3e713c8512f38d125c50fbbe250b6d2.tar.gz
gentoo-e081e240b3e713c8512f38d125c50fbbe250b6d2.tar.bz2
gentoo-e081e240b3e713c8512f38d125c50fbbe250b6d2.zip
app-editors/vis: add FEATURES=test
Diffstat (limited to 'app-editors/vis/vis-0.3.ebuild')
-rw-r--r--app-editors/vis/vis-0.3.ebuild17
1 files changed, 15 insertions, 2 deletions
diff --git a/app-editors/vis/vis-0.3.ebuild b/app-editors/vis/vis-0.3.ebuild
index e6ef1b663060..4f5eded38a78 100644
--- a/app-editors/vis/vis-0.3.ebuild
+++ b/app-editors/vis/vis-0.3.ebuild
@@ -3,13 +3,16 @@
EAPI=5
+MY_PTV=0.1
+
DESCRIPTION="modern, legacy free, simple yet efficient vim-like editor"
HOMEPAGE="https://github.com/martanne/vis"
-SRC_URI="https://github.com/martanne/vis/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/martanne/vis/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ test? ( https://github.com/martanne/vis-test/archive/v${MY_PTV}.tar.gz -> vis-test-${MY_PTV}.tar.gz )"
LICENSE="ISC"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="+ncurses selinux tre"
+IUSE="+ncurses selinux test tre"
#Note: vis is reported to also work with NetBSD curses
#TODO: >=dev-lang/lua-5.2 (needed for syntax highlighting and settings)
@@ -18,6 +21,16 @@ DEPEND=" dev-libs/libtermkey
tre? ( dev-libs/tre:= )"
RDEPEND="${DEPEND}"
+src_prepare() {
+ if use test; then
+ rm -r test || die
+ mv "${WORKDIR}/vis-test-${MY_PTV}" test || die
+ if ! type -P vim &>/dev/null; then
+ sed -i 's/.*vim.*//' test/Makefile || die
+ fi
+ fi
+}
+
src_configure() {
econf \
$(use_enable ncurses curses) \