summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-08-22 09:11:20 -0300
committerMatt Turner <mattst88@gentoo.org>2023-08-22 10:03:48 -0400
commit0a558aeb546c836ffde7dd8e18cf9c5d63af5f74 (patch)
treede7ccf756e47afdbfe1d6a750b9ce202333f9489 /app-editors/ghex
parentgnome-extra/gnome-calendar: Version bump to 45_beta (diff)
downloadgentoo-0a558aeb546c836ffde7dd8e18cf9c5d63af5f74.tar.gz
gentoo-0a558aeb546c836ffde7dd8e18cf9c5d63af5f74.tar.bz2
gentoo-0a558aeb546c836ffde7dd8e18cf9c5d63af5f74.zip
app-editors/ghex: Version bump to 45_beta
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/32408 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-editors/ghex')
-rw-r--r--app-editors/ghex/Manifest1
-rw-r--r--app-editors/ghex/ghex-45_beta.ebuild66
-rw-r--r--app-editors/ghex/ghex-9999.ebuild2
3 files changed, 68 insertions, 1 deletions
diff --git a/app-editors/ghex/Manifest b/app-editors/ghex/Manifest
index 65963b505ce0..bb3756980091 100644
--- a/app-editors/ghex/Manifest
+++ b/app-editors/ghex/Manifest
@@ -1,2 +1,3 @@
DIST ghex-44.1.tar.xz 895780 BLAKE2B 553dc5002a3524ad4642d4f7693d7ee69a0c94bbc2976c1fae640d7d71eb84e145bd764c7acc946735b0b45235b6229a269c12ccb8566e591a83311c6d6177d5 SHA512 4239af382ed3bce0a932db875b1ccc8e1666cfc2827cd13b65afc8310de9107e3f106553dbde4c2663aaf6f0bbc906c51d9f8b61d9af661baf6cbb6b6e2be675
DIST ghex-44.2.tar.xz 897944 BLAKE2B 0db001b90390f7747792ac89a5daaf9d38165b72dce77c3a2fd41914a4386001b9f15aaf4352a3b41a204a9104a5234a6ac50a3a7269e10a151c000d57228480 SHA512 a06876e06488bb25b17fbdf17ea73e57f563fe49a414c173d680a6bf4db9b66b40fce90ad67cfb73c62f25d88f436a58b7e0fd588c7a664faf78c5058524cabf
+DIST ghex-45.beta.tar.xz 899044 BLAKE2B 4b37a882a6626c16349ac0671e1b049d9fdb166262cce0605bf84ba5d099354647fa61f380a18f217bf20f80570de64d946dec97a05bc47441ed641c847cc6b8 SHA512 5a35fe4449ffda75e587fb55d8ef641e054cb079b880c7750c00ceb61c207fbfee649b16a53c639c7108ced35efa0cfc2e092da3197dd6b5af116ec737e4c773
diff --git a/app-editors/ghex/ghex-45_beta.ebuild b/app-editors/ghex/ghex-45_beta.ebuild
new file mode 100644
index 000000000000..7d5199d0588b
--- /dev/null
+++ b/app-editors/ghex/ghex-45_beta.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="GNOME hexadecimal editor"
+HOMEPAGE="https://wiki.gnome.org/Apps/Ghex"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.gnome.org/GNOME/ghex.git"
+ SRC_URI=""
+else
+ KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="GPL-2+ FDL-1.1+"
+IUSE="gtk-doc test"
+RESTRICT="!test? ( test )"
+SLOT="4"
+
+RDEPEND="
+ >=dev-libs/glib-2.68.0:2
+ >=gui-libs/gtk-4.4.0:4
+ gui-libs/libadwaita:1
+ dev-libs/gobject-introspection
+ !app-editors/ghex:2
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ gtk-doc? ( dev-util/gi-docgen )
+ test? (
+ dev-util/desktop-file-utils
+ dev-libs/appstream-glib
+ )
+ dev-util/gtk-update-icon-cache
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Ddocdir="${EPREFIX}"/usr/share/gtk-doc/
+ -Ddevelopment=false
+ -Dmmap-buffer-backend=true
+ -Ddirect-buffer-backend=true
+ -Dintrospection=enabled
+ $(meson_use gtk-doc gtk_doc)
+ -Dstatic-html-help=false
+ -Dvapi=false
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}
diff --git a/app-editors/ghex/ghex-9999.ebuild b/app-editors/ghex/ghex-9999.ebuild
index e0eb24528bc6..7d5199d0588b 100644
--- a/app-editors/ghex/ghex-9999.ebuild
+++ b/app-editors/ghex/ghex-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8