summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2024-04-26 22:24:21 +0900
committerAkinori Hattori <hattya@gentoo.org>2024-04-26 22:26:00 +0900
commit88810287133bb17e0069ea2f7a22fa610d95e76a (patch)
treeec1c74f125d598f45df27bfd6fc929268ac137ff /app-dicts
parentapp-dicts/migemo-dict: tidy (diff)
downloadgentoo-88810287133bb17e0069ea2f7a22fa610d95e76a.tar.gz
gentoo-88810287133bb17e0069ea2f7a22fa610d95e76a.tar.bz2
gentoo-88810287133bb17e0069ea2f7a22fa610d95e76a.zip
app-dicts/migemo-dict: new snapshot
Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-dicts')
-rw-r--r--app-dicts/migemo-dict/Manifest1
-rw-r--r--app-dicts/migemo-dict/migemo-dict-202402.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/app-dicts/migemo-dict/Manifest b/app-dicts/migemo-dict/Manifest
index 925756c7debb..aea3fc4e781c 100644
--- a/app-dicts/migemo-dict/Manifest
+++ b/app-dicts/migemo-dict/Manifest
@@ -1 +1,2 @@
DIST migemo-dict-200812.tar.bz2 1467494 BLAKE2B 25f4da49e0e1970df9f43a26f72f1ae85c89ee0d3b708e7f7ea46a2b3b133c59a3990a44e6e578335d3c836027543fc695334573613674ad4e100c06da3eac0b SHA512 cc42d62247c5ff0c3a4ff30a7c135173f94c4f49685df997b305486502b86144428dc104a77361d5ceff91683b0b663d0c68174300d628f70f6999cf7667f3c0
+DIST migemo-dict-202402.tar.xz 1202732 BLAKE2B aea31efc4b4967ba52fbfe85a691b1deb7eef70f2c9d5a1dcb6942d10507ef140045af9232055ab9ae6bbd2936bc5f077ef1564237316e3f0a98b2e0e3100aef SHA512 622b237eb1bdb3abcc18cc104cba3bed56eefbd2a92f47ed316757ce3d9016a435c9b3181030b392a42ff4ef59582cbee3879570ad6312907699e50f297ff5dc
diff --git a/app-dicts/migemo-dict/migemo-dict-202402.ebuild b/app-dicts/migemo-dict/migemo-dict-202402.ebuild
new file mode 100644
index 000000000000..e32b040c4c56
--- /dev/null
+++ b/app-dicts/migemo-dict/migemo-dict-202402.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+DESCRIPTION="Dictionary files for the Migemo and C/Migemo"
+HOMEPAGE="https://skk-dev.github.io/dict/"
+SRC_URI="mirror://gentoo/${P}.tar.xz
+ https://dev.gentoo.org/~hattya/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="unicode"
+
+src_configure() {
+ if use unicode; then
+ iconv -f euc-jp -t utf-8 ${PN} >"${T}"/${PN} || die
+ else
+ cp ${PN} "${T}"/ || die
+ fi
+}
+
+src_install() {
+ insinto /usr/share/${PN%-*}
+ doins "${T}"/${PN}
+}