summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Kurakin <kuraga333@mail.ru>2024-07-04 22:15:27 +0300
committerJoonas Niilola <juippis@gentoo.org>2024-08-10 10:19:28 +0300
commit3e62d062af1b6da1ccab8b985f4b5e021f8a71c3 (patch)
tree3b176cc0038ca86f077bd1dc365b3abe764ad4fb /app-dicts/myspell-en
parentnet-mail/automx2: drop 2022.1 (diff)
downloadgentoo-3e62d062af1b6da1ccab8b985f4b5e021f8a71c3.tar.gz
gentoo-3e62d062af1b6da1ccab8b985f4b5e021f8a71c3.tar.bz2
gentoo-3e62d062af1b6da1ccab8b985f4b5e021f8a71c3.zip
app-dicts/myspell-en: add 20240801
Closes: https://bugs.gentoo.org/935499 Signed-off-by: Alexander Kurakin <kuraga333@mail.ru> Closes: https://github.com/gentoo/gentoo/pull/37437 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-dicts/myspell-en')
-rw-r--r--app-dicts/myspell-en/Manifest1
-rw-r--r--app-dicts/myspell-en/myspell-en-20240801.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/app-dicts/myspell-en/Manifest b/app-dicts/myspell-en/Manifest
index b513fa6b4acc..a516c745b298 100644
--- a/app-dicts/myspell-en/Manifest
+++ b/app-dicts/myspell-en/Manifest
@@ -1,3 +1,4 @@
DIST dict-en-20240201_lo.oxt 6105836 BLAKE2B 2978b36dfea07570b8be255c021e8f6cf9113f3ea342db0cc25d52e58a406f75015fdc5961556594756fde30293c21bcbf17c00b49e962e5a4f558be3f17b42c SHA512 92098925935ec23a3058db4a136e37f6dc3c24f0901de45bfd84e19efb5c3b207bb06e902368fd00c0851003b2e385719d850b3cced15e3d4a2b2d5143b5eafc
DIST dict-en-20240501_lo.oxt 6107426 BLAKE2B 811ca6f8a82f348c391b8b4df832446a8d248ec9b6ec85a9c1320f7329679e4fa6d3d507d18d3d792d878fc6f369b70135fa25a75c86b858333e370816db5761 SHA512 3d4ae13c4d68a62970742bb7e8568bebf03cbfaa04051b2152197f2d2a9fb539642a6ff6032123716c31e5f340bd2bad428983f79a7d8c6679e9da48f272e65c
DIST dict-en-20240601_lo.oxt 6109035 BLAKE2B a90f4f2dad3a0b694aadeddf0a028138cb06f6e9f244279a43741b87260bacefd83148997f99ddca83343a301dc92a84253174e16595c11796a20dda3a372237 SHA512 688ad1a14f6a3eadbcaa7cc9e08ce6fe4bf5d6867fa92df6eb9fc91d06645936ad1844e1fa954e6c9d20aabfa8cb323a99ff9383f70c55b1afcf6685d5970b5e
+DIST dict-en-20240801_lo.oxt 6111095 BLAKE2B 47f4aa028946a05af94e9eca2d259e437de2c095c0ee83dc44da49d1066122aaba628036aa5858cbed5a97d487196d31ed29df72c962fc1f64c834997098691c SHA512 bd3b203d3914e10fe020075defa7a6b90220789751f0124743c4fd60e799dc4e41bf4c168d894d673335615c3d0eafc5e773c915e843e776d871952a6cc7cf8a
diff --git a/app-dicts/myspell-en/myspell-en-20240801.ebuild b/app-dicts/myspell-en/myspell-en-20240801.ebuild
new file mode 100644
index 000000000000..2889bdb32007
--- /dev/null
+++ b/app-dicts/myspell-en/myspell-en-20240801.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit myspell-r2
+
+DESCRIPTION="English dictionaries for myspell/hunspell"
+HOMEPAGE="
+ https://extensions.libreoffice.org/extensions/english-dictionaries
+ https://github.com/marcoagpinto/aoo-mozilla-en-dict
+ https://proofingtoolgui.org
+"
+SRC_URI="https://extensions.libreoffice.org/assets/downloads/41/1722502287/dict-en-20240801_lo.oxt"
+
+LICENSE="BSD MIT LGPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+PLOCALES=( "en-AU" "en-CA" "en-GB" "en-US" "en-ZA" )
+IUSE="${PLOCALES[*]/#/+l10n_}"
+REQUIRED_USE="|| ( ${PLOCALES[*]/#/l10n_} )"
+
+src_prepare() {
+ # This thesaurus is used by all the English dictionaries, see
+ # ./dictionaries.xcu in the distfile, lines 71-81.
+ MYSPELL_THES=(
+ "th_en_US_v2.dat"
+ "th_en_US_v2.idx"
+ )
+
+ local non_us_dic_used=0
+ local mylinguas
+ for lang in "${PLOCALES[@]}"; do
+ mylinguas="${lang/-/_}"
+ if use "l10n_${lang}"; then
+ MYSPELL_DICT+=( "${mylinguas}.aff" "${mylinguas}.dic" )
+ if [[ ${lang} == en-US ]]; then
+ MYSPELL_HYPH=( "hyph_en_US.dic" )
+ else
+ non_us_dic_used=1
+ fi
+ else
+ rm "README_${mylinguas}.txt" || die
+ if [[ ${lang} == "en-US" ]]; then
+ rm "README_hyph_en_US.txt" || die
+ elif [[ ${lang} == "en-GB" ]]; then
+ rm "README_en_GB_thes.txt" || die
+ fi
+ fi
+ done
+
+ if [[ non_us_dic_used -eq 1 ]]; then
+ # This is used by every English variety, except for the en-US, see
+ # ./dictionaries.xcu, lines 60-70.
+ MYSPELL_HYPH+=( "hyph_en_GB.dic" )
+ else
+ rm "README_hyph_en_GB.txt" || die
+ fi
+
+ default
+}