summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-09-09 11:21:20 +0200
committerHans de Graaff <graaff@gentoo.org>2023-09-09 11:21:55 +0200
commitb063910c9335cc6982ee9b2ad1e290f23824b928 (patch)
tree021a7586db01f02504ce5288899d62bee8d3521f /app-crypt
parentdev-ruby/aws-partitions: add 1.820.0 (diff)
downloadgentoo-b063910c9335cc6982ee9b2ad1e290f23824b928.tar.gz
gentoo-b063910c9335cc6982ee9b2ad1e290f23824b928.tar.bz2
gentoo-b063910c9335cc6982ee9b2ad1e290f23824b928.zip
app-crypt/xca: install man page uncompressed
Closes: https://bugs.gentoo.org/913882 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/xca/files/xca-2.4.0-man-page.patch24
-rw-r--r--app-crypt/xca/xca-2.4.0_p20230526-r1.ebuild72
2 files changed, 96 insertions, 0 deletions
diff --git a/app-crypt/xca/files/xca-2.4.0-man-page.patch b/app-crypt/xca/files/xca-2.4.0-man-page.patch
new file mode 100644
index 000000000000..a5b52176418d
--- /dev/null
+++ b/app-crypt/xca/files/xca-2.4.0-man-page.patch
@@ -0,0 +1,24 @@
+--- a/doc/CMakeLists.txt 2023-09-09 11:10:22.671031619 +0200
++++ b/doc/CMakeLists.txt 2023-09-09 11:17:15.398798825 +0200
+@@ -138,7 +138,7 @@
+ if (NOT WIN32)
+ add_custom_command(
+- OUTPUT "${D}/xca.1.gz"
++ OUTPUT "${D}/xca.1"
+- COMMAND cat "${S}/xca.1.head" "${D}/xca.1.options" "${S}/xca.1.tail" | gzip -n9 > "${D}/xca.1.gz"
++ COMMAND cat "${S}/xca.1.head" "${D}/xca.1.options" "${S}/xca.1.tail" | cat > "${D}/xca.1"
+ DEPENDS "${S}/xca.1.head" "${S}/xca.1.tail"
+ "${D}/xca.1.options"
+ COMMENT "Compiling man page"
+@@ -148,9 +148,9 @@
+ COMMAND xcadoc man "${D}/xca.1.options"
+ COMMENT "Generate 'man' commandline documentation"
+ )
+- add_custom_target(manpage ALL DEPENDS ${D}/xca.1.gz)
++ add_custom_target(manpage ALL DEPENDS ${D}/xca.1)
+ if (NOT APPLE)
+- install(FILES "${D}/xca.1.gz"
++ install(FILES "${D}/xca.1"
+ DESTINATION ${CMAKE_INSTALL_MANDIR}/man1
+ )
+ endif()
diff --git a/app-crypt/xca/xca-2.4.0_p20230526-r1.ebuild b/app-crypt/xca/xca-2.4.0_p20230526-r1.ebuild
new file mode 100644
index 000000000000..2501dd9cbf58
--- /dev/null
+++ b/app-crypt/xca/xca-2.4.0_p20230526-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit cmake xdg-utils
+
+COMMIT=8983e5010d99c8d37bc7e316bf3ef00265763027
+
+DESCRIPTION="A GUI to OpenSSL, RSA public keys, certificates, signing requests etc"
+HOMEPAGE="https://hohnstaedt.de/xca/"
+#SRC_URI="https://github.com/chris2511/${PN}/releases/download/RELEASE.${PV}/${P}.tar.gz"
+SRC_URI="https://github.com/chris2511/xca/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/xca-${COMMIT}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc"
+
+RDEPEND="
+ dev-libs/libltdl:0=
+ dev-qt/qthelp:5
+ dev-qt/qtgui:5
+ dev-qt/qtsql:5[sqlite]
+ dev-qt/qtwidgets:5
+ dev-libs/openssl:*
+ doc? ( app-text/linuxdoc-tools )"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-qt/linguist-tools:5"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.0.0-desktop.patch"
+ "${FILESDIR}/${PN}-2.4.0-man-page.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DQTFIXEDVERSION=Qt5
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+}
+
+src_install() {
+ cmake_src_install
+
+ insinto /etc/xca
+ doins misc/*.txt
+
+ dosym xca /usr/bin/xca-console
+
+ ewarn "This is an unofficial snapshot that is compatible with openssl 3."
+ ewarn "One known flaw is that starting xca without a database will no longer open"
+ ewarn "the GUI. Provide either a new or existing database as an argument on the"
+ ewarn "command line."
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}