summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-20 07:34:39 +0100
committerSam James <sam@gentoo.org>2023-05-20 07:55:56 +0100
commiteaafd2ec6e20a199c2ef0077bdbd1b93c761f695 (patch)
tree6d08537c77578ba3fb6c87c2962004bfeb0540ca /app-crypt/sequoia-sqv
parentdev-python/podcastparser: Remove old (diff)
downloadgentoo-eaafd2ec6e20a199c2ef0077bdbd1b93c761f695.tar.gz
gentoo-eaafd2ec6e20a199c2ef0077bdbd1b93c761f695.tar.bz2
gentoo-eaafd2ec6e20a199c2ef0077bdbd1b93c761f695.zip
app-crypt/sequoia-sqv: use llvm.eclass for bindgen
Just like 1fd5803705bc3bc5ede5559d08b6e4c57a201fbf. Could bump the crates like gyakovlev said but we're about to do that for a bump anyway. Closes: https://bugs.gentoo.org/902127 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-crypt/sequoia-sqv')
-rw-r--r--app-crypt/sequoia-sqv/sequoia-sqv-1.1.0.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/app-crypt/sequoia-sqv/sequoia-sqv-1.1.0.ebuild b/app-crypt/sequoia-sqv/sequoia-sqv-1.1.0.ebuild
index 6d67fc76f141..9fe98046e2db 100644
--- a/app-crypt/sequoia-sqv/sequoia-sqv-1.1.0.ebuild
+++ b/app-crypt/sequoia-sqv/sequoia-sqv-1.1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2021-2022 Gentoo Authors
+# Copyright 2021-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -155,7 +155,10 @@ CRATES="
zeroize_derive-1.2.2
"
-inherit bash-completion-r1 cargo
+# TODO: Should be able to try 16 in next release after 1.1.0
+LLVM_MAX_SLOT=15
+
+inherit bash-completion-r1 cargo llvm
DESCRIPTION="A simple OpenPGP signature verification program"
HOMEPAGE="https://sequoia-pgp.org/ https://gitlab.com/sequoia-pgp/sequoia"
@@ -176,15 +179,20 @@ COMMON_DEPEND="
"
DEPEND="
- sys-devel/clang
${COMMON_DEPEND}
"
RDEPEND="${COMMON_DEPEND}"
+# Needed for bindgen
BDEPEND="
+ <sys-devel/clang-$((${LLVM_MAX_SLOT} + 1))
sys-apps/help2man
virtual/pkgconfig
"
+llvm_check_deps() {
+ has_version -b "sys-devel/clang:${LLVM_SLOT}"
+}
+
src_compile() {
# Setting CARGO_TARGET_DIR is required to have the build system
# create the bash and zsh completion files.