summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2019-07-23 17:20:48 +0200
committerManuel Rüger <mrueg@gentoo.org>2019-07-23 17:20:48 +0200
commit0a5304ca2078f648ee2b675098b447b4b1bf26a0 (patch)
treed326d9bb1cec965be24d55d75522f525b717755e /app-crypt/cfssl
parentapp-admin/dxf: Version bump to 7.5.1 (diff)
downloadgentoo-0a5304ca2078f648ee2b675098b447b4b1bf26a0.tar.gz
gentoo-0a5304ca2078f648ee2b675098b447b4b1bf26a0.tar.bz2
gentoo-0a5304ca2078f648ee2b675098b447b4b1bf26a0.zip
app-crypt/cfssl: Version bump to 1.3.4
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Manuel Rüger <mrueg@gentoo.org>
Diffstat (limited to 'app-crypt/cfssl')
-rw-r--r--app-crypt/cfssl/Manifest1
-rw-r--r--app-crypt/cfssl/cfssl-1.3.4.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/app-crypt/cfssl/Manifest b/app-crypt/cfssl/Manifest
index 026f19e5e181..b7af606c042e 100644
--- a/app-crypt/cfssl/Manifest
+++ b/app-crypt/cfssl/Manifest
@@ -1,2 +1,3 @@
DIST cfssl-1.3.2.tar.gz 6867118 BLAKE2B 775b3419ecf878d9add13faf03a3e1d4cca7b30d965f1ca55c8faa5abf679188a1ea1f80c1416f19c85bc551395628a31da8669ca647e1c1e7a1a313d68f4c7b SHA512 aba27a282c8ca8e95769996aea7e5300b0c3f8fea7ae26484d19a7e1a0330f0b3a0649407062f1a10e8c93136693954e3b24c92456f69db3abee509f982ba554
DIST cfssl-1.3.3.tar.gz 5005924 BLAKE2B 81e7ec1f27a6597d69f16254a5ded672b9b3ac0bc8dee0f5bb00939e86147b1ed0389d38ea406fe671f3de052ac2e88fe320ffbf6065a83c2d9627ac3c497740 SHA512 39b42f3f8c22e254fa8ed4079308ecad1b0f77cdb56e57099e434389866e58863687307d6cf0f5ec8e4664ad4743ee8728f47a6a1375f3f74f8206a709f0ffc3
+DIST cfssl-1.3.4.tar.gz 7092440 BLAKE2B 85a7a73ae5b18ae0e4ac02b1a4d5f633d73f2c0f81cb49ef85c39b6a241ac538220a8cebb448af795140a6308f46f6e53003f25a31edad452cb6db39ff95a9b2 SHA512 796f24f9a7cd9966b3586b5b08deb410570cc31ec747b0c834215c105df1b4fea4907bfa223d196ad71fb296724dc690b6ffd298c8ef81db1333ed3e69f1ecd4
diff --git a/app-crypt/cfssl/cfssl-1.3.4.ebuild b/app-crypt/cfssl/cfssl-1.3.4.ebuild
new file mode 100644
index 000000000000..64942d2fca9b
--- /dev/null
+++ b/app-crypt/cfssl/cfssl-1.3.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGO_PN="github.com/cloudflare/${PN}"
+inherit golang-build golang-vcs-snapshot
+
+SRC_URI="https://${EGO_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Cloudflare's PKI and TLS toolkit"
+HOMEPAGE="https://github.com/cloudflare/cfssl"
+LICENSE="BSD-2"
+SLOT="0"
+IUSE="hardened"
+
+RDEPEND="!!dev-lang/mono" #File collision (bug 614364)
+
+RESTRICT="test"
+
+src_compile() {
+ pushd src || die
+ CGO_LDFLAGS="$(usex hardened '-fno-PIC ' '')" GOPATH="${S}" go install -v github.com/cloudflare/cfssl/cmd/... || die
+ popd || die
+}
+
+src_install() {
+ dobin bin/*
+ pushd src/${EGO_PN} || die
+ dodoc CHANGELOG README.md
+ popd || die
+}