summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-crypt/bcwipe
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-crypt/bcwipe')
-rw-r--r--app-crypt/bcwipe/Manifest2
-rw-r--r--app-crypt/bcwipe/bcwipe-1.9.8.ebuild49
-rw-r--r--app-crypt/bcwipe/files/bcwipe-1.9.7-fix_warnings.patch20
-rw-r--r--app-crypt/bcwipe/files/bcwipe-1.9.8-fix-flags.patch11
-rw-r--r--app-crypt/bcwipe/metadata.xml5
5 files changed, 87 insertions, 0 deletions
diff --git a/app-crypt/bcwipe/Manifest b/app-crypt/bcwipe/Manifest
new file mode 100644
index 000000000000..49a47b5ab22b
--- /dev/null
+++ b/app-crypt/bcwipe/Manifest
@@ -0,0 +1,2 @@
+DIST BCWipe-1.9-8.tar.gz 131414 SHA256 6f5261716da15e3df07569ca2516334f7d132f0069420082fc71faf2aaf04fc0 SHA512 fe0b72b5279f8dc85c7ac2bee9c3b4ba13df542750faa25556b4a9a03eff323a5822e9e736440e4677c6aa6011a9ecf02acb51b7e934b30f4354826e798d7aa2 WHIRLPOOL 28fbf43435433a4858813329d474dd67e61af615616f9a3283e4b98b7bf9bdebd7ce84c1c787d4ba08a9f7f8ae53293c331cd2bcef3321c0de4ea932a570d618
+DIST BCWipe.doc.tgz 21218 SHA256 afa50bf8653bb6bee108f0ae8b3dc35d289dde3d5c513b7e9ae7fe373635df4f SHA512 5aa402669ded46b6dc680293f18aea4ab20a7d6b7d9d7bf8e63003e557b953e8f8019431ea69d96d2236121e754bc456b3700a0895f4fff0573d2e9bac2e2ee3 WHIRLPOOL 2f6475d9395d2424cbabb046085ce0a016ecad4e76f195e51fb385e57f68f13313587b52c2776ad29798b682eaa8503bae4186029b698a2405f08187180a904f
diff --git a/app-crypt/bcwipe/bcwipe-1.9.8.ebuild b/app-crypt/bcwipe/bcwipe-1.9.8.ebuild
new file mode 100644
index 000000000000..791fe6542845
--- /dev/null
+++ b/app-crypt/bcwipe/bcwipe-1.9.8.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit eutils versionator
+
+MY_PV="$(replace_version_separator 2 -)"
+
+DESCRIPTION="Secure file removal utility"
+HOMEPAGE="http://www.jetico.com/"
+SRC_URI="http://www.jetico.com/linux/BCWipe-${MY_PV}.tar.gz
+ doc? ( http://www.jetico.com/linux/BCWipe.doc.tgz )"
+
+LICENSE="bestcrypt"
+SLOT="0"
+IUSE="doc"
+KEYWORDS="amd64 ppc x86"
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.9.7-fix_warnings.patch \
+ "${FILESDIR}"/${P}-fix-flags.patch
+}
+
+src_test() {
+ echo "abc123" >> testfile
+ ./bcwipe -f testfile || die "bcwipe test failed"
+ [[ -f testfile ]] && die "test file still exists. bcwipe should have deleted it"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ if use doc ; then
+ dohtml -r ../bcwipe-help || die "dohtml failed"
+ fi
+}
+
+pkg_postinst() {
+ ewarn "The BestCrypt drivers are not free - Please purchace a license from "
+ ewarn "http://www.jetico.com/"
+ ewarn "full details /usr/share/doc/${PF}/html/bcwipe-help/wu_licen.htm"
+}
diff --git a/app-crypt/bcwipe/files/bcwipe-1.9.7-fix_warnings.patch b/app-crypt/bcwipe/files/bcwipe-1.9.7-fix_warnings.patch
new file mode 100644
index 000000000000..f24a6acdb600
--- /dev/null
+++ b/app-crypt/bcwipe/files/bcwipe-1.9.7-fix_warnings.patch
@@ -0,0 +1,20 @@
+--- schemes.c
++++ schemes.c
+@@ -15,6 +15,7 @@
+ *
+ *******************************************************************/
+ #include "config.h"
++#include <ctype.h>
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <errno.h>
+--- wipe.c
++++ wipe.c
+@@ -42,6 +42,7 @@
+ #include <sys/ioctl.h>
+ #include <signal.h>
+ #include <time.h>
++#include <sys/time.h>
+ #include <ctype.h>
+
+ #if HAVE_SYS_DISKIO_H /* HP-UX */
diff --git a/app-crypt/bcwipe/files/bcwipe-1.9.8-fix-flags.patch b/app-crypt/bcwipe/files/bcwipe-1.9.8-fix-flags.patch
new file mode 100644
index 000000000000..ac91518e0270
--- /dev/null
+++ b/app-crypt/bcwipe/files/bcwipe-1.9.8-fix-flags.patch
@@ -0,0 +1,11 @@
+--- Makefile.in 2011-02-23 01:07:29.841894634 +0100
++++ Makefile.in 2011-02-23 01:07:46.626793943 +0100
+@@ -174,7 +174,7 @@
+ bcwipe_SOURCES = wipe.c wipe.h options.c options.h schemes.c schemes.h sha1.c sha1.h sha1random.c sha1random.h log.c log.h standard.h rand.h rand.c prng.c
+ man_MANS = bcwipe.1
+ EXTRA_DIST = $(man_MANS) bcwipe.spec.in osxpkg.sh.in
+-AM_CFLAGS = -g -D_LARGE_FILES -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
++AM_CFLAGS = -D_LARGE_FILES -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
+ all: config.h
+ $(MAKE) $(AM_MAKEFLAGS) all-am
+
diff --git a/app-crypt/bcwipe/metadata.xml b/app-crypt/bcwipe/metadata.xml
new file mode 100644
index 000000000000..b02ffbb5d348
--- /dev/null
+++ b/app-crypt/bcwipe/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>crypto</herd>
+</pkgmetadata>