summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-04-04 23:59:22 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2018-04-04 23:59:22 -0500
commit2b5e0c95f6393acdf25683dea6ef7c797721cde3 (patch)
treeea467e2e0a15987df09d169c010eb1ea513a50f7 /app-crypt/acme
parentapp-crypt/certbot-nginx: 0.23.0 bup (diff)
downloadgentoo-2b5e0c95f6393acdf25683dea6ef7c797721cde3.tar.gz
gentoo-2b5e0c95f6393acdf25683dea6ef7c797721cde3.tar.bz2
gentoo-2b5e0c95f6393acdf25683dea6ef7c797721cde3.zip
app-crypt/{acme,certbot,certbot-apache,certbot-nginx}: 0.20.0 cleanup
Diffstat (limited to 'app-crypt/acme')
-rw-r--r--app-crypt/acme/acme-0.20.0.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/app-crypt/acme/acme-0.20.0.ebuild b/app-crypt/acme/acme-0.20.0.ebuild
deleted file mode 100644
index 91d9aa0f2d69..000000000000
--- a/app-crypt/acme/acme-0.20.0.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
-
-if [[ ${PV} == 9999* ]]; then
- EGIT_REPO_URI="https://github.com/certbot/certbot.git"
- inherit git-r3
- S=${WORKDIR}/${P}/${PN}
-else
- SRC_URI="https://github.com/certbot/certbot/archive/v${PV}.tar.gz -> certbot-${PV}.tar.gz"
- KEYWORDS="amd64 ~arm ~ppc64 x86"
- S=${WORKDIR}/certbot-${PV}/acme
-fi
-
-inherit distutils-r1
-
-DESCRIPTION="An implementation of the ACME protocol"
-HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="test"
-
-RDEPEND="
- >=dev-python/cryptography-0.8[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- >=dev-python/pyopenssl-0.13[${PYTHON_USEDEP}]
- dev-python/pyrfc3339[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- >=dev-python/requests-2.10[${PYTHON_USEDEP}]
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
- !dev-python/josepy[${PYTHON_USEDEP}]
-"
-DEPEND="
- test? (
- ${RDEPEND}
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )
- >=dev-python/setuptools-1.0[${PYTHON_USEDEP}]
-"
-
-python_test() {
- nosetests -w ${PN} || die
-}