summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2022-08-04 10:53:31 -0500
committerWilliam Hubbs <williamh@gentoo.org>2022-08-04 10:53:31 -0500
commitba94cff2df5c9ea3a55868d9670ab44b455e96da (patch)
treee832ca1f7db10a3338cda49557733a013118e208 /app-containers
parentapp-containers/buildah: add 1.26.4 (diff)
downloadgentoo-ba94cff2df5c9ea3a55868d9670ab44b455e96da.tar.gz
gentoo-ba94cff2df5c9ea3a55868d9670ab44b455e96da.tar.bz2
gentoo-ba94cff2df5c9ea3a55868d9670ab44b455e96da.zip
app-containers/grype: add 0.45.0
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/grype/Manifest2
-rw-r--r--app-containers/grype/grype-0.45.0.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/app-containers/grype/Manifest b/app-containers/grype/Manifest
index baf72cb23a92..7988e683c9d8 100644
--- a/app-containers/grype/Manifest
+++ b/app-containers/grype/Manifest
@@ -1,2 +1,4 @@
DIST grype-0.44.0-deps.tar.xz 641743984 BLAKE2B f30557d75628f84dff70ca4272555c7c3577bfe572c9ba16b0e78bc472732d5e82e734ed1ba4dfed59dbb86dc6a788d1379824e7b31bcdd148c5dff43f87e011 SHA512 de46c03f35f70353f0250b77364252316c48f70c1c4549f5d2a680062faee0305c7190906087e94d927333c4fae76de3c3b16046e3f3dc089013b66e132a2ff9
DIST grype-0.44.0.tar.gz 1071804 BLAKE2B 2334ec9b9c04dfc03dbd280725a55bb6cdcd4569431eeb94abe799c75be08ff5164446cba7e97e3dc0ed8dcc10ba4bc8f70edecf9766cdc63e91b3dd420de391 SHA512 7573d03c2e0cbabb6ae3a91ebaa65848a7b43fc3624416f6c52a001acf6cfc839bce806e8e914c29bc2d0fc1aadd9b568ffc21d5a60bd9c05905e0185d7bdcd3
+DIST grype-0.45.0-deps.tar.xz 644905072 BLAKE2B 5f1dd53106798b861ed90ed502406aa844fb99448fc8bf30dec3d32749db00c11106a16a93c2d92893cb2e8611b6dae7c63d9a5dfcc56b98fd373c3f8ddafc28 SHA512 31c343e898a880c91f7153e258e68d4c350484c9edcabb7b4a0df4d18a10b518b6878d04b5d96b8029855bf81f0b59fc052ee1cac3bcb27bdcfa334bdbe876ce
+DIST grype-0.45.0.tar.gz 1074637 BLAKE2B 4cfa86a0ad695971241c40f19f982f54654642ff31f7220583af3b3aa0c1d6ca56f613e96b7343c4cb32b567efeb81c2145c19f009183b3d7f23ddeb1f01e02d SHA512 0a899c420d3d6ed9e669a0d02b0d79f0c63d50288b31c44cbbe61a883d46b93bf98be263cd7859d392ee40b82754c8cbe9b284dec593f79c5906988b01369209
diff --git a/app-containers/grype/grype-0.45.0.ebuild b/app-containers/grype/grype-0.45.0.ebuild
new file mode 100644
index 000000000000..44c3442495f8
--- /dev/null
+++ b/app-containers/grype/grype-0.45.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+GIT_COMMIT=8fe761b41ffc280e58e82b7fbba4d0d1a05aeb91
+SYFT_VERSION=0.53.4
+
+DESCRIPTION="A vulnerability scanner for container images and filesystems"
+HOMEPAGE="https://www.anchore.com"
+SRC_URI="https://github.com/anchore/grype/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# tests require a running docker
+RESTRICT="test"
+
+src_compile() {
+ ego build -o bin/grype -ldflags "
+ -extldflags '-static'
+ -X github.com/anchore/grype/internal/version.version=${PV}
+ -X github.com/anchore/grype/internal/version.syftVersion=${SYFT_VERSION}
+ -X github.com/anchore/grype/internal/version.gitCommit=${GIT_COMMIT}
+ -X github.com/anchore/grype/internal/version.buildDate=${BUILD_DATE}
+ -X github.com/anchore/grype/internal/version.gitDescription=v${PV}"
+}
+
+src_install() {
+ dobin bin/grype
+}