summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-11-21 10:52:19 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-11-21 10:56:07 +0100
commitd217b9cb22f991af277e2366205b7531c853221a (patch)
tree758722dd55a8e699c2c1e0d50b1f3648b0455e31 /app-containers/distrobox/distrobox-1.6.0.1.ebuild
parentdev-util/cargo-c: add 0.9.28 (diff)
downloadgentoo-d217b9cb22f991af277e2366205b7531c853221a.tar.gz
gentoo-d217b9cb22f991af277e2366205b7531c853221a.tar.bz2
gentoo-d217b9cb22f991af277e2366205b7531c853221a.zip
app-containers/distrobox: bump to 1.6.0.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-containers/distrobox/distrobox-1.6.0.1.ebuild')
-rw-r--r--app-containers/distrobox/distrobox-1.6.0.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-containers/distrobox/distrobox-1.6.0.1.ebuild b/app-containers/distrobox/distrobox-1.6.0.1.ebuild
new file mode 100644
index 000000000000..cf9ea7ec09d5
--- /dev/null
+++ b/app-containers/distrobox/distrobox-1.6.0.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Use any Linux distribution inside your terminal (powered by docker/podman)"
+HOMEPAGE="https://distrobox.privatedns.org/
+ https://github.com/89luca89/distrobox/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/89luca89/${PN}.git"
+else
+ SRC_URI="https://github.com/89luca89/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-3" # GPL-3.0-only !
+SLOT="0"
+
+RDEPEND="
+ || (
+ app-containers/docker
+ app-containers/podman
+ )
+"
+
+src_install() {
+ sh ./install --prefix "${ED}"/usr || die "${PN} install script failed"
+ dodoc *.md
+}