summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2018-07-12 09:33:21 +0200
committerTony Vroon <chainsaw@gentoo.org>2018-07-12 10:14:44 +0100
commit99fccadfd8fca63cd671d9e21613bdcf0a268269 (patch)
treef1b88f4c28496748f064a92dc98887018e5879bd /app-benchmarks/sysbench
parentnet-misc/kea: Synced live ebuild. (diff)
downloadgentoo-99fccadfd8fca63cd671d9e21613bdcf0a268269.tar.gz
gentoo-99fccadfd8fca63cd671d9e21613bdcf0a268269.tar.bz2
gentoo-99fccadfd8fca63cd671d9e21613bdcf0a268269.zip
app-benchmarks/sysbench: bump to 1.0.15
Package-Manager: Portage-2.3.41, Repoman-2.3.9 Closes: https://github.com/gentoo/gentoo/pull/9195
Diffstat (limited to 'app-benchmarks/sysbench')
-rw-r--r--app-benchmarks/sysbench/Manifest1
-rw-r--r--app-benchmarks/sysbench/sysbench-1.0.15.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/app-benchmarks/sysbench/Manifest b/app-benchmarks/sysbench/Manifest
index f9ca44d49284..aabafc01867f 100644
--- a/app-benchmarks/sysbench/Manifest
+++ b/app-benchmarks/sysbench/Manifest
@@ -1,2 +1,3 @@
DIST sysbench-1.0.10.tar.gz 1496937 BLAKE2B d2cf3283a2e2cac89a54e51e975eecec4b5514c08b14fe81138dc36b077e82de54cb3c5d218e1cc00dc6bff66319d780c69249c49c93e810d3ebde3c0b36b656 SHA512 3e2c9597538c9b71a50a0fb0e198f8852206fc609b0968253ee6b12f652fd56f1b2c6e7a4c93161b725e5c56193f7ce9d5cf58c4882839a4c1055c539861d16d
DIST sysbench-1.0.14.tar.gz 1507008 BLAKE2B b2e5e53e65c4993b844f45cbf1dd648b8c67a4e00c6c7e713a032a15f5af7176d7fccf14120f1a485fe984e704386ec84d17391a9f7951584cc5072dcd153a45 SHA512 9030b1f40f6800d85ba4c7bf38041a509769983db4bce82b5cab097a5e4439e1ede5d8933f276779172537c961e6f670680bee106fcac3723ef99f361fdcc4f1
+DIST sysbench-1.0.15.tar.gz 1507930 BLAKE2B d4f18b08a122b8574b916b5ddadf69dd37718ac94642fb8d31582c79788569190a26fad3b3cccaadb695a65a3b9efda59943e32947a709918b3fb6d80aee6cac SHA512 ff68ad15c037006a2a49e3d59062611062336860205816ca6d9cdd20832fc55b631960411caa718dff881e926196046a7317b33e803061868e524a819569d3a2
diff --git a/app-benchmarks/sysbench/sysbench-1.0.15.ebuild b/app-benchmarks/sysbench/sysbench-1.0.15.ebuild
new file mode 100644
index 000000000000..58a949c87462
--- /dev/null
+++ b/app-benchmarks/sysbench/sysbench-1.0.15.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools pax-utils
+
+DESCRIPTION="System performance benchmark"
+HOMEPAGE="https://github.com/akopytov/sysbench"
+SRC_URI="https://github.com/akopytov/sysbench/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="aio mysql postgres test"
+
+RDEPEND="aio? ( dev-libs/libaio )
+ mysql? ( virtual/libmysqlclient )
+ postgres? ( dev-db/postgresql:= )
+ dev-lang/luajit:="
+DEPEND="${RDEPEND}
+ dev-libs/concurrencykit
+ dev-libs/libxslt
+ sys-devel/libtool
+ virtual/pkgconfig
+ test? ( dev-util/cram )"
+
+src_prepare() {
+ default
+
+ # remove bundled libs
+ rm -r third_party/luajit/luajit third_party/concurrency_kit/ck third_party/cram || die
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable aio)
+ $(use_with mysql)
+ $(use_with postgres pgsql)
+ --without-attachsql
+ --without-drizzle
+ --without-oracle
+ --with-system-luajit
+ --with-system-ck
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ emake check test
+}
+
+src_install() {
+ default
+
+ pax-mark m "${ED%/}"/usr/bin/${PN}
+}