summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrea Cerisara <andreacerisara@gmail.com>2020-04-24 08:46:01 +1000
committerJoonas Niilola <juippis@gentoo.org>2020-04-26 16:36:46 +0300
commitdf43d67e374b9da123f8074bb5dfe7c15c4f8d32 (patch)
tree2e3782df43f804746de5cfe535e7a183777bcf10 /app-benchmarks/siege/siege-4.0.5.ebuild
parentmedia-gfx/yafaray: drop old 3.3.0 (diff)
downloadgentoo-df43d67e374b9da123f8074bb5dfe7c15c4f8d32.tar.gz
gentoo-df43d67e374b9da123f8074bb5dfe7c15c4f8d32.tar.bz2
gentoo-df43d67e374b9da123f8074bb5dfe7c15c4f8d32.zip
app-benchmarks/siege: version bump to 4.0.5
- update header and eapi - update license Bug: https://bugs.gentoo.org/717588 Signed-off-by: Andrea Cerisara <andreacerisara@gmail.com> Package-Manager: Portage-2.3.89, Repoman-2.3.20 Closes: https://github.com/gentoo/gentoo/pull/15494 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-benchmarks/siege/siege-4.0.5.ebuild')
-rw-r--r--app-benchmarks/siege/siege-4.0.5.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/app-benchmarks/siege/siege-4.0.5.ebuild b/app-benchmarks/siege/siege-4.0.5.ebuild
new file mode 100644
index 000000000000..d5508aa06bf7
--- /dev/null
+++ b/app-benchmarks/siege/siege-4.0.5.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools bash-completion-r1
+
+DESCRIPTION="A HTTP regression testing and benchmarking utility"
+HOMEPAGE="https://www.joedog.org/siege-home https://github.com/JoeDog/siege"
+SRC_URI="http://download.joedog.org/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~x86 ~x64-macos"
+SLOT="0"
+IUSE="libressl ssl"
+
+RDEPEND="ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )"
+DEPEND="${RDEPEND}
+ sys-devel/libtool"
+
+src_prepare() {
+ default
+ # bundled macros break recent libtool
+ sed -i -e '/AC_PROG_SHELL/d' configure.ac || die
+ rm *.m4 || die "failed to remove bundled macros"
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ $(use_with ssl ssl "${EPREFIX}/usr")
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc AUTHORS ChangeLog INSTALL README* doc/siegerc doc/urls.txt
+
+ newbashcomp "${FILESDIR}"/${PN}.bash-completion ${PN}
+}
+
+pkg_postinst() {
+ elog "An example ~/.siegerc file has been installed in"
+ elog "${EPREFIX}/usr/share/doc/${PF}/"
+}