summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@gentoo.org>2024-11-25 23:02:42 +0100
committerPetr Vaněk <arkamar@gentoo.org>2024-11-25 23:05:49 +0100
commite7aead42deee0881b045adf7c243b6ef7089ee06 (patch)
tree982e7a7968b69b2a00010cd4e20a5d7064c72ea1 /app-backup
parentsci-libs/gdal: Stabilize 3.9.1 ppc64, #944739 (diff)
downloadgentoo-e7aead42deee0881b045adf7c243b6ef7089ee06.tar.gz
gentoo-e7aead42deee0881b045adf7c243b6ef7089ee06.tar.bz2
gentoo-e7aead42deee0881b045adf7c243b6ef7089ee06.zip
app-backup/borgmatic: add 1.9.3
Signed-off-by: Petr Vaněk <arkamar@gentoo.org>
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/borgmatic/Manifest1
-rw-r--r--app-backup/borgmatic/borgmatic-1.9.3.ebuild85
-rw-r--r--app-backup/borgmatic/files/borgmatic-1.9.3-no_test_coverage.patch18
3 files changed, 104 insertions, 0 deletions
diff --git a/app-backup/borgmatic/Manifest b/app-backup/borgmatic/Manifest
index 2e4502ca9140..9f0ba9a03326 100644
--- a/app-backup/borgmatic/Manifest
+++ b/app-backup/borgmatic/Manifest
@@ -2,3 +2,4 @@ DIST borgmatic-1.8.14.tar.gz 623966 BLAKE2B fd52bc5be4f63e1207a0bedcf654af075082
DIST borgmatic-1.9.0.tar.gz 636235 BLAKE2B ff71f8c811ca185926369402de5f2b1bd750135fcc66d54744056292994b781fba501945cf5dc39cc727d2c8f2ef360e79b4f2ba7a868f29bf0304722cae9649 SHA512 767b11451377d9ab046fe36272d523f1ec7c72fe162cc3eef09583f4e9a6e0d4bae09bb446b746a47e73fb4afdac1d0206b75b93a9fb2859987909f17aa87c43
DIST borgmatic-1.9.1.tar.gz 636657 BLAKE2B 6061b49d501be28afe7a3a6ac928ec77233bb354e494e14584c1cdeb76e5c06cb9fe06e97f0eb0be4a5aa03c7f0359ce47a7b45044e95358b80ab0986ed5d9b8 SHA512 c86fd5a0d1db065df8e0f4366e2742be798e225cd3af2baea86e27f165cd9956f059f5d51f85f49715c40db51e7aca93a64f5a8fcefceec316a588560875ce69
DIST borgmatic-1.9.2.tar.gz 641879 BLAKE2B 0c1678c905235ee435fdeb7fc57eabb44054344fab596ecb17f5cbeb0a2afa944b3105b08c61547de853de561c58971a6d32ac677434475b38cc90af4600b88d SHA512 8226155f049141b80bed32f955faa37cd8d2c01489092510440c1f53247d1aabf7d8730aa8c22b20f16ffb5686b158966a544e2bea4558178ec52da187b18c13
+DIST borgmatic-1.9.3.tar.gz 645018 BLAKE2B ae069bece54d80eab080cb30d4fb4b523cc7f31ca5d434a7f2fdfc8447ab72e6687fc6775a7811e15f120a0ad57284c539813c07b5cb258a2acf92e02dd55999 SHA512 22624e1a4454660288a3019513509006b389aafd657a45fa9e24c0b13b6a1266450c5b4ed531be5d8574c5f5fa5b869cb6860273f5d3d9a53b4e41474fb1b90e
diff --git a/app-backup/borgmatic/borgmatic-1.9.3.ebuild b/app-backup/borgmatic/borgmatic-1.9.3.ebuild
new file mode 100644
index 000000000000..c8ac8622d33f
--- /dev/null
+++ b/app-backup/borgmatic/borgmatic-1.9.3.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 systemd pypi
+
+DESCRIPTION="Automatically create, prune and verify backups with borgbackup"
+HOMEPAGE="
+ https://torsion.org/borgmatic/
+ https://projects.torsion.org/borgmatic-collective/borgmatic
+"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv"
+IUSE="apprise"
+
+# borg is called as an external tool, hence no pythonic stuff
+RDEPEND="
+ app-backup/borgbackup
+ $(python_gen_cond_dep '
+ <dev-python/colorama-0.5[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ ')
+ apprise? ( $(python_gen_cond_dep '
+ dev-python/apprise[${PYTHON_USEDEP}]
+ ') )
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ $(python_gen_cond_dep '
+ dev-python/apprise[${PYTHON_USEDEP}]
+ >=dev-python/flexmock-0.10.10[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.7.14-systemd_service_bin_path.patch
+ "${FILESDIR}"/${PN}-1.9.3-no_test_coverage.patch
+)
+
+EPYTEST_DESELECT=(
+ # A fragile test whose only purpose is to make sure the NEWS file
+ # has been updated for the current version.
+ tests/integration/commands/test_borgmatic.py::test_borgmatic_version_matches_news_version
+)
+
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+ systemd_dounit sample/systemd/borgmatic.{service,timer}
+ keepdir /etc/borgmatic
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "To generate a sample configuration file, run:"
+ elog " ${PN} config generate"
+ elog
+ elog "Systemd users wishing to periodically run ${PN} can use the provided timer and service units."
+ else
+ local oldver
+ for oldver in ${REPLACING_VERSIONS}; do
+ if ver_test "${oldver}" -lt 1.9.0; then
+ ewarn "Please be warned that ${PN}-1.9.0 has introduced several breaking changes."
+ ewarn "For details, please see"
+ ewarn
+ ewarn " https://github.com/borgmatic-collective/borgmatic/releases/tag/1.9.0"
+ ewarn
+ break
+ fi
+ done
+ fi
+}
diff --git a/app-backup/borgmatic/files/borgmatic-1.9.3-no_test_coverage.patch b/app-backup/borgmatic/files/borgmatic-1.9.3-no_test_coverage.patch
new file mode 100644
index 000000000000..0c452651c455
--- /dev/null
+++ b/app-backup/borgmatic/files/borgmatic-1.9.3-no_test_coverage.patch
@@ -0,0 +1,18 @@
+no test coverage
+
+diff --git a/pyproject.toml b/pyproject.toml
+index d081573f..d209c27a 100644
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -49,7 +49,7 @@ skip-string-normalization = true
+
+ [tool.pytest.ini_options]
+ testpaths = "tests"
+-addopts = "--cov-report term-missing:skip-covered --cov=borgmatic --no-cov-on-fail --cov-fail-under=100 --ignore=tests/end-to-end"
++addopts = "--ignore=tests/end-to-end"
+
+ [tool.isort]
+ profile = "black"
+--
+2.45.2
+