summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-backup/boxbackup
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-backup/boxbackup')
-rw-r--r--app-backup/boxbackup/Manifest1
-rw-r--r--app-backup/boxbackup/boxbackup-0.11.1.ebuild75
-rw-r--r--app-backup/boxbackup/files/bbackupd.rc21
-rw-r--r--app-backup/boxbackup/files/bbstored.rc21
-rw-r--r--app-backup/boxbackup/files/boxbackup-0.11_rc8-testbbackupd.patch11
-rw-r--r--app-backup/boxbackup/metadata.xml11
6 files changed, 140 insertions, 0 deletions
diff --git a/app-backup/boxbackup/Manifest b/app-backup/boxbackup/Manifest
new file mode 100644
index 000000000000..6870363bd54c
--- /dev/null
+++ b/app-backup/boxbackup/Manifest
@@ -0,0 +1 @@
+DIST boxbackup-0.11.1.tgz 1863270 SHA256 1328b010477259c4767276dbfebab6580e883336cc9d25696c39991b09cc6d32 SHA512 15ceceae3659f14254f422136805a8b3ed3c39d14f8a1ffd0c96efb05b7acb5be310e13144ed86fe4afd24a3c0b86ec771b7d3a9f08b2789bb98e18468ca97f8 WHIRLPOOL 9abcae4e907d526e6df0ebfee813cd374e8f981e5f25e0a2cbc2e958e0bf4d0ce10a455d71e036dc13aa31c01c422349cdbb1f1a36a0ea8ae16cf2b14f0f97fc
diff --git a/app-backup/boxbackup/boxbackup-0.11.1.ebuild b/app-backup/boxbackup/boxbackup-0.11.1.ebuild
new file mode 100644
index 000000000000..55bf9cb51035
--- /dev/null
+++ b/app-backup/boxbackup/boxbackup-0.11.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils user
+
+DESCRIPTION="A completely automatic on-line backup system"
+HOMEPAGE="http://boxbackup.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+SRC_URI="http://boxbackup.org/svn/box/packages/${P/_/}.tgz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86 ~ppc-macos ~x86-macos"
+IUSE="client-only"
+DEPEND="sys-libs/zlib
+ sys-libs/db
+ >=dev-libs/openssl-0.9.7
+ >=dev-lang/perl-5.6"
+RDEPEND="${DEPEND}
+ virtual/mta"
+
+S="${WORKDIR}/${P/_/}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.11_rc8-testbbackupd.patch
+}
+
+src_compile() {
+ # bug #299411
+ emake -j1 || die
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die "install failed"
+ emake -j1 DESTDIR="${D}" install-backup-client || die "client install failed"
+ use client-only || \
+ emake -j1 DESTDIR="${D}" install-backup-server || die "server install failed"
+
+ dodoc *.txt
+ newinitd "${FILESDIR}"/bbackupd.rc bbackupd
+ use client-only || \
+ newinitd "${FILESDIR}"/bbstored.rc bbstored
+
+ keepdir /etc/boxbackup
+
+ # apparently new versions have the files in the right location, so this is redundant
+ # move executables from /usr/bin to /usr/sbin, as configuration of
+ # this is unfortunately not optimal
+ #mv "${D%/}${EPREFIX}/usr/bin" "${D%/}${EPREFIX}/usr/sbin" || die "could not move files from bin to sbin"
+}
+
+pkg_preinst() {
+ if ! use client-only;
+ then
+ enewgroup bbstored
+ enewuser bbstored -1 -1 -1 bbstored
+ fi
+}
+
+pkg_postinst() {
+ while read line; do elog "${line}"; done <<EOF
+After configuring the Box Backup client and/or server, you can start
+the daemon using the init scripts /etc/init.d/bbackupd and
+/etc/init.d/bbstored.
+The configuration files can be found in /etc/boxbackup
+
+More information about configuring the client can be found at
+${HOMEPAGE}client.html,
+and more information about configuring the server can be found at
+${HOMEPAGE}server.html.
+EOF
+ echo
+}
diff --git a/app-backup/boxbackup/files/bbackupd.rc b/app-backup/boxbackup/files/bbackupd.rc
new file mode 100644
index 000000000000..a1a9ae2de771
--- /dev/null
+++ b/app-backup/boxbackup/files/bbackupd.rc
@@ -0,0 +1,21 @@
+#!/sbin/runscript
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need localmount
+ use net
+}
+
+start() {
+ ebegin "Starting box backup daemon"
+ start-stop-daemon --start --exec /usr/sbin/bbackupd > /dev/null
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping box backup daemon"
+ start-stop-daemon --stop --exec /usr/sbin/bbackupd
+ eend $?
+}
diff --git a/app-backup/boxbackup/files/bbstored.rc b/app-backup/boxbackup/files/bbstored.rc
new file mode 100644
index 000000000000..8d54fdb5f72e
--- /dev/null
+++ b/app-backup/boxbackup/files/bbstored.rc
@@ -0,0 +1,21 @@
+#!/sbin/runscript
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need localmount
+ use net
+}
+
+start() {
+ ebegin "Starting box backup store daemon"
+ start-stop-daemon --start --exec /usr/sbin/bbstored > /dev/null
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping box backup store daemon"
+ start-stop-daemon --stop --exec /usr/sbin/bbstored
+ eend $?
+}
diff --git a/app-backup/boxbackup/files/boxbackup-0.11_rc8-testbbackupd.patch b/app-backup/boxbackup/files/boxbackup-0.11_rc8-testbbackupd.patch
new file mode 100644
index 000000000000..12a6825cc759
--- /dev/null
+++ b/app-backup/boxbackup/files/boxbackup-0.11_rc8-testbbackupd.patch
@@ -0,0 +1,11 @@
+--- a/test/bbackupd/testbbackupd.cpp 2010-05-01 15:52:27.000000000 +0200
++++ b/test/bbackupd/testbbackupd.cpp 2010-05-07 07:12:42.000000000 +0200
+@@ -1176,7 +1176,7 @@
+ std::string touchfile =
+ "testfiles/TestDir1/spacetest/d1/touch-me";
+
+- fd = open(touchfile.c_str(), O_CREAT | O_WRONLY);
++ fd = open(touchfile.c_str(), O_CREAT | O_WRONLY, 700);
+ TEST_THAT(fd > 0);
+ // write again, to update the file's timestamp
+ TEST_EQUAL_LINE(sizeof(buffer),
diff --git a/app-backup/boxbackup/metadata.xml b/app-backup/boxbackup/metadata.xml
new file mode 100644
index 000000000000..939fd5533c18
--- /dev/null
+++ b/app-backup/boxbackup/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>app-backup</herd>
+ <longdescription>An open source, completely automatic on-line backup
+ system for UNIX.</longdescription>
+ <use>
+ <flag name='client-only'>Disable server support, and just build a
+ client</flag>
+ </use>
+</pkgmetadata>