summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <ajak@gentoo.org>2022-04-21 13:27:29 -0500
committerJohn Helmert III <ajak@gentoo.org>2022-04-21 13:33:08 -0500
commitf83e6a22fd22d7e48de60102be33d1419c8a1732 (patch)
tree7099d5ff87e7430d003a187f6deab7946a37e11e /app-antivirus
parentdev-lang/python: Stabilize 2.7.18_p15 arm, #839942 (diff)
downloadgentoo-f83e6a22fd22d7e48de60102be33d1419c8a1732.tar.gz
gentoo-f83e6a22fd22d7e48de60102be33d1419c8a1732.tar.bz2
gentoo-f83e6a22fd22d7e48de60102be33d1419c8a1732.zip
app-antivirus/lkrg: add 0.9.3
Signed-off-by: John Helmert III <ajak@gentoo.org>
Diffstat (limited to 'app-antivirus')
-rw-r--r--app-antivirus/lkrg/Manifest2
-rw-r--r--app-antivirus/lkrg/lkrg-0.9.3.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/app-antivirus/lkrg/Manifest b/app-antivirus/lkrg/Manifest
index 23ac54a2e6e6..e8b582565d8d 100644
--- a/app-antivirus/lkrg/Manifest
+++ b/app-antivirus/lkrg/Manifest
@@ -1,2 +1,4 @@
DIST lkrg-0.9.2.tar.gz 125976 BLAKE2B c3da2d4599c9dd5b7d6fbec426fd93d802715f6c8566471f82c8f1c7d31621ebb4a2cc4c285d076aad6a6ee6b1bb790debbb365cfc6220192df049ac1d3c67a9 SHA512 5fec807618817bcb516e1a6779def6979badbdac6fe9b38fcce8425a0c7ebe3fb55c05d3080d8cac2d67cac6e8b7d2d77b3a1be450227299e2a02a311e223331
DIST lkrg-0.9.2.tar.gz.sign 801 BLAKE2B 0cd8b18c8a0fbcca61ffa868b406d048461ddf9189fb08f15faa45e01b8731906a6b14105dfcf92bb5124373860f6695594063ee8d138c94c70adf471bc15e0a SHA512 18b547ca84a7fd2957484857e17983408e92fd005d58b77b399c5156ecb09fc5e9e6c910337654a2655883d103098c1769b1993017eec753bd21e63d6491ad04
+DIST lkrg-0.9.3.tar.gz 127986 BLAKE2B 5d059247c9a8a5abe4795d22b3806544dbb4c332947012ec33ceace27747663375acf68a4e859fae293eead5f7d9540b4261d3fef149d1e5c6ee8714a2df28d6 SHA512 9b441b93ff28b733afc513643a5d843c1707ac5a05adb359a3142b9ca7cba6a4790ebca4f9e6ca88a6ddf61f2b06aa242e02f288e9295e74999ed534794fb45d
+DIST lkrg-0.9.3.tar.gz.sign 801 BLAKE2B c054522f281d09a008821f92c7b43b5384241100c68ef0b0ea7171b8c492772a5d668b425089e1aac990bf6a675215dd5861f3f2598995e31a8db82a8b2ec7e9 SHA512 87c2bfe8d342b85f3c6c8226be5b698527a507369603a03eefead89ea8635b5ba95f3cbbe1d84cd77ac42bb8a773a7133917e0c87132b4851ff4017f77bc683a
diff --git a/app-antivirus/lkrg/lkrg-0.9.3.ebuild b/app-antivirus/lkrg/lkrg-0.9.3.ebuild
new file mode 100644
index 000000000000..92ead47afb71
--- /dev/null
+++ b/app-antivirus/lkrg/lkrg-0.9.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-mod linux-info verify-sig
+
+DESCRIPTION="Linux Kernel Runtime Guard"
+HOMEPAGE="https://lkrg.org"
+SRC_URI="https://lkrg.org/download/${P}.tar.gz
+ verify-sig? ( https://lkrg.org/download/${P}.tar.gz.sign )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="verify-sig? ( sec-keys/openpgp-keys-openwall )"
+
+MODULE_NAMES="p_lkrg(misc:${S}:${S})"
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}/usr/share/openpgp-keys/openwall.asc"
+
+pkg_setup() {
+ CONFIG_CHECK="HAVE_KRETPROBES KALLSYMS_ALL KPROBES JUMP_LABEL"
+ CONFIG_CHECK+=" MODULE_UNLOAD !PREEMPT_RT ~STACKTRACE"
+ linux-mod_pkg_setup
+
+ # compile against selected (not running) target
+ BUILD_PARAMS="P_KVER=${KV_FULL} P_KERNEL=${KERNEL_DIR}"
+ BUILD_TARGETS="all"
+}
+
+src_unpack() {
+ if use verify-sig; then
+ verify-sig_verify_detached ${DISTDIR}/${P}.tar.gz{,.sign}
+ fi
+
+ default
+}