summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2024-11-15 16:29:17 +0100
committerAgostino Sarubbo <ago@gentoo.org>2024-11-15 16:29:17 +0100
commitce8b82b7aa0417d63a675591a6f575e5e011362e (patch)
treecfb32b3cc672f754cb3e470b87631c2f7687c984 /app-admin
parentapp-admin/hcloud: remove old (diff)
downloadgentoo-ce8b82b7aa0417d63a675591a6f575e5e011362e.tar.gz
gentoo-ce8b82b7aa0417d63a675591a6f575e5e011362e.tar.bz2
gentoo-ce8b82b7aa0417d63a675591a6f575e5e011362e.zip
app-admin/exo: add 1.81.0
Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/exo/Manifest1
-rw-r--r--app-admin/exo/exo-1.81.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/app-admin/exo/Manifest b/app-admin/exo/Manifest
index 846db63654ec..c851d2caa36a 100644
--- a/app-admin/exo/Manifest
+++ b/app-admin/exo/Manifest
@@ -1 +1,2 @@
DIST exo-1.80.0.gh.tar.gz 11144829 BLAKE2B 9ce60c9039129d651e3da9d707e5c4b34e751d46e928778fbf9b884fb5ba366dda1ff10f748a0c8c5e0461c7a0229b5cb6ee497a383820c68859a93c1d76f555 SHA512 e2dbf97704e5ee5e38b70216f0ea071446e29573ff16d34f75bfd4e51eb3d9c65b761d8d1299a750c5906043b2a09d463ca811da1816b7fe74382aaf942ccdb9
+DIST exo-1.81.0.gh.tar.gz 11143610 BLAKE2B aa4830b4e799705cff11ad99bcc8bb422f488772d688bd132bc746d50293e9446e799920149582b29f14910a3167b58de4d3f0f5dc042369f4e8b66757fc43a3 SHA512 8f1dbda8439852d4e92cb6668097a69cf8581fec5bb115a859428b8825483df61872180ef389faa115eb1986eb25932cececeae85bfcbddca2e617135534a481
diff --git a/app-admin/exo/exo-1.81.0.ebuild b/app-admin/exo/exo-1.81.0.ebuild
new file mode 100644
index 000000000000..43fbacd8aa32
--- /dev/null
+++ b/app-admin/exo/exo-1.81.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Command-line tool for everything at Exoscale: compute, storage, dns"
+HOMEPAGE="https://github.com/exoscale/cli"
+SRC_URI="https://github.com/exoscale/cli/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/cli-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND=">=dev-lang/go-1.16:="
+RESTRICT="strip"
+
+src_compile() {
+ ego build -mod vendor -o ${PN} -ldflags "-X main.version=${PVR}-gentoo -X main.commit="
+}
+
+src_test() {
+ # run at least 'exo version' for test
+ ./exo version > /dev/null 2>&1
+ if [[ $? -ne 0 ]]
+ then
+ die "Test failed"
+ fi
+}
+
+src_install() {
+ dobin ${PN}
+}