summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-11-19 13:35:06 +0000
committerSam James <sam@gentoo.org>2024-11-19 13:35:06 +0000
commita5b31a181b15422246e0197e0a828157b52b7a99 (patch)
tree507fad69169300ac79b08af5cbbf8f3db581b3d7 /app-admin
parentapp-i18n/skkfep: use -std=gnu89 (diff)
downloadgentoo-a5b31a181b15422246e0197e0a828157b52b7a99.tar.gz
gentoo-a5b31a181b15422246e0197e0a828157b52b7a99.tar.bz2
gentoo-a5b31a181b15422246e0197e0a828157b52b7a99.zip
app-admin/radmind: build w/ -std=gnu89
Relies on lots of K&R decls. Closes: https://bugs.gentoo.org/880375 Closes: https://bugs.gentoo.org/881967 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/radmind/radmind-1.15.4-r1.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/app-admin/radmind/radmind-1.15.4-r1.ebuild b/app-admin/radmind/radmind-1.15.4-r1.ebuild
index 99ad31c192c5..a767b962fde3 100644
--- a/app-admin/radmind/radmind-1.15.4-r1.ebuild
+++ b/app-admin/radmind/radmind-1.15.4-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit autotools
+inherit autotools flag-o-matic
DESCRIPTION="Command-line tools and server to remotely administer multiple Unix filesystems"
HOMEPAGE="https://github.com/Radmind https://sourceforge.net/projects/radmind/"
@@ -43,6 +43,9 @@ src_prepare() {
}
src_configure() {
+ # bug #880375
+ append-flags -std=gnu89
+
local myconf=(
$(use_enable pam)
$(use_enable zlib)