summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn M. Harris Jr. <johnmh@johnmh.me>2024-10-31 21:32:33 -0700
committerSam James <sam@gentoo.org>2024-11-11 08:37:47 +0000
commit7f419975d4bc3635db3d73fd489a657c00840dbb (patch)
treead04a4a1d6a299f21636e4d58c260c83d9e52dc3 /app-admin
parentmedia-sound/abcmidi: Stabilize 2024.10.10 amd64, #943219 (diff)
downloadgentoo-7f419975d4bc3635db3d73fd489a657c00840dbb.tar.gz
gentoo-7f419975d4bc3635db3d73fd489a657c00840dbb.tar.bz2
gentoo-7f419975d4bc3635db3d73fd489a657c00840dbb.zip
app-admin/ansible-lint: add 24.9.2
Signed-off-by: John M. Harris Jr. <johnmh@johnmh.me> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/ansible-lint/Manifest1
-rw-r--r--app-admin/ansible-lint/ansible-lint-24.9.2.ebuild62
-rw-r--r--app-admin/ansible-lint/files/ansible-lint-24.7.0-warnings.patch22
3 files changed, 85 insertions, 0 deletions
diff --git a/app-admin/ansible-lint/Manifest b/app-admin/ansible-lint/Manifest
index 3d8b190d5d1b..af3a6d8fc95d 100644
--- a/app-admin/ansible-lint/Manifest
+++ b/app-admin/ansible-lint/Manifest
@@ -1,3 +1,4 @@
DIST ansible-lint-24.2.2.tar.gz 515822 BLAKE2B e9d8e689dfe4e4efbd4dad44ff3567f50412400ed979f2d60150f09f17c5f63f2441f25a33ecdf0112024ced07e62ac16b8a2dbc1c01d62855ec785fc75d1b9a SHA512 3de6b14e4b64ba577abcb67920a45dbf45fedb84e21091cd6a29e3c52a7a91555a152ee3e265624aafbf9dddba96d04241c2598a18f2103ce2cae48706142446
DIST ansible_lint-24.6.0.tar.gz 529088 BLAKE2B 3d307669d2035eb5a3a8295b40e3afca92ca4eae4ea419948fd2fa86127e05c60f3ca037a4b85b447320ba8a57f7e1a736a55d63aac80e386f9fc4d733190b09 SHA512 1eb8e3e1805ff98ae76ddcd873a5e90b0b0182fbbce3c40844b2a9069e6879fef906e14f98dd77e41372e461ea4350388b68e08be420afaf5d6c449a449a7989
DIST ansible_lint-24.7.0.tar.gz 530977 BLAKE2B bc6b98b2372dc58bedc8fc305ebad72e75bddf980906789f51f8dde9eda9b2f51ad3397b8dc2bb5712c1abbf61d08a1a6ab5c1468d6ae10404846f952e2fc078 SHA512 1ba69c7fd2c29f89cc2526ad14ea6a7aff4a0715d3dddf0abc79d6dae9bc5ad02152bdece635684a0d1a805a816ea2f28b2a07c5570975bb73bfa332e8679109
+DIST ansible_lint-24.9.2.tar.gz 536244 BLAKE2B db7195d569698a2c5d43b0b0293dc2fa97cf3f5de8807b95e43f991b12432cdaedaa0b4a7165cd7af5a67142062eaa981ccb642888153d97296ae4125fe4019d SHA512 ae570ae86e31b83ab89e1b4c7f0996165ecb40299a8374fd5baac4ff955aa17f0a05542a7d14683e43e680fc6e55acb862589fa48b86b82a11dc31bf6a0d6aab
diff --git a/app-admin/ansible-lint/ansible-lint-24.9.2.ebuild b/app-admin/ansible-lint/ansible-lint-24.9.2.ebuild
new file mode 100644
index 000000000000..5f2a99479951
--- /dev/null
+++ b/app-admin/ansible-lint/ansible-lint-24.9.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Checks ansible playbooks for practices and behaviour that can be improved"
+HOMEPAGE="https://github.com/ansible/ansible-lint"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+# Upstream has stated explicitly that all tests require Internet access
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND="
+ >=app-admin/ansible-core-2.13.0[${PYTHON_USEDEP}]
+ >=dev-python/ansible-compat-24.9.1[${PYTHON_USEDEP}]
+ >=dev-python/black-24.3.0[${PYTHON_USEDEP}]
+ >=dev-python/filelock-3.8.0[${PYTHON_USEDEP}]
+ dev-python/importlib-metadata[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.17.0[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/pathspec-0.10.3[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.4.1[${PYTHON_USEDEP}]
+ >=dev-python/rich-12.0.0[${PYTHON_USEDEP}]
+ >=dev-python/ruamel-yaml-0.18.5[${PYTHON_USEDEP}]
+ >=dev-python/wcmatch-8.5.0[${PYTHON_USEDEP}]
+ >=dev-util/yamllint-1.30.0[${PYTHON_USEDEP}]
+ dev-vcs/git"
+BDEPEND="
+ >=dev-python/setuptools-scm-7.0.5[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mypy[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ >=dev-python/pytest-plus-0.6[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-2.5.0[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-24.7.0-warnings.patch
+)
+
+# test_call_from_outside_venv doesn't play nicely with the sandbox
+# irrespective of whether Internet access is allowed or not
+EPYTEST_DESELECT=(
+ test/test_main.py::test_call_from_outside_venv
+)
+
+distutils_enable_tests pytest
+
+# Test suite fails to start without this
+python_test() {
+ epytest test
+}
diff --git a/app-admin/ansible-lint/files/ansible-lint-24.7.0-warnings.patch b/app-admin/ansible-lint/files/ansible-lint-24.7.0-warnings.patch
new file mode 100644
index 000000000000..6386bfe010c9
--- /dev/null
+++ b/app-admin/ansible-lint/files/ansible-lint-24.7.0-warnings.patch
@@ -0,0 +1,22 @@
+Author: John M. Harris Jr. <johnmh@johnmh.me>
+Date: Mon Nov 11 00:26:19 2024 -0700
+
+Remove unnecessary warning
+
+On Gentoo systems, this check normally throws unnecessary warnings.
+Assume we're using system-provided ansible when the path begins with
+"/usr/lib/python-exec/python3."
+
+diff --git a/src/ansiblelint/__main__.py b/src/ansiblelint/__main__.py
+index ca4a33b6..c2dd3cef 100755
+--- a/src/ansiblelint/__main__.py
++++ b/src/ansiblelint/__main__.py
+@@ -461,7 +461,7 @@ def path_inject(own_location: str = "") -> None:
+ if own_location:
+ own_location = os.path.realpath(own_location)
+ parent = Path(own_location).parent
+- if (parent / "ansible").exists() and str(parent) not in paths:
++ if not str(parent).startswith("/usr/lib/python-exec/python3.") and (parent / "ansible").exists() and str(parent) not in paths:
+ inject_paths.append(str(parent))
+
+ if not os.environ.get("PYENV_VIRTUAL_ENV", None):