summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-09 07:25:12 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-09 07:56:19 +0100
commit5544d5acbbcbd2fb3953be603baac3651bc8cbff (patch)
tree6195145dd31ad117024e45657e14783757459ecc /app-admin
parentdev-python/boto3: Bump to 1.35.57 (diff)
downloadgentoo-5544d5acbbcbd2fb3953be603baac3651bc8cbff.tar.gz
gentoo-5544d5acbbcbd2fb3953be603baac3651bc8cbff.tar.bz2
gentoo-5544d5acbbcbd2fb3953be603baac3651bc8cbff.zip
app-admin/awscli: Bump to 1.35.23
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.35.23.ebuild95
2 files changed, 96 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index b4bf93592abc..2d420defd851 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -3,3 +3,4 @@ DIST aws-cli-1.35.15.gh.tar.gz 2810766 BLAKE2B 18a8464acede1801a533da89191c31309
DIST aws-cli-1.35.20.gh.tar.gz 2817368 BLAKE2B 92c86af16eb29a22c437491c938c08d4a2745067ed923c52f271de3fd249b8fc35d4f7aa9a6e523279c463f619294096b5e88d9800a53fc9d3c3a9ddeae1e507 SHA512 d2a1aafd3aba9441b6560e1a197c1c65c3597883ac93cd8c29e1c88f03cd554039ffaacd8df10392189de5ed0b11169b2d32c8a5513ab70cc0a9f331eb87813a
DIST aws-cli-1.35.21.gh.tar.gz 2817837 BLAKE2B 3dd29e42ddcb46e2da10739de00218c8bd493ce02221c94d67a8ab901921a2530780bf2b08a8d8463b81d69da3001af5ac886a1b93b4596efa2092520d979c63 SHA512 e216824e5453ca8bf21968703172bf13f728899bd07b5a1c7f910926385d884a82549f886c687da016af52918b4a3cbf41b9d485a8577d3c8bca7382333598dd
DIST aws-cli-1.35.22.gh.tar.gz 2818220 BLAKE2B 8fee8243d11a189ee696317ec12082e3ac17aedb10cb54bdda0f6defd50f9605e2ab4114f7dca4c00cbace6365ee2285a9cea8c7186f994ff1bd796b427762b2 SHA512 ce6be250b7aac5155322e88d9ad4c6b17b0cc9defadc4f420c3d4a0162a5fe43d7321d69cba62ea7804b6875a2fc9ef0802abfb7979b80f16f49255b6a1ddcc1
+DIST aws-cli-1.35.23.gh.tar.gz 2819656 BLAKE2B 6e9d20410344f075ce12bfc8c0a49941a846f02304de9a30516376d0b6666b8c0a9affb36dd94a463f48f17f478f5d27e0f7375a48c63eca1b3a28927211e6aa SHA512 9075af833da9abc9494a2dd01a987b874e2b4444d7d5d1f4f974da1b56940b88603e8ec115662c85c2beb7cb70a65c3bcdbbd5510a1973433f8030efc6a1c69a
diff --git a/app-admin/awscli/awscli-1.35.23.ebuild b/app-admin/awscli/awscli-1.35.23.ebuild
new file mode 100644
index 000000000000..23ee84e2ec41
--- /dev/null
+++ b/app-admin/awscli/awscli-1.35.23.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit bash-completion-r1 distutils-r1
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.y.(z+34)
+BOTOCORE_PV="$(ver_cut 1).$(ver_cut 2).$(( $(ver_cut 3-) + 34 ))"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local serial_tests=(
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_{fails,success}
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_with_new_version_plugin_success
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/customizations/test_sessionmanager.py
+ tests/unit/test_compat.py::TestIgnoreUserSignals
+ tests/unit/test_help.py
+ tests/unit/test_utils.py::TestIgnoreCtrlC::test_ctrl_c_is_ignored
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ EPYTEST_XDIST= epytest "${serial_tests[@]}"
+
+ local EPYTEST_DESELECT=(
+ "${serial_tests[@]}"
+
+ # flaky (some ordering?)
+ tests/functional/s3/test_cp_command.py::TestCPCommand::test_multipart_upload_with_checksum_algorithm_crc32
+ )
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}