summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-18 05:23:38 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-18 05:23:38 +0200
commit451c75ff69c3a7999dd090a5a40b462de9064c9b (patch)
tree967f95cf8f32887df51699411205407ce73c4c23 /app-admin
parentdev-python/boto3: Bump to 1.35.43 (diff)
downloadgentoo-451c75ff69c3a7999dd090a5a40b462de9064c9b.tar.gz
gentoo-451c75ff69c3a7999dd090a5a40b462de9064c9b.tar.bz2
gentoo-451c75ff69c3a7999dd090a5a40b462de9064c9b.zip
app-admin/awscli: Bump to 1.35.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.35.9.ebuild98
2 files changed, 99 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 38800930473e..9a4a1fdec175 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -4,3 +4,4 @@ DIST aws-cli-1.35.5.gh.tar.gz 2808789 BLAKE2B 545c76bd349485fbf2dc5565317678904c
DIST aws-cli-1.35.6.gh.tar.gz 2809349 BLAKE2B 565ee8bbebdb387c437bccfc608833abb789b5a44cf7a246b04264536edc8b5c282ecdeedb4a26652058ba85b22c8ca048812f3ebf890503d5853c582ac67791 SHA512 481c6cf4a3f516cfd929736cfa556620eb493f9b5f47a861e8a44c37edb9642a7bddffcf69ed2d43e63a9253114f0ad1bd700c9f7b66c114cb1b7ad2c3271c15
DIST aws-cli-1.35.7.gh.tar.gz 2809700 BLAKE2B 02cbe60f2ee5afd8dabd9e339e95f21794d331f4a19d4548d8f8c07c2ca4e6ab5c859559f0fb01af413832f57a9726a61e50c5b26a34db7f789f544583c0d6c6 SHA512 23bf47790bc51547ad9af289f4ad0a84ede1c6a01171adc7bf8e1236227ef8f59fabfefc9f89560dcaeae1d3118f12e25eccac6afae7f33f8bd6682a7feed959
DIST aws-cli-1.35.8.gh.tar.gz 2809964 BLAKE2B 1fe220f751c8874969ac78f36618a1b0195ec36f848181604a6e43cd052ecf1424c49155382511d26f0a1d7c1d35ae13b46124be7af88c4cc3cde12b19c59c61 SHA512 9308743f14f68ada3ab43dbc2f33d0b01ac1c565af3d6da38706e950a04aae09035a63eeb68c1a85ed91bd122d76488a730156b85eb60078bf542752dbc1abfa
+DIST aws-cli-1.35.9.gh.tar.gz 2810739 BLAKE2B 37229a034677c9ce1bf7c6970b77b457a8a27a9cb65c964444441a7109c9dbf46c7d8de0855cbcc88eee8458f62c3a70e8c29cb0419f309951a52a59518a9a2d SHA512 1bc9c95e954a5ea9036842071c995f97dc31ee53a7978a4f089eb78d025a7109d7461ed03563b049a822298da988a60a9c067d7dcd00557c21fd922c42711bd5
diff --git a/app-admin/awscli/awscli-1.35.9.ebuild b/app-admin/awscli/awscli-1.35.9.ebuild
new file mode 100644
index 000000000000..0fc6192a8587
--- /dev/null
+++ b/app-admin/awscli/awscli-1.35.9.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit bash-completion-r1 distutils-r1
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.y.(z+34)
+BOTOCORE_PV="$(ver_cut 1).$(ver_cut 2).$(( $(ver_cut 3-) + 34 ))"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local serial_tests=(
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_{fails,success}
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_with_new_version_plugin_success
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/customizations/test_sessionmanager.py
+ tests/unit/test_compat.py::TestIgnoreUserSignals
+ tests/unit/test_help.py
+ tests/unit/test_utils.py::TestIgnoreCtrlC::test_ctrl_c_is_ignored
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ EPYTEST_XDIST= epytest "${serial_tests[@]}"
+
+ local EPYTEST_DESELECT=( "${serial_tests[@]}" )
+ case ${EPYTHON} in
+ python3.13*)
+ EPYTEST_DESELECT+=(
+ # flaky (some ordering?)
+ tests/functional/s3/test_cp_command.py::TestCPCommand::test_multipart_upload_with_checksum_algorithm_crc32
+ )
+ ;;
+ esac
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}