summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-01 04:49:34 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-01 06:07:18 +0200
commit12665a3e8b40bfc580f6bbfc18a74d48c66f069f (patch)
treee69d5b35d17aabd951e36cf57ff7b85f0faeafc5 /app-admin
parentdev-python/boto3: Bump to 1.26.144 (diff)
downloadgentoo-12665a3e8b40bfc580f6bbfc18a74d48c66f069f.tar.gz
gentoo-12665a3e8b40bfc580f6bbfc18a74d48c66f069f.tar.bz2
gentoo-12665a3e8b40bfc580f6bbfc18a74d48c66f069f.zip
app-admin/awscli: Bump to 1.27.144
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.27.144.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 2f98c363b368..b81720416475 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -2,3 +2,4 @@ DIST aws-cli-1.27.133.gh.tar.gz 2421348 BLAKE2B 0511291bf018bb62616f11231327b47a
DIST aws-cli-1.27.137.gh.tar.gz 2423020 BLAKE2B 9cdc1cab324eaa2b2bc17418180bf8bec6e34903b427afbd2bceb0c35eb0923b5e7d98e42954f239bf13576b5d10b80c29d15af17e0f230ff79c244b1532a671 SHA512 9d3220b392839334bc077e0ae417b73ae2aaec363a5a3684690eabe790c062f9b428851b02cb2f27b65193c712fc149eb602a33b8f500afc81daed5cd2d3e8db
DIST aws-cli-1.27.142.gh.tar.gz 2426758 BLAKE2B 587791e0102d51b9681718a71c1225c673f1545f98d2cbd679d266c559ae4252e92ec2c41a640584b5ce1e4aced885489723edb90e0700846e3fd74968be42bd SHA512 cb2ba71dc955ddd5a738f6e703a16216effdbd1232fa4e14c5974bf59c6f871ba80a4a61614dccb0fc110c689ce24f466c4142967be83f48c5de41699450d092
DIST aws-cli-1.27.143.gh.tar.gz 2428987 BLAKE2B 3cc1d312e2a5cb4187234615d42f69c1296ad810a317adb2ebce05514168aee5b58b9ff0240e84bd31d4000d6f6cc76d476bee739ea6d394a833ee25ec422dce SHA512 f82634435ac67ba1cd2b43913d86c66ebe0dd06d40a708ae63a2bfc150a9733f1c80ff82362b48834ede5bba317c970d88d5e70d133860bb0ef022fd00ac07a1
+DIST aws-cli-1.27.144.gh.tar.gz 2429624 BLAKE2B 63b447244a5e1d110d30d69d02c6f895fcd667870c25e7f85abb0f51c47fe7547494010930bd0167861c187a0cfef3d298e55e83d1aaa77614687ee90b69da35 SHA512 979a38e3b089258d6828d55294ac5ba664df8b1a62180a3ecbdd98e0554676952e785c6ee917ff31eed32ec36cde0e08cf8cf98489eaff6b2242d6923493d2a3
diff --git a/app-admin/awscli/awscli-1.27.144.ebuild b/app-admin/awscli/awscli-1.27.144.ebuild
new file mode 100644
index 000000000000..62c19f3a63fb
--- /dev/null
+++ b/app-admin/awscli/awscli-1.27.144.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/functional/eks/test_kubeconfig.py::TestKubeconfigLoader::test_load_simple
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_env_only
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_existing
+ tests/unit/customizations/eks/test_kubeconfig.py::TestKubeconfigValidator::test_valid
+ )
+
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)" --forked
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}