summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2024-08-14 07:36:38 +0300
committerViorel Munteanu <ceamac@gentoo.org>2024-08-14 07:36:38 +0300
commit035dba3f14d74470a0ffe0b3cb7b63afcd52a47e (patch)
treeba4601d60d5b48215e5aa2152c46a4aa4dfed5ef /app-admin
parentprofiles: fix cURL HTTP/3 / QUIC mask (diff)
downloadgentoo-035dba3f14d74470a0ffe0b3cb7b63afcd52a47e.tar.gz
gentoo-035dba3f14d74470a0ffe0b3cb7b63afcd52a47e.tar.bz2
gentoo-035dba3f14d74470a0ffe0b3cb7b63afcd52a47e.zip
app-admin/linode-cli: add 5.51.0
Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/linode-cli/Manifest1
-rw-r--r--app-admin/linode-cli/linode-cli-5.51.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/app-admin/linode-cli/Manifest b/app-admin/linode-cli/Manifest
index 70eb9dda5fca..4d1281a97eae 100644
--- a/app-admin/linode-cli/Manifest
+++ b/app-admin/linode-cli/Manifest
@@ -1 +1,2 @@
DIST linode_cli-5.50.0.tar.gz 146902 BLAKE2B ebe83454f06bc281a91dcc276db7378779d73717ca49bbcc81fe59e61c6eb448d7a7bde9e5482bb21ca05c0484001f86dab4b4296011ecbb156c13b38573f7ea SHA512 3fb95f76c19f17f897ebce3bfb6d32de1f9a2ed2d8ba9078180e465acbe20b873a59092809a2c766c326e0c5e27c983c84aef9ae7c210004f51b2b62225694e1
+DIST linode_cli-5.51.0.tar.gz 154535 BLAKE2B 7cd59795bed698ec73510d7881a2768f31fb405619e991608b711433cc971aa024d173b54a184b96aa7de9db879593fd358d5b4cdd140c699f941ad19f29bdd4 SHA512 ca9fad8af34e84993c8be9d6f253955389df32d42e6a881b72b2445a71951b5d2458e8580189fdc26d3c870ff7af20fce71a4a838aeb0d96380b0588e1f34146
diff --git a/app-admin/linode-cli/linode-cli-5.51.0.ebuild b/app-admin/linode-cli/linode-cli-5.51.0.ebuild
new file mode 100644
index 000000000000..21d1ca44d811
--- /dev/null
+++ b/app-admin/linode-cli/linode-cli-5.51.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 pypi shell-completion
+
+DESCRIPTION="Official command-line interface for interacting with the Linode API"
+HOMEPAGE="https://github.com/linode/linode-cli https://www.linode.com/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# Tests require network, a linode account and an API key.
+# WARNING: tests will incur costs and will wipe the account.
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/boto3[${PYTHON_USEDEP}]
+ >=dev-python/linode-metadata-0.3[${PYTHON_USEDEP}]
+ dev-python/openapi3[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ <dev-python/urllib3-3[${PYTHON_USEDEP}]
+"
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ PYTHONPATH=. ${EPYTHON} linodecli completion bash > "${T}/${PN}".bash || die
+ PYTHONPATH=. ${EPYTHON} linodecli completion fish > "${T}/${PN}".fish || die
+
+ newbashcomp "${T}/${PN}".bash ${PN}
+ newfishcomp "${T}/${PN}".fish ${PN}
+
+ dosym ${PN} "$(get_bashcompdir)"/linode
+ dosym ${PN} "$(get_bashcompdir)"/lin
+ dosym ${PN} "$(get_fishcompdir)"/linode
+ dosym ${PN} "$(get_fishcompdir)"/lin
+}