summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2024-06-12 13:55:52 +0100
committerMarek Szuba <marecki@gentoo.org>2024-06-12 14:04:03 +0100
commit00e13567fe82801105c56fa4d0ecdbe7f03ba9e6 (patch)
tree414c6c0198d5cebe22b1b6078afe82e87add3073 /app-admin
parentapp-admin/ansible-lint: stabilize 24.2.2 for amd64 (diff)
downloadgentoo-00e13567fe82801105c56fa4d0ecdbe7f03ba9e6.tar.gz
gentoo-00e13567fe82801105c56fa4d0ecdbe7f03ba9e6.tar.bz2
gentoo-00e13567fe82801105c56fa4d0ecdbe7f03ba9e6.zip
app-admin/ansible-lint: add 24.6.0
Closes: https://bugs.gentoo.org/932729 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/ansible-lint/Manifest1
-rw-r--r--app-admin/ansible-lint/ansible-lint-24.6.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/app-admin/ansible-lint/Manifest b/app-admin/ansible-lint/Manifest
index 793cf95128c8..e72e478c6e01 100644
--- a/app-admin/ansible-lint/Manifest
+++ b/app-admin/ansible-lint/Manifest
@@ -1,3 +1,4 @@
DIST ansible-lint-24.2.0.tar.gz 513719 BLAKE2B 54e05acf982cf13cb2142a10bf04250171f07936df14933525dfae68b312a0d92ceb30867603dc7ce686206b7de010f6ca4eb9ab532ca000fc3c15c77c354c81 SHA512 3276d28c7b85a6087a0142cc56442efddf9ff3e81155455c74686015a2ab45ece64847b0243373ad01145e67599d8449866c122efe8ae404cd819011e41c5235
DIST ansible-lint-24.2.2.tar.gz 515822 BLAKE2B e9d8e689dfe4e4efbd4dad44ff3567f50412400ed979f2d60150f09f17c5f63f2441f25a33ecdf0112024ced07e62ac16b8a2dbc1c01d62855ec785fc75d1b9a SHA512 3de6b14e4b64ba577abcb67920a45dbf45fedb84e21091cd6a29e3c52a7a91555a152ee3e265624aafbf9dddba96d04241c2598a18f2103ce2cae48706142446
DIST ansible_lint-24.5.0.tar.gz 525539 BLAKE2B 2681da05c69299f62b9a180ff4a10ea8fa27731d5a9f3d836e67fd211c2def86a6baa38583900e9c8be1a5da0a8658aded6e83cb8f13f129f55bd18a06b2e574 SHA512 b390743bbb09c03c9b402c35644c2b2e29b9a94fce842bf42b8938f7094b145ea75275f643949383bdad694408c606c0bc3038d5ca733a39ac08ef77cc7dc459
+DIST ansible_lint-24.6.0.tar.gz 529088 BLAKE2B 3d307669d2035eb5a3a8295b40e3afca92ca4eae4ea419948fd2fa86127e05c60f3ca037a4b85b447320ba8a57f7e1a736a55d63aac80e386f9fc4d733190b09 SHA512 1eb8e3e1805ff98ae76ddcd873a5e90b0b0182fbbce3c40844b2a9069e6879fef906e14f98dd77e41372e461ea4350388b68e08be420afaf5d6c449a449a7989
diff --git a/app-admin/ansible-lint/ansible-lint-24.6.0.ebuild b/app-admin/ansible-lint/ansible-lint-24.6.0.ebuild
new file mode 100644
index 000000000000..057962e736a9
--- /dev/null
+++ b/app-admin/ansible-lint/ansible-lint-24.6.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Checks ansible playbooks for practices and behaviour that can be improved"
+HOMEPAGE="https://github.com/ansible/ansible-lint"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+# Upstream has stated explicitly that all tests require Internet access
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND="
+ >=app-admin/ansible-core-2.13.0[${PYTHON_USEDEP}]
+ >=dev-python/ansible-compat-24.5.0[${PYTHON_USEDEP}]
+ >=dev-python/black-24.3.0[${PYTHON_USEDEP}]
+ >=dev-python/filelock-3.8.0[${PYTHON_USEDEP}]
+ dev-python/importlib-metadata[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.17.0[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/pathspec-0.10.3[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.4.1[${PYTHON_USEDEP}]
+ >=dev-python/rich-12.0.0[${PYTHON_USEDEP}]
+ >=dev-python/ruamel-yaml-0.18.5[${PYTHON_USEDEP}]
+ >=dev-python/wcmatch-8.5.0[${PYTHON_USEDEP}]
+ >=dev-util/yamllint-1.30.0[${PYTHON_USEDEP}]
+ dev-vcs/git"
+BDEPEND="
+ >=dev-python/setuptools-scm-7.0.5[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mypy[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ >=dev-python/pytest-plus-0.6[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-2.5.0[${PYTHON_USEDEP}]
+ )"
+
+# test_call_from_outside_venv doesn't play nicely with the sandbox
+# irrespective of whether Internet access is allowed or not
+EPYTEST_DESELECT=(
+ test/test_main.py::test_call_from_outside_venv
+)
+
+distutils_enable_tests pytest
+
+# Test suite fails to start without this
+python_test() {
+ epytest test
+}