summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Molik <dan@danmolik.com>2019-01-04 11:42:46 -0500
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2019-01-04 13:20:30 -0800
commit78b3d9a3093d8a3fa72a266dccef2357a6173fce (patch)
tree0f9eabde7975c6af3ef55a608fe00db472a316f8 /app-admin/terraform
parentdev-util/ccache: bump up to 3.5.1a, bug #674516 (diff)
downloadgentoo-78b3d9a3093d8a3fa72a266dccef2357a6173fce.tar.gz
gentoo-78b3d9a3093d8a3fa72a266dccef2357a6173fce.tar.bz2
gentoo-78b3d9a3093d8a3fa72a266dccef2357a6173fce.zip
app-admin/terraform: new package
Adding Hashicorp's terraform infrastructure as code utility. Information on the tool can be found here: https://terraform.io and the code base can be found here: https://github.com/hashicorp/terraform Package-Manager: Portage-2.3.54, Repoman-2.3.12 Closes: https://bugs.gentoo.org/634538 Closes: https://github.com/gentoo/gentoo/pull/10740 Signed-off-by: Dan Molik <dan@danmolik.com> Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'app-admin/terraform')
-rw-r--r--app-admin/terraform/Manifest1
-rw-r--r--app-admin/terraform/metadata.xml28
-rw-r--r--app-admin/terraform/terraform-0.11.11.ebuild28
3 files changed, 57 insertions, 0 deletions
diff --git a/app-admin/terraform/Manifest b/app-admin/terraform/Manifest
new file mode 100644
index 000000000000..d83bd780e06a
--- /dev/null
+++ b/app-admin/terraform/Manifest
@@ -0,0 +1 @@
+DIST terraform-0.11.11.tar.gz 10938952 BLAKE2B 76062c2c95c95751f7a1a28fc7047ebd2255504dece99efa08ea8deede5e774a838571a2e0ab81fa90e2580823958d8e1781d154ecbed9c1d839a0cb2998487c SHA512 7c0cf4b0b70eab7dc88133d50ac4b586b72ac53e01c21c00766d03d10c753cfd404b146add21e378be8f1d305c5e92703cbaeac9e4c4b55bfc8b2532f74f63ee
diff --git a/app-admin/terraform/metadata.xml b/app-admin/terraform/metadata.xml
new file mode 100644
index 000000000000..6cdb29b9fbee
--- /dev/null
+++ b/app-admin/terraform/metadata.xml
@@ -0,0 +1,28 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>dan@danmolik.com</email>
+ <name>Dan Molik</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ Terraform is a tool for building, changing, and versioning infrastructure
+ safely and efficiently. Terraform can manage existing and popular service
+ providers as well as custom in-house solutions.
+
+ Terraform files describe the components needed to run a single application
+ or your entire datacenter. Terraform generates an execution plan describing
+ what it will do to reach the desired state, and then executes it to build
+ the described infrastructure. As the configuration changes, Terraform is
+ able to determine what changed and create incremental execution plans which
+ can be applied.
+ </longdescription>
+ <upstream>
+ <changelog>https://github.com/hashicorp/terraform/blob/master/CHANGELOG.md</changelog>
+ <remote-id type="github">hashicorp/terraform</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-admin/terraform/terraform-0.11.11.ebuild b/app-admin/terraform/terraform-0.11.11.ebuild
new file mode 100644
index 000000000000..15c8b080b179
--- /dev/null
+++ b/app-admin/terraform/terraform-0.11.11.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit golang-vcs-snapshot
+
+DESCRIPTION="A tool for building, changing, and combining infrastructure safely"
+HOMEPAGE="https://www.terraform.io/"
+
+EGO_PN="github.com/hashicorp/${PN}"
+SRC_URI="https://github.com/hashicorp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+DEPEND=">=dev-lang/go-1.11.0"
+
+src_compile() {
+ cd "src/${EGO_PN}" || die
+ GOPATH="${S}" GOCACHE="${T}/go-cache" go build \
+ -v -work -o "${S}/${PN}" ./ || die
+}
+
+src_install() {
+ dobin terraform
+}