summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-06-05 09:30:28 -0400
committerMatt Turner <mattst88@gentoo.org>2023-06-05 09:30:51 -0400
commitfc2debfbb4795b30cbae1dc9ce34ac5aab010e38 (patch)
treea3b3f333722647809e9d6f6fb2c51ac4ed6d8c25 /app-admin/openrc-settingsd
parentgnome-base/nautilus: Version bump to 44.2.1 (diff)
downloadgentoo-fc2debfbb4795b30cbae1dc9ce34ac5aab010e38.tar.gz
gentoo-fc2debfbb4795b30cbae1dc9ce34ac5aab010e38.tar.bz2
gentoo-fc2debfbb4795b30cbae1dc9ce34ac5aab010e38.zip
app-admin/openrc-settingsd: Version bump to 1.3.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-admin/openrc-settingsd')
-rw-r--r--app-admin/openrc-settingsd/Manifest1
-rw-r--r--app-admin/openrc-settingsd/openrc-settingsd-1.3.0.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/app-admin/openrc-settingsd/Manifest b/app-admin/openrc-settingsd/Manifest
index e240a2118145..b068d72b2622 100644
--- a/app-admin/openrc-settingsd/Manifest
+++ b/app-admin/openrc-settingsd/Manifest
@@ -1 +1,2 @@
DIST openrc-settingsd-v1.2.0.tar.bz2 41713 BLAKE2B e4630e934fc55549b3d81cc448adb35cb22cb99b898363a1113909a24acc0709d5693841a9c651b4ecf52044c3a45cc4b8207f9c9a3d0e1e8a4f85edefb23d65 SHA512 b1862e80454d3ca22d083f283f4ef3215dfad4da6d2aa495211fa31014c66fb6891ae87a3a1c6932944ed4c1e7100d247e80abc659f37868adcf5fce3b90385b
+DIST openrc-settingsd-v1.3.0.tar.bz2 41865 BLAKE2B 48dbb75bfd33a0e2b6cc99ccbea4cd22db7a0dca13c665c59c73dac9eb4b65554741fc3b45028fbbe81cc014059e896a1dac8b18bf166a8fa15e4df375927a31 SHA512 5ef93acd1f78aa6aa6af4b0702096a30fe2fdb0ff5a20e17d680bf48c8d995a09db390fda7e16a3098e9cb3e3ce1ff13d76471cf1f0c3ccf67d3f3929a5567bb
diff --git a/app-admin/openrc-settingsd/openrc-settingsd-1.3.0.ebuild b/app-admin/openrc-settingsd/openrc-settingsd-1.3.0.ebuild
new file mode 100644
index 000000000000..f3ac7e0b4b11
--- /dev/null
+++ b/app-admin/openrc-settingsd/openrc-settingsd-1.3.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="System settings D-Bus service for OpenRC"
+HOMEPAGE="https://gitlab.com/postmarketOS/openrc-settingsd/"
+SRC_URI="https://gitlab.com/postmarketOS/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="systemd"
+
+DEPEND="
+ >=dev-libs/glib-2.30:2
+ sys-apps/dbus
+ sys-auth/polkit
+ dev-libs/libdaemon:0=
+ sys-apps/openrc
+"
+RDEPEND="
+ ${DEPEND}
+ systemd? ( >=sys-apps/systemd-197 )
+ !systemd? ( sys-auth/nss-myhostname !sys-apps/systemd )
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${PN}-v${PV}"
+
+src_configure() {
+ local emesonargs=(
+ -Dopenrc=enabled
+ -Denv-update=/usr/bin/env-update
+ -Dhostname-style=gentoo
+ -Dlocale-style=gentoo
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ if use systemd; then
+ # Avoid file collision with systemd
+ rm -vr "${ED}"/usr/share/{dbus-1,polkit-1} "${ED}"/etc/dbus-1 || die "rm failed"
+ fi
+}
+
+pkg_postinst() {
+ if use systemd; then
+ elog "You installed ${PN} with USE=systemd. In this mode,"
+ elog "${PN} will not start via simple dbus activation, so you"
+ elog "will have to manually enable it as an rc service:"
+ elog " # /etc/init.d/openrc-settingsd start"
+ elog " # rc-update add openrc-settingsd default"
+ fi
+}