summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-03-08 14:55:42 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-03-08 14:56:05 +0100
commit1940f4b7f0d20a8bd73448e5a652e64fe7e0a100 (patch)
treec1c8a64d5bcb763b77009cafc37de5c9bb6c79bb /app-admin/keepassxc
parentprofiles: mask USE=hipe for dev-lang/erlang on arm (diff)
downloadgentoo-1940f4b7f0d20a8bd73448e5a652e64fe7e0a100.tar.gz
gentoo-1940f4b7f0d20a8bd73448e5a652e64fe7e0a100.tar.bz2
gentoo-1940f4b7f0d20a8bd73448e5a652e64fe7e0a100.zip
app-admin/keepassxc: Don't call mandb
Closes: https://bugs.gentoo.org/679766 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'app-admin/keepassxc')
-rw-r--r--app-admin/keepassxc/files/keepassxc-dont_call_mandb.patch25
-rw-r--r--app-admin/keepassxc/keepassxc-2.3.3.ebuild3
-rw-r--r--app-admin/keepassxc/keepassxc-2.3.4-r1.ebuild1
-rw-r--r--app-admin/keepassxc/keepassxc-2.4.0_beta2.ebuild4
4 files changed, 32 insertions, 1 deletions
diff --git a/app-admin/keepassxc/files/keepassxc-dont_call_mandb.patch b/app-admin/keepassxc/files/keepassxc-dont_call_mandb.patch
new file mode 100644
index 000000000000..f966ae5ff28f
--- /dev/null
+++ b/app-admin/keepassxc/files/keepassxc-dont_call_mandb.patch
@@ -0,0 +1,25 @@
+From f3e52d89b20a8740d18cd9f1124f299b64f06b36 Mon Sep 17 00:00:00 2001
+From: Lars Wendler <polynomial-c@gentoo.org>
+Date: Fri, 8 Mar 2019 14:48:13 +0100
+Subject: [PATCH] Don't call mandb
+
+There are other man implementateions beside man-db so it is not even sure
+that the "mandb" binary even exists on all unices. Other than that, usually
+there's a cron job running "mandb" on a daily basis.
+---
+ src/cli/CMakeLists.txt | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/src/cli/CMakeLists.txt b/src/cli/CMakeLists.txt
+index e59a911a..c3f97a2c 100644
+--- a/src/cli/CMakeLists.txt
++++ b/src/cli/CMakeLists.txt
+@@ -94,5 +94,4 @@ endif()
+
+ if(APPLE OR UNIX)
+ install(FILES keepassxc-cli.1 DESTINATION ${CMAKE_INSTALL_MANDIR}/man1/)
+- execute_process(COMMAND mandb -q)
+ endif()
+--
+2.21.0
+
diff --git a/app-admin/keepassxc/keepassxc-2.3.3.ebuild b/app-admin/keepassxc/keepassxc-2.3.3.ebuild
index 3b2a5255c887..bf0e88ca357a 100644
--- a/app-admin/keepassxc/keepassxc-2.3.3.ebuild
+++ b/app-admin/keepassxc/keepassxc-2.3.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -49,6 +49,7 @@ DEPEND="
PATCHES=(
"${FILESDIR}/${P}-qt-5.11-edit-entry-widget-includes.patch" #655844
+ "${FILESDIR}/${PN}-dont_call_mandb.patch"
)
src_prepare() {
diff --git a/app-admin/keepassxc/keepassxc-2.3.4-r1.ebuild b/app-admin/keepassxc/keepassxc-2.3.4-r1.ebuild
index 222a7249efa6..bf07bec346a5 100644
--- a/app-admin/keepassxc/keepassxc-2.3.4-r1.ebuild
+++ b/app-admin/keepassxc/keepassxc-2.3.4-r1.ebuild
@@ -54,6 +54,7 @@ PDEPEND="
PATCHES=(
"${FILESDIR}/${PN}-2.3.3-qt-5.11-edit-entry-widget-includes.patch" #655844
+ "${FILESDIR}/${PN}-dont_call_mandb.patch"
)
src_prepare() {
diff --git a/app-admin/keepassxc/keepassxc-2.4.0_beta2.ebuild b/app-admin/keepassxc/keepassxc-2.4.0_beta2.ebuild
index 1b5f2654570d..b05a5089d561 100644
--- a/app-admin/keepassxc/keepassxc-2.4.0_beta2.ebuild
+++ b/app-admin/keepassxc/keepassxc-2.4.0_beta2.ebuild
@@ -57,6 +57,10 @@ PDEPEND="
x11-misc/xsel
"
+PATCHES=(
+ "${FILESDIR}/${PN}-dont_call_mandb.patch"
+)
+
src_prepare() {
use test || \
sed -e "/^find_package(Qt5Test/d" -i CMakeLists.txt || die