summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2022-04-26 09:15:03 +0200
committerAgostino Sarubbo <ago@gentoo.org>2022-04-26 09:15:03 +0200
commitf06a3bb600ab7734f63a50e1040b4ae8de619ff6 (patch)
tree44bec2e0fa846aa909ce5a9819c2c85f41a9647f /app-admin/exo
parentdev-cpp/glog: amd64 stable wrt bug #840927 (diff)
downloadgentoo-f06a3bb600ab7734f63a50e1040b4ae8de619ff6.tar.gz
gentoo-f06a3bb600ab7734f63a50e1040b4ae8de619ff6.tar.bz2
gentoo-f06a3bb600ab7734f63a50e1040b4ae8de619ff6.zip
app-admin/exo: version bump to 1.53.0
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Diffstat (limited to 'app-admin/exo')
-rw-r--r--app-admin/exo/Manifest1
-rw-r--r--app-admin/exo/exo-1.53.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/app-admin/exo/Manifest b/app-admin/exo/Manifest
index 0a94e8d86f1c..a60cd34412b3 100644
--- a/app-admin/exo/Manifest
+++ b/app-admin/exo/Manifest
@@ -1 +1,2 @@
DIST exo-1.52.1.tar.gz 5594576 BLAKE2B c8cd5011014b9eee899afe7cdd1d45708be221d33772c858c5fb4d62ece0ecec3cdef0aa106c9ce2b0604cb9735cc17674f65274f88becb6c6f7eaaf2643d29f SHA512 25612b8dfd1ce55a1860f75357977ca8cccd0b24860eb091a203c84895c449b59ee5788e6a9e71168cf1927d3d6584cd5f379a3e32565215dcc1ea7210d38714
+DIST exo-1.53.0.tar.gz 5597243 BLAKE2B ed9536a3e62b8344aef4d5a3edb3948615b96360bd302c90c16ba366eeb50a869200de39de45f3fbd6a1a3dfff7e42622720dffcbb91cb9c0cdf402f6eac8a2d SHA512 471c7024cdddb7734218fc942bb38593de759d408c859c135672d7bbf870c554dabb6eaf216ca20616e0b2d4eea487731f2142b39fda7daea5104f077bce99a1
diff --git a/app-admin/exo/exo-1.53.0.ebuild b/app-admin/exo/exo-1.53.0.ebuild
new file mode 100644
index 000000000000..6149acedfa18
--- /dev/null
+++ b/app-admin/exo/exo-1.53.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Command-line tool for everything at Exoscale: compute, storage, dns"
+HOMEPAGE="https://github.com/exoscale/cli"
+SRC_URI="https://github.com/exoscale/cli/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE=""
+DEPEND="dev-lang/go:="
+RESTRICT="strip"
+QA_FLAGS_IGNORED=".*"
+
+S="${WORKDIR}/cli-${PV}"
+
+src_compile() {
+ go build -mod vendor -o ${PN} || die "build failed"
+}
+
+src_test() {
+ # run at least 'exo version' for test
+ ./exo version > /dev/null 2>&1
+ if [[ $? -ne 0 ]]
+ then
+ die "Test failed"
+ fi
+}
+
+src_install() {
+ dobin ${PN}
+}