summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/aws-iam-tools
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/aws-iam-tools')
-rw-r--r--app-admin/aws-iam-tools/Manifest1
-rw-r--r--app-admin/aws-iam-tools/aws-iam-tools-1.3.0.ebuild61
-rw-r--r--app-admin/aws-iam-tools/metadata.xml13
3 files changed, 75 insertions, 0 deletions
diff --git a/app-admin/aws-iam-tools/Manifest b/app-admin/aws-iam-tools/Manifest
new file mode 100644
index 000000000000..25352ac91b4c
--- /dev/null
+++ b/app-admin/aws-iam-tools/Manifest
@@ -0,0 +1 @@
+DIST IAMCli-1.3.0.zip 3957057 SHA256 4878b19d889dab063d09f724b342b67fb872843ac60c1105a77cf2f6610908d1 SHA512 5012ece2d0569545848d83cf879b4d05f7f955f22bbc31b86f3993e4f5ee48de3099369fddf7f2b2d98f89e56c8c329e427a1f7dca0afa728ea9593c1b36497c WHIRLPOOL b228ce1cf048eed4e1cd9679510184321657a47491d8215b624db37345cadebf3f61325556e52e65fea8f622cbc611f0a126f92e9061d51e7486589c9829374f
diff --git a/app-admin/aws-iam-tools/aws-iam-tools-1.3.0.ebuild b/app-admin/aws-iam-tools/aws-iam-tools-1.3.0.ebuild
new file mode 100644
index 000000000000..15afc3264526
--- /dev/null
+++ b/app-admin/aws-iam-tools/aws-iam-tools-1.3.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+DESCRIPTION="The Command Line Interface (CLI) for the AWS Identity and Access Management (IAM) Service"
+HOMEPAGE="http://aws.amazon.com/developertools/AWS-Identity-and-Access-Management/4143"
+SRC_URI="mirror://sabayon/${CATEGORY}/IAMCli-${PV}.zip"
+
+S="${WORKDIR}/IAMCli-${PV}"
+
+LICENSE="Amazon"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND="app-arch/unzip"
+RDEPEND="virtual/jre"
+RESTRICT="mirror"
+
+src_unpack() {
+ unpack ${A}
+ cd "${WORKDIR}/IAMCli-${PV}"
+ find . -name '*.cmd' -delete || die
+}
+
+src_install() {
+ dodir /opt/${PN}
+ insinto /opt/${PN}/lib
+ doins -r "${S}"/lib/*
+ exeinto /opt/${PN}/bin
+ doexe "${S}"/bin/*
+
+ dodir /etc/env.d
+ cat - > "${T}"/99${PN} <<EOF
+AWS_IAM_HOME=/opt/${PN}
+PATH=/opt/${PN}/bin
+ROOTPATH=/opt/${PN}/bin
+EOF
+ doenvd "${T}"/99${PN}
+
+ dodoc "LICENSE.txt"
+}
+
+pkg_postinst() {
+ ewarn "Remember to run: env-update && source /etc/profile if you plan"
+ ewarn "to use these tools in a shell before logging out (or restarting"
+ ewarn "your login manager)"
+ elog
+ elog "You need to put the following in your ~/.bashrc replacing the"
+ elog "values with the full path to your AWS credentials file."
+ elog
+ elog " export AWS_CREDENTIAL_FILE=/path/and_filename_of_credential_file"
+ elog
+ elog "It should contains two lines: the first line lists the AWS Account's"
+ elog "AWS Access Key ID, and the second line lists the AWS Account's"
+ elog "Secret Access Key. For example:"
+ elog
+ elog " AWSAccessKeyId=AKIAIOSFODNN7EXAMPLE"
+ elog " AWSSecretKey=wJalrXUtnFEMI/K7MDENG/bPxRfiCYzEXAMPLEKEY"
+}
diff --git a/app-admin/aws-iam-tools/metadata.xml b/app-admin/aws-iam-tools/metadata.xml
new file mode 100644
index 000000000000..1a971abe53b5
--- /dev/null
+++ b/app-admin/aws-iam-tools/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>lxnay@gentoo.org</email>
+ </maintainer>
+ <maintainer>
+ <email>sergey.zhuga@gmail.com</email>
+ <name>Sergey Zhuga</name>
+ <description>Proxy maintainers. CC him on bugs</description>
+ </maintainer>
+</pkgmetadata>