summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2025-01-11 17:11:23 +0100
committerMaciej Barć <xgqt@gentoo.org>2025-01-11 17:29:21 +0100
commiteea1492c31992f2e69d7c4241557a330f3eaec52 (patch)
tree927d9dc8d06ee3b4b2b728429fb5449eec2bbc0b /app-accessibility
parentprofiles: Mask net-misc/fatrat for removal (diff)
downloadgentoo-eea1492c31992f2e69d7c4241557a330f3eaec52.tar.gz
gentoo-eea1492c31992f2e69d7c4241557a330f3eaec52.tar.bz2
gentoo-eea1492c31992f2e69d7c4241557a330f3eaec52.zip
app-accessibility/emacspeak: use elisp_src_compile
Closes: https://bugs.gentoo.org/947898 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/emacspeak/emacspeak-60.0-r1.ebuild (renamed from app-accessibility/emacspeak/emacspeak-60.0.ebuild)22
1 files changed, 17 insertions, 5 deletions
diff --git a/app-accessibility/emacspeak/emacspeak-60.0.ebuild b/app-accessibility/emacspeak/emacspeak-60.0-r1.ebuild
index 826442309b2e..556f5a80588f 100644
--- a/app-accessibility/emacspeak/emacspeak-60.0.ebuild
+++ b/app-accessibility/emacspeak/emacspeak-60.0-r1.ebuild
@@ -14,9 +14,9 @@ HOMEPAGE="http://emacspeak.sourceforge.net/
https://github.com/tvraman/emacspeak/"
if [[ "${PV}" == 9999 ]] ; then
- EGIT_REPO_URI="https://github.com/tvraman/${PN}"
-
inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/tvraman/${PN}"
else
SRC_URI="https://github.com/tvraman/${PN}/releases/download/${PV}/${P}.tar.bz2"
@@ -43,11 +43,18 @@ As of version 39.0 and later, the /usr/bin/emacspeak
shell script has been removed downstream in Gentoo.
You should launch emacspeak by another method, for instance by adding
the following to your init file (~/.emacs or ~/.config/emacs/init.el):
-(load "/usr/share/emacs/site-lisp/emacspeak/lisp/emacspeak.el")
+(load "/usr/share/emacs/site-lisp/emacspeak/lisp/emacspeak-setup.el")
'
HTML_DOCS=( etc/ info/ )
+src_prepare() {
+ elisp_src_prepare
+
+ # A Make rule will regenerate it.
+ rm ./lisp/emacspeak-loaddefs.el || die
+}
+
src_configure() {
MAKEOPTS+=" -j1 "
tc-export CXX
@@ -56,16 +63,21 @@ src_configure() {
}
src_compile() {
- emake -C lisp
emake README
+ cd "${S}/lisp" || die
+ emake emacspeak-loaddefs.el
+ local -x BYTECOMPFLAGS="-L . -l emacspeak-preamble.el -l emacspeak-loaddefs.el"
+ elisp_src_compile
+
if use espeak ; then
local tcl_version="$(echo 'puts $tcl_version;exit 0' |tclsh)"
+
if [[ -z ${tcl_version} ]]; then
die 'Unable to detect the installed version of dev-lang/tcl.'
fi
- cd servers/native-espeak || die
+ cd "${S}/servers/native-espeak" || die
emake TCL_VERSION="${tcl_version}"
fi
}