summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-accessibility/sound-icons
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-accessibility/sound-icons')
-rw-r--r--app-accessibility/sound-icons/Manifest1
-rw-r--r--app-accessibility/sound-icons/metadata.xml11
-rw-r--r--app-accessibility/sound-icons/sound-icons-0.1.ebuild29
3 files changed, 41 insertions, 0 deletions
diff --git a/app-accessibility/sound-icons/Manifest b/app-accessibility/sound-icons/Manifest
new file mode 100644
index 000000000000..81b11e18fe7a
--- /dev/null
+++ b/app-accessibility/sound-icons/Manifest
@@ -0,0 +1 @@
+DIST sound-icons-0.1.tar.gz 591196 SHA256 382dda1d14a07b3125a8b5084695aa9ba5cb0fff02e5aab69fd6c7e23cbcf4d7 SHA512 f0ba9e1e84ace325671c7f323f01d647aa0e1a318e9adc2a6d8af4e0d795e478b2ea66007670f9c7ced9ef7310fdbccb5168b0f404579f5dff8712fe12ad93a0 WHIRLPOOL cacf8afc80819d99fed82a91ec2e82bee9f096483b7334364294bbd5c016e80f9f1fa200416f86c9dc54a8799824eaee7db1eec3c8ca0c506b7a784e2761a70e
diff --git a/app-accessibility/sound-icons/metadata.xml b/app-accessibility/sound-icons/metadata.xml
new file mode 100644
index 000000000000..04c0d89a3a64
--- /dev/null
+++ b/app-accessibility/sound-icons/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>accessibility</herd>
+<maintainer>
+ <email>williamh@gentoo.org</email>
+</maintainer>
+<longdescription lang="en">
+This is a collection of sound icons which can be used by speech dispatcher.
+</longdescription>
+</pkgmetadata>
diff --git a/app-accessibility/sound-icons/sound-icons-0.1.ebuild b/app-accessibility/sound-icons/sound-icons-0.1.ebuild
new file mode 100644
index 000000000000..c49a2f2c88a4
--- /dev/null
+++ b/app-accessibility/sound-icons/sound-icons-0.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="a collection of Sound Icons for speech-dispatcher"
+HOMEPAGE="http://www.freebsoft.org"
+SRC_URI="http://www.freebsoft.org/pub/projects/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE=""
+
+RDEPEND="app-accessibility/speech-dispatcher"
+
+src_compile(){
+ einfo "Nothing to compile."
+}
+
+src_install() {
+ dodoc README
+ insinto /usr/share/sounds/sound-icons
+ doins "${S}"/*.wav
+ links="`find ${S} -type l -print`"
+ for link in $links; do
+ target=`readlink -n $link`
+ dosym $target /usr/share/sounds/sound-icons/`basename $link`
+ done
+}