summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-10-07 20:52:49 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-10-07 21:57:22 +0200
commitfeed1bbd0a2b081dc310a82db542d8d043ccba9c (patch)
tree56fa0a03460faec9883b3f05fb8025ddc704ee19
parentkde-apps/poxml: 21.08.2 version bump (diff)
downloadgentoo-feed1bbd0a2b081dc310a82db542d8d043ccba9c.tar.gz
gentoo-feed1bbd0a2b081dc310a82db542d8d043ccba9c.tar.bz2
gentoo-feed1bbd0a2b081dc310a82db542d8d043ccba9c.zip
kde-apps/umbrello: 21.08.2 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-apps/umbrello/Manifest1
-rw-r--r--kde-apps/umbrello/umbrello-21.08.2.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/kde-apps/umbrello/Manifest b/kde-apps/umbrello/Manifest
index de1505bb7599..f1bc6764fb6b 100644
--- a/kde-apps/umbrello/Manifest
+++ b/kde-apps/umbrello/Manifest
@@ -1,2 +1,3 @@
DIST umbrello-21.04.3.tar.xz 5650032 BLAKE2B b306695798eb2791968b9b4ad98b34825c8712800fbf2a87a2f6398768cf9bcee1e94dd1efa8d513f2cb8f07f683ee880c8e655236d88b96c3c1bcc98929af6d SHA512 f4f632bf37f4170ebf6c1d776b70b058ded1c8a1a9626adea1c9b63e7d7cf45c0afaf77c4c9bf778c601265b9d819f5a898813ac32b58bcf29d7ab94c753d73d
DIST umbrello-21.08.1.tar.xz 5650000 BLAKE2B 5abae7ffd82bdb71633d9a0ea4f354c93e9123e1d812e939c0010ca2ec6f71ae4ff06ee9264e9c530780acdeae2ec3349b9b6c9aff6f035b51c7ea2ee99d6bff SHA512 9ccba7ba2ac59df91d930baeca1e8841e31d790f6a590c8a03fd8a1e65818f7376281d6fe6770f0f60fd6f5958b8196a3dfe409a5e886becc864f18cc715a19d
+DIST umbrello-21.08.2.tar.xz 5650252 BLAKE2B a67d35bca086f26e343629eab2431a615bebf3a6d5a2990ff856ba42b0368862881576ca7ea511d571a74eba3b04b37747569677b817f5ce41f84d542ec2adb5 SHA512 90498caf980cd468b307c7e206621933a03402109fb1dd9b30f9a76cb86bb64993fc8eb4b3dc17fff63bf1e72d16ba4e0f0065fa3c97a0b42065b2470d6035b1
diff --git a/kde-apps/umbrello/umbrello-21.08.2.ebuild b/kde-apps/umbrello/umbrello-21.08.2.ebuild
new file mode 100644
index 000000000000..8681fe2a91bf
--- /dev/null
+++ b/kde-apps/umbrello/umbrello-21.08.2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="forceoptional"
+ECM_QTHELP="false" # TODO: figure out install error
+ECM_TEST="forceoptional"
+KFMIN=5.84.0
+QTMIN=5.15.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="KDE UML Modeller"
+HOMEPAGE="https://apps.kde.org/umbrello/ https://umbrello.kde.org"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="php"
+
+RDEPEND="
+ dev-libs/libxml2
+ dev-libs/libxslt
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtprintsupport-${QTMIN}:5
+ >=dev-qt/qtsvg-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ >=kde-frameworks/karchive-${KFMIN}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kcrash-${KFMIN}:5
+ >=kde-frameworks/kdelibs4support-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kjobwidgets-${KFMIN}:5
+ >=kde-frameworks/ktexteditor-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ php? (
+ dev-util/kdevelop:5=
+ dev-util/kdevelop-pg-qt:5
+ dev-util/kdevelop-php:5
+ )
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-20.08.3-no-qtwebkit.patch
+ "${FILESDIR}"/${PN}-20.08.3-gentoo-docbundledir.patch # fix hardcoded path
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_Doxygen=ON # broken, re-enable w/ ECM_QTHELP
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt5WebKitWidgets=ON
+ -DBUILD_APIDOC=OFF
+ -DBUILD_KF5=ON
+ -DBUILD_PHP_IMPORT=$(usex php)
+ -DBUILD_unittests=$(usex test)
+ )
+ use test && mycmakeargs+=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_LLVM=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_Clang=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_CLANG=ON
+ )
+
+ ecm_src_configure
+}