summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-18 06:25:33 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-18 06:25:33 +0100
commitf982067cfba95b10d501da6f36b757d9864e6895 (patch)
tree0a875118a54af60e2b372c7236488c34fa823d8e
parentsys-devel/gcc: add 12.3.1_p20231117 (diff)
downloadgentoo-f982067cfba95b10d501da6f36b757d9864e6895.tar.gz
gentoo-f982067cfba95b10d501da6f36b757d9864e6895.tar.bz2
gentoo-f982067cfba95b10d501da6f36b757d9864e6895.zip
dev-python/botocore: Bump to 1.32.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.32.3.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 9c483a32af5b..b61177cef1d0 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -4,3 +4,4 @@ DIST botocore-1.31.85.gh.tar.gz 12070341 BLAKE2B b4867e351d209511db263654873f5a8
DIST botocore-1.32.0.gh.tar.gz 12086167 BLAKE2B 54e580c4d034b437d1e2e7748f1dd4785354db87459116565bc15d60bd73fe5d46cade212fd44fabd243614f3be55d9eeaef575ea6d6312ad83c0b6c1e741515 SHA512 9aba3cc3f823ba47ee7964517189d1227e5934c63ecdf1631ade59524594fb7cc20b9cfc7060dd8a69648d48e2d1ede0a377f204124d06ef843dd98a4cd1b11f
DIST botocore-1.32.1.gh.tar.gz 12098630 BLAKE2B 3a2501da4bd2ec8d29f032a2df4d7946840682df426b4496f60bab487b0eb47580314b4c3029dded6a589463a8636c362c560fd4c2da02c113647ee10ebf079d SHA512 4ec58dcf896ef46f27f3c4af7c6e58efad62e5c2e3fb9aa8de9a90ee390d65b036116d9d8ba7c766b95b03e6e85e909cc620b838511152004dbcfb67968525b4
DIST botocore-1.32.2.gh.tar.gz 12148168 BLAKE2B 29a70ed37526b8b5e3439a183b194d350505dd4ad0ac1e5d2ff729be29813b4b99b2b0806ca2f20a776efdcefc2b46295432af281e026ecf014fe45d5317c528 SHA512 775c5076e691605d6efe392e5565b84314ed7c93300ea394e5598ee34f4bb9e708a2c8479fbd646fdb619d36e0122fd4f6854e9ed40430c069677345bd76e335
+DIST botocore-1.32.3.gh.tar.gz 12176739 BLAKE2B b119a54fb4770757c8f2c75b7404e009be1c7b35598d8a97e892aa644bbcc301b5f6bb44fa0f37bc8f4523af5ca9771daeda877937e640dd557038c8283967e1 SHA512 398127e140edc33750553f33a14cdc140048f5ee03c162705c6681b9bf08d871c9ba29f824ba2b6f1b11592260c6f0614ab4c06464cdda98172e8ca81bce73e9
diff --git a/dev-python/botocore/botocore-1.32.3.ebuild b/dev-python/botocore/botocore-1.32.3.ebuild
new file mode 100644
index 000000000000..05766e84276c
--- /dev/null
+++ b/dev-python/botocore/botocore-1.32.3.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ local -x EPYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}