summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-07-01 11:12:27 +0200
committerHans de Graaff <graaff@gentoo.org>2022-07-01 14:57:44 +0200
commitf43b1126e38691081164bcf1c186051f808ab8ea (patch)
tree394abe69ef1658804543df899c57009fa3ecdf8f
parentdev-ruby/recog: add 3.0.1 (diff)
downloadgentoo-f43b1126e38691081164bcf1c186051f808ab8ea.tar.gz
gentoo-f43b1126e38691081164bcf1c186051f808ab8ea.tar.bz2
gentoo-f43b1126e38691081164bcf1c186051f808ab8ea.zip
dev-ruby/coercible: add 1.0.0_p20200116
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/coercible/Manifest1
-rw-r--r--dev-ruby/coercible/coercible-1.0.0_p20200116.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/coercible/Manifest b/dev-ruby/coercible/Manifest
index a4a39c67364f..3aeb533becc1 100644
--- a/dev-ruby/coercible/Manifest
+++ b/dev-ruby/coercible/Manifest
@@ -1 +1,2 @@
DIST coercible-1.0.0.gem 24064 BLAKE2B 5f9708211600621869e78742dc5421672f27162c1e09e703bb2954d67b2ad281ddf59f9ecb28722f4423cbd0c7fc8bc14bda0f1f064135cbefc24ddb94ab1648 SHA512 5de43166625cca102cd048ae5cd4113ef834b273fb798490a99eeaab423174f1fa40410546de4e0224234efb996a4aa1f2c37b093298f50356f925b8a6163767
+DIST coercible-1.0.0_p20200116.tar.gz 18949 BLAKE2B 92c4b2a38ac662d270aacd2d46216c188fef12b99f0a54c2642d96f72e5d45fac895c8e0c1d4300784e754f384eb86a9731c32a9780af9877668251fa39eca57 SHA512 27c563a70a028af0fdcf72200b47e29b4eb312539d16634b9533140903504a42284ff31fe73286b0944129b6481614184c2966f47b82d08ac419bdadb862f5ea
diff --git a/dev-ruby/coercible/coercible-1.0.0_p20200116.ebuild b/dev-ruby/coercible/coercible-1.0.0_p20200116.ebuild
new file mode 100644
index 000000000000..8ab84b741a99
--- /dev/null
+++ b/dev-ruby/coercible/coercible-1.0.0_p20200116.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_EXTRADOC="README.md Changelog.md"
+RUBY_FAKEGEM_GEMSPEC="coercible.gemspec"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+COMMIT=c076869838531abb5783280da108aa3cbddbd61a
+
+inherit ruby-fakegem
+
+DESCRIPTION="Powerful, flexible and configurable coercion library"
+HOMEPAGE="https://github.com/solnic/coercible https://rubygems.org/gems/coercible"
+SRC_URI="https://github.com/solnic/coercible/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+RUBY_S="${PN}-${COMMIT}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/descendants_tracker-0.0.1
+ <dev-ruby/descendants_tracker-0.1"
+
+all_ruby_prepare() {
+ sed -i -e 's/git ls-files/find * -print/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}