summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-01-23 22:21:31 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-01-23 23:06:56 +0100
commitf29caf8ed92b86cf94ae6462de8a4c8233662111 (patch)
tree882bd4126c2bc837bed95b4720fdb79ad64283d8
parentapp-containers/devcontainer: drop old 0.54.2 (diff)
downloadgentoo-f29caf8ed92b86cf94ae6462de8a4c8233662111.tar.gz
gentoo-f29caf8ed92b86cf94ae6462de8a4c8233662111.tar.bz2
gentoo-f29caf8ed92b86cf94ae6462de8a4c8233662111.zip
app-containers/devcontainer: bump to 0.56.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-containers/devcontainer/Manifest1
-rw-r--r--app-containers/devcontainer/devcontainer-0.56.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/app-containers/devcontainer/Manifest b/app-containers/devcontainer/Manifest
index 787d7a49c7ef..3a461946a079 100644
--- a/app-containers/devcontainer/Manifest
+++ b/app-containers/devcontainer/Manifest
@@ -1,2 +1,3 @@
DIST devcontainer-0.55.0.tgz 604221 BLAKE2B e369e20b19dc780f7543f409ac04a46f432a9c007d4976dcb34829ede883424fb9496f6b7a50d047665fd4cba4b45c7ae1bc3372720f0b1dc65a8085d06a9287 SHA512 53bc02b7cdb04f7901f3c74d0a26d466231f4bc7f0e53de25c786a9ecb3b774a09b14e47e36470538560893fc6c7ec6bf9b19345e0d6bf0ff3b9db329f21e8cd
DIST devcontainer-0.56.0.tgz 604266 BLAKE2B 5dd79411905f7d1fdb9c0998d4729aed60d15c1c337327d9e6e95d32c22453f7fe44ff6bc01416f81a1939140444072b7ade09f29419bd53392428595bc54d10 SHA512 46760fc8f2bba5349d7ac6e6d599a326579d3ace5ed26223abae8b6f5e328ee9bf9a49c6b3c31abcee4a828c80c906e06ecb217c18c46e28d5736e082ffb8d18
+DIST devcontainer-0.56.1.tgz 604649 BLAKE2B 887a034a9771843ce84be1b78d00ba7b52d09b64861f113d27e0dd662acabf175d4e7922a25826f2bf500ecc380473381ec05e307af0b7655535188240582700 SHA512 22f2d911b021f16181a1d954b31beaf323a84296be03489b6375729ea3ebcb198d58d3f731c40b8ec5ee20bfe26a933db1328a2d5278fa76686d965487924261
diff --git a/app-containers/devcontainer/devcontainer-0.56.1.ebuild b/app-containers/devcontainer/devcontainer-0.56.1.ebuild
new file mode 100644
index 000000000000..991cd956e37b
--- /dev/null
+++ b/app-containers/devcontainer/devcontainer-0.56.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Reference implementation of the Development Containers specification"
+HOMEPAGE="https://containers.dev/
+ https://github.com/devcontainers/cli/"
+SRC_URI="https://registry.npmjs.org/@devcontainers/cli/-/cli-${PV}.tgz
+ -> ${P}.tgz"
+S="${WORKDIR}/package"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ net-libs/nodejs
+"
+BDEPEND="
+ >=net-libs/nodejs-16[npm]
+"
+
+DOCS=( CHANGELOG.md README.md )
+
+src_compile() {
+ # Skip, nothing to compile here.
+ :
+}
+
+src_install() {
+ local -a my_npm_opts=(
+ --audit false
+ --color false
+ --foreground-scripts
+ --global
+ --offline
+ --omit dev
+ --prefix "${ED}/usr"
+ --progress false
+ --verbose
+ )
+ npm "${my_npm_opts[@]}" install "${DISTDIR}/${P}.tgz" || die "npm install failed"
+
+ einstalldocs
+}