summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository QA checks <repo-qa-checks@gentoo.org>2017-01-07 10:49:21 +0000
committerRepository QA checks <repo-qa-checks@gentoo.org>2017-01-07 10:49:21 +0000
commitf13b91495125f2f0a5235e2b83e0c4fd07c3d574 (patch)
treeabc47f7f701424164c293ee2fbe25439570a3df3
parent2017-01-07 10:12:21 UTC (diff)
parentnet-analyzer/suricata: fixing error with logrotate file (diff)
downloadgentoo-f13b91495125f2f0a5235e2b83e0c4fd07c3d574.tar.gz
gentoo-f13b91495125f2f0a5235e2b83e0c4fd07c3d574.tar.bz2
gentoo-f13b91495125f2f0a5235e2b83e0c4fd07c3d574.zip
Merge updates from master
-rw-r--r--eclass/cmake-utils.eclass7
-rw-r--r--net-analyzer/suricata/suricata-3.2-r1.ebuild4
2 files changed, 6 insertions, 5 deletions
diff --git a/eclass/cmake-utils.eclass b/eclass/cmake-utils.eclass
index 1b269dd6d134..099aaac7b26f 100644
--- a/eclass/cmake-utils.eclass
+++ b/eclass/cmake-utils.eclass
@@ -117,7 +117,7 @@ case ${EAPI} in
*) die "EAPI=${EAPI:-0} is not supported" ;;
esac
-inherit toolchain-funcs multilib flag-o-matic eutils versionator
+inherit toolchain-funcs multilib flag-o-matic eutils multiprocessing versionator
EXPORT_FUNCTIONS src_prepare src_configure src_compile src_test src_install
@@ -780,8 +780,9 @@ enable_cmake-utils_src_test() {
[[ -n ${TEST_VERBOSE} ]] && myctestargs+=( --extra-verbose --output-on-failure )
- echo ctest "${myctestargs[@]}" "$@"
- if ctest "${myctestargs[@]}" "$@" ; then
+ set -- ctest -j "$(makeopts_jobs)" --test-load "$(makeopts_loadavg)" "${myctestargs[@]}" "$@"
+ echo "$@" >&2
+ if "$@" ; then
einfo "Tests succeeded."
popd > /dev/null || die
return 0
diff --git a/net-analyzer/suricata/suricata-3.2-r1.ebuild b/net-analyzer/suricata/suricata-3.2-r1.ebuild
index 0d4739e63092..9d39b833eeab 100644
--- a/net-analyzer/suricata/suricata-3.2-r1.ebuild
+++ b/net-analyzer/suricata/suricata-3.2-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -130,7 +130,7 @@ src_install() {
if use logrotate; then
insopts -m0644
insinto /etc/logrotate.d
- newins "${FILESDIR}"/${PN}.logrotate ${PN}
+ newins "${FILESDIR}"/${PN}-logrotate ${PN}
fi
}