summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2025-02-08 23:48:27 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2025-02-08 23:48:27 +0000
commiteefbbd372ec4fb5b6e5ecdb0ae35228a329569f6 (patch)
tree697f98352b6068d2948612e636899a936e87e335
parent2025-02-08 23:18:32 UTC (diff)
parentdev-libs/bglibs: disable the one failing network test (diff)
downloadgentoo-eefbbd372ec4fb5b6e5ecdb0ae35228a329569f6.tar.gz
gentoo-eefbbd372ec4fb5b6e5ecdb0ae35228a329569f6.tar.bz2
gentoo-eefbbd372ec4fb5b6e5ecdb0ae35228a329569f6.zip
Merge updates from master
-rw-r--r--dev-libs/bglibs/bglibs-2.04-r3.ebuild15
1 files changed, 14 insertions, 1 deletions
diff --git a/dev-libs/bglibs/bglibs-2.04-r3.ebuild b/dev-libs/bglibs/bglibs-2.04-r3.ebuild
index cf69431cce50..1327b6161114 100644
--- a/dev-libs/bglibs/bglibs-2.04-r3.ebuild
+++ b/dev-libs/bglibs/bglibs-2.04-r3.ebuild
@@ -34,9 +34,22 @@ PATCHES=(
src_prepare() {
default
- # disable tests as we want them manually
+
+ # Remove the tests from the default target so that we can run
+ # them only when the user has enabled them.
sed -i '/^all:/s|selftests||' Makefile || die
sed -i '/selftests/d' TARGETS || die
+
+ # The selftests.sh script collects the list of tests to run by
+ # grepping for "#ifdef SELFTEST_MAIN", which is defined in each *.c
+ # file to be tested. We can therefore disable individual tests by
+ # clobbering that line. (This should be safe; the contents of that
+ # ifdef are the test program, which we are disabling anyway.)
+ #
+ # This test requires network access, and currently fails even
+ # if you have it (https://github.com/bruceg/bglibs/issues/5).
+ sed -e 's/#ifdef SELFTEST_MAIN/#ifdef UNDEFINED/' \
+ -i net/resolve_ipv4addr.c || die
}
src_configure() {