summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-04-16 18:11:27 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-04-16 18:36:15 +0300
commite8da2a528a561b7eb82539cecfab20b861d04226 (patch)
treebd3efbcf27abbfca9ccc8f9ad36aea44b57813cd
parentdev-python/cssselect2: add 0.6.0 (diff)
downloadgentoo-e8da2a528a561b7eb82539cecfab20b861d04226.tar.gz
gentoo-e8da2a528a561b7eb82539cecfab20b861d04226.tar.bz2
gentoo-e8da2a528a561b7eb82539cecfab20b861d04226.zip
dev-python/pyamg: add 4.2.3
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/pyamg/Manifest1
-rw-r--r--dev-python/pyamg/pyamg-4.2.3.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pyamg/Manifest b/dev-python/pyamg/Manifest
index 70c507a67c10..48e0aaa3ffbc 100644
--- a/dev-python/pyamg/Manifest
+++ b/dev-python/pyamg/Manifest
@@ -1,3 +1,4 @@
DIST pyamg-4.1.0.tar.gz 749906 BLAKE2B 31c05d64317b32cbdbd616e982557f0a94bc17b2fce3d982fe93e629d56ad526516603032b3cba9785bf5ebed038481ae641f55a5a1ad621442dde08791981cb SHA512 311642cbbe8dca621cb58bebb1bb05b7dc7b2364713886df96937ba56575137bcb4fb7006a232d2c14380cd41f4337f6f09a8a9794e279a155f27287497d2b08
DIST pyamg-4.2.1.gh.tar.gz 3900395 BLAKE2B ad4427eb297f044b4782274ce55799bd9da4abec108267c4c0aaedab38e2fb4d89c4c365eca90e4045c411254640ead667fa0e511d9597ff00081c0ebacde9b2 SHA512 933f5f1da808cb02ff5fa91df54a48a971bb3b017582f5a829cf71c94f698469476b9f0306962140dc38f7265266c9b53f98dc7aaa99945b45bfa83003d26df9
DIST pyamg-4.2.2.gh.tar.gz 3900331 BLAKE2B 34858026eb9e1eff20101e3ef810e7f3fed40e5b363c3a0858189276259576b8abe4d2a46fc386a1d759eff724bb8b7814944d08fd555783cf33e908a05812f0 SHA512 f9f18df8b34f240be7e738f1e0f74f348d718f63bb7a32bf0c78158e2ace985d60fc182beee5a9e75248aad3fafe0525a6f41b3acc356c52ce15b52730cbd970
+DIST pyamg-4.2.3.gh.tar.gz 4101959 BLAKE2B 190cce0bb06bbfc09e8c7a8d6d70498308e4d0e098c23a12d12ae8373b56ef183694430c1f85e287682f9733e3f85ff2bd94d8e10003f578af32f3c3f583a8f4 SHA512 ad11ed2870de41bb9596167a5a7fc3edd4c4bc898c2f5b5ffa3cfa862372d993fe1adfc5f3d199150ba69a4d2acbf75e5d99b3aa872273da0d05f1fd8d9f5c6d
diff --git a/dev-python/pyamg/pyamg-4.2.3.ebuild b/dev-python/pyamg/pyamg-4.2.3.ebuild
new file mode 100644
index 000000000000..3b4aa574d96e
--- /dev/null
+++ b/dev-python/pyamg/pyamg-4.2.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Algebraic multigrid solvers in Python"
+HOMEPAGE="https://pyamg.org"
+SRC_URI="
+ https://github.com/pyamg/pyamg/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/pybind11[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ test? (
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ cd "${T}" || die
+ epytest --pyargs pyamg
+}