summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-08-28 07:13:01 +0200
committerHans de Graaff <graaff@gentoo.org>2023-08-28 11:25:29 +0200
commitdefc0ff301e2ba3e5a4f1af55487ae755a2cc5d4 (patch)
treea46bb6eee9ff96a60ea10cce3404229991a5ccfe
parentdev-ruby/webrick: drop 1.8.0 (diff)
downloadgentoo-defc0ff301e2ba3e5a4f1af55487ae755a2cc5d4.tar.gz
gentoo-defc0ff301e2ba3e5a4f1af55487ae755a2cc5d4.tar.bz2
gentoo-defc0ff301e2ba3e5a4f1af55487ae755a2cc5d4.zip
dev-ruby/vagrant_cloud: update EAPI 7 -> 8, add ruby32
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/vagrant_cloud/vagrant_cloud-3.0.5-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-ruby/vagrant_cloud/vagrant_cloud-3.0.5-r1.ebuild b/dev-ruby/vagrant_cloud/vagrant_cloud-3.0.5-r1.ebuild
new file mode 100644
index 000000000000..9c8b674c0db5
--- /dev/null
+++ b/dev-ruby/vagrant_cloud/vagrant_cloud-3.0.5-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_GEMSPEC="vagrant_cloud.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Vagrant Cloud API Library"
+HOMEPAGE="https://github.com/hashicorp/vagrant_cloud"
+SRC_URI="https://github.com/hashicorp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="test"
+
+ruby_add_rdepend "
+ >=dev-ruby/excon-0.73
+ >=dev-ruby/log4r-1.1.10
+"
+ruby_add_bdepend ">=dev-ruby/rake-12.3
+ test? (
+ >=dev-ruby/webmock-3.0
+ )
+"
+
+all_ruby_prepare() {
+ # # loosen dependencies
+ sed -e 's:require_relative ":require "./:' \
+ -e '/excon/s/~>/>=/' \
+ -e '/log4r/s/~>/>=/' \
+ -e '/rake/s/~>/>=/' \
+ -e '/rspec/s/~>/>=/' \
+ -e '/webmock/s/~>/>=/' \
+ -i ${PN}.gemspec || die
+}