summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository QA checks <repo-qa-checks@gentoo.org>2016-06-10 17:01:54 +0000
committerRepository QA checks <repo-qa-checks@gentoo.org>2016-06-10 17:01:54 +0000
commitdc552a9fb40685601e7d3c9fec567cf334f6b011 (patch)
treed782524f931181ff5f6cd87e1c5bf6448cc7aa66
parent2016-06-10 16:22:13 UTC (diff)
parentnet-nds/389-ds-base: live ebuild for upstream's git repo Live ebuild for buil... (diff)
downloadgentoo-dc552a9fb40685601e7d3c9fec567cf334f6b011.tar.gz
gentoo-dc552a9fb40685601e7d3c9fec567cf334f6b011.tar.bz2
gentoo-dc552a9fb40685601e7d3c9fec567cf334f6b011.zip
Merge updates from master
-rw-r--r--app-editors/atom/atom-1.7.4-r2.ebuild (renamed from app-editors/atom/atom-1.7.4-r1.ebuild)57
-rw-r--r--app-editors/atom/files/atom-apm-path.patch4
-rw-r--r--dev-python/pbr/pbr-1.10.0.ebuild1
-rw-r--r--media-gfx/displaycal/Manifest1
-rw-r--r--media-gfx/displaycal/displaycal-3.1.3.1.ebuild79
-rw-r--r--net-nds/389-ds-base/389-ds-base-1.3.5.4.ebuild126
-rw-r--r--net-nds/389-ds-base/389-ds-base-9999.ebuild127
-rw-r--r--net-nds/389-ds-base/Manifest1
-rw-r--r--sys-kernel/rt-sources/Manifest2
-rw-r--r--sys-kernel/rt-sources/rt-sources-4.4.12_p19.ebuild46
10 files changed, 420 insertions, 24 deletions
diff --git a/app-editors/atom/atom-1.7.4-r1.ebuild b/app-editors/atom/atom-1.7.4-r2.ebuild
index c45728cce2a3..68fb871efdc1 100644
--- a/app-editors/atom/atom-1.7.4-r1.ebuild
+++ b/app-editors/atom/atom-1.7.4-r2.ebuild
@@ -5,7 +5,7 @@
EAPI=6
PYTHON_COMPAT=( python2_7 )
-inherit flag-o-matic python-any-r1 eutils rpm
+inherit flag-o-matic python-any-r1 eutils multiprocessing rpm
DESCRIPTION="A hackable text editor for the 21st Century"
HOMEPAGE="https://atom.io"
@@ -274,7 +274,7 @@ src_prepare() {
_s="${WORKDIR}/$(package_dir asar)"
"${_s}"/node_modules/asar/bin/asar \
extract "${S}/usr/share/atom/resources/app.asar" \
- "${S}/build/app.asar" || die
+ "${S}/build/app" || die
cd "${S}" || die
@@ -282,7 +282,7 @@ src_prepare() {
epatch "${FILESDIR}/asar-require.patch"
sed -i -e "s|{{ATOM_SUFFIX}}|${suffix}|g" \
- "${S}/build/app.asar/src/config-schema.js" || die
+ "${S}/build/app/src/config-schema.js" || die
eapply_user
}
@@ -310,6 +310,14 @@ src_configure() {
src_compile() {
local binmod _s x nodegyp="/usr/$(get_libdir)/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js"
+ local ctags_d="node_modules/symbols-view/vendor"
+ local jobs=$(makeopts_jobs) gypopts
+
+ gypopts="--nodedir=/usr/include/electron/node/ --verbose"
+
+ if [[ ${MAKEOPTS} == *-j* && ${jobs} != 999 ]]; then
+ gypopts+=" --jobs ${jobs}"
+ fi
mkdir -p "${S}/build/modules/" || die
@@ -317,17 +325,33 @@ src_compile() {
einfo "Building ${binmod}..."
_s="${WORKDIR}/$(package_dir ${binmod})"
cd "${_s}" || die
- "${nodegyp}" --nodedir=/usr/include/electron/node/ --verbose build || die
+ "${nodegyp}" ${gypopts} build || die
x=${binmod##node-}
mkdir -p "${S}/build/modules/${x}"
cp build/Release/*.node "${S}/build/modules/${x}"
done
+ # Put compiled binary modules in place
+ _fix_binmods "${S}/build" "app"
+ _fix_binmods "${S}/usr/share/atom/resources" "app"
+
+ # Remove non-Linux vendored ctags binaries
+ rm "${S}/build/app/${ctags_d}/ctags-darwin" \
+ "${S}/build/app/${ctags_d}/ctags-win32.exe" || die
+
# Re-pack app.asar
- _s="${WORKDIR}/$(package_dir asar)"
- "${_s}"/node_modules/asar/bin/asar \
- pack "${S}/build/app.asar" \
- "${S}/usr/share/atom/resources/app.asar" || die
+ # Keep unpack rules in sync with build/tasks/generate-asar-task.coffee
+ x="--unpack={*.node,ctags-config,ctags-linux,**/node_modules/spellchecker/**,**/resources/atom.png}"
+ _s="${WORKDIR}/$(package_dir asar)/node_modules/asar/bin"
+ cd "${S}/build" || die
+ echo "asar" pack "${x}" "app" "app.asar"
+ "${_s}/asar" pack "${x}" "app" "app.asar" || die
+ cd "${S}" || die
+
+ # Replace vendored ctags with a symlink to system ctags
+ rm "${S}/build/app.asar.unpacked/${ctags_d}/ctags-linux" || die
+ ln -s "/usr/bin/ctags" \
+ "${S}/build/app.asar.unpacked/${ctags_d}/ctags-linux" || die
}
_fix_binmods() {
@@ -345,7 +369,7 @@ _fix_binmods() {
mod=$(basename ${modpath})
# must copy here as symlinks will cause the module loading to fail
- cp "${ED}/${install_dir}/modules/${mod}/${f}" "${path}" || die
+ cp -f "${S}/build/modules/${mod}/${f}" "${path}" || die
cruft=$(find "${d}" -name '*.a' -print)
if [ -n "${cruft}" ]; then
rm ${cruft} || die
@@ -356,25 +380,14 @@ _fix_binmods() {
src_install() {
local install_dir="$(get_install_dir)"
local suffix="$(get_install_suffix)"
- local ctags_d="${ED}/${install_dir}/app.asar.unpacked/node_modules/symbols-view/vendor"
cd "${S}" || die
insinto "${install_dir}"
- doins -r build/modules
- doins usr/share/atom/resources/app.asar
+ doins build/app.asar
+ doins -r build/app.asar.unpacked
doins -r usr/share/atom/resources/app
- doins -r usr/share/atom/resources/app.asar.unpacked
-
- _fix_binmods "${ED}/${install_dir}" "app"
- _fix_binmods "${ED}/${install_dir}" "app.asar.unpacked"
-
- rm -r "${ED}/${install_dir}/modules" || die
-
- # Remove vendored ctags binary and replace with a symlink to system ctags
- rm "${ctags_d}"/* || die
- ln -s "/usr/bin/ctags" "${ctags_d}/ctags-linux" || die
insinto /usr/share/applications/
newins usr/share/applications/atom.desktop "atom${suffix}.desktop"
diff --git a/app-editors/atom/files/atom-apm-path.patch b/app-editors/atom/files/atom-apm-path.patch
index 8746b95e24fa..957fed4b71bd 100644
--- a/app-editors/atom/files/atom-apm-path.patch
+++ b/app-editors/atom/files/atom-apm-path.patch
@@ -1,5 +1,5 @@
---- build/app.asar/src/config-schema.js.orig 2016-05-24 16:59:41.284449076 -0400
-+++ build/app.asar/src/config-schema.js 2016-05-24 17:01:05.685447769 -0400
+--- build/app/src/config-schema.js.orig 2016-05-24 16:59:41.284449076 -0400
++++ build/app/src/config-schema.js 2016-05-24 17:01:05.685447769 -0400
@@ -9,6 +9,11 @@
core: {
type: 'object',
diff --git a/dev-python/pbr/pbr-1.10.0.ebuild b/dev-python/pbr/pbr-1.10.0.ebuild
index 64ff796cf12b..bb13095f596f 100644
--- a/dev-python/pbr/pbr-1.10.0.ebuild
+++ b/dev-python/pbr/pbr-1.10.0.ebuild
@@ -36,6 +36,7 @@ DEPEND="
>=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
>=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
dev-python/virtualenv[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
dev-vcs/git
)"
PDEPEND=""
diff --git a/media-gfx/displaycal/Manifest b/media-gfx/displaycal/Manifest
index 60fffe126e6f..164e02401cd8 100644
--- a/media-gfx/displaycal/Manifest
+++ b/media-gfx/displaycal/Manifest
@@ -1,2 +1,3 @@
DIST DisplayCAL-3.0.6.0.tar.gz 16228 SHA256 ff19c4299e33a587103ab475d136e446bfc7a5b631c8b90563227fe6b9898077 SHA512 003110ddb26b01e1517a2605d341649600b64dfa4b55c3cb8e38b5160c5d2b0d876ae76e6a5b4571740b0030c3c713958bc1d7723d5c0c31e626ac4c702e91ee WHIRLPOOL 30ebaf130f0ae3765fd2ada8852d4bd9443ce24b3b53cdd3c111abe9d5b4715e42214ddf69747b2dc806f119106f93436d3f894fc0dcf00c5748b701f08af8a7
DIST DisplayCAL-3.1.2.0.tar.gz 9361108 SHA256 78dbfd2be1cf7542657cc0f5ed9e16e27558206a4878ffae5ce68bd62460680d SHA512 2c14ed0230e6bdd6f8876a5e8887498e3005941e2f68aedad2926f9b8dda642e909f9aa70205977123b1b7c1376dd3f361ad08ecc5015bfae77342ff1b848837 WHIRLPOOL 74f311618190974e6e9c0c5b895ab7f0dba18de06e52dcf1cca4df0373a278b4c4e170b6add51bdf550b21499ff1ecf249cae6f2eb2f3e0813c666bd0bc4f941
+DIST DisplayCAL-3.1.3.1.tar.gz 9555280 SHA256 d48e0b12c0b4fe75e0c99eb5fd85c8651afc2c3a2e72d29ade9bb0a76e61f645 SHA512 ef560155cf0eebf4fcd9beab699afd6f0e766901e44d6aba8f33242662aae68a5644e6e253f3bdfe2bb687b30e967190ddf746ef4467c41c9cda06c6bd9326ef WHIRLPOOL b696c68d7b25388b51c056534ca37f7e14d0f918b2471cd1e6662cfadc186eb989ad9429c3a40bc74992c9352d762c40e05add69773a834e99971ac46339f015
diff --git a/media-gfx/displaycal/displaycal-3.1.3.1.ebuild b/media-gfx/displaycal/displaycal-3.1.3.1.ebuild
new file mode 100644
index 000000000000..0d69de973612
--- /dev/null
+++ b/media-gfx/displaycal/displaycal-3.1.3.1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 fdo-mime eutils
+
+MY_PN="DisplayCAL"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Display calibration and characterization powered by Argyll CMS"
+HOMEPAGE="https://displaycal.net/"
+SRC_URI="mirror://sourceforge/dispcalgui/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=media-gfx/argyllcms-1.1.0
+ dev-python/wxpython:2.8
+ >=x11-libs/libX11-1.3.3
+ >=x11-apps/xrandr-1.3.2
+ >=x11-libs/libXxf86vm-1.1.0
+ >=x11-proto/xineramaproto-1.2
+ >=x11-libs/libXinerama-1.1"
+RDEPEND="${DEPEND}
+ >=dev-python/numpy-1.2.1"
+
+# Just in case someone renames the ebuild
+S=${WORKDIR}/${MY_P}
+
+DOCS=(
+ README.html
+)
+
+src_prepare() {
+ # Prohibit setup from running xdg-* programs, resulting to sandbox violation
+ cd "${S}/DisplayCAL" || die "Cannot cd to source directory."
+ sed -e 's/if which(\"xdg-icon-resource\"):/if which(\"xdg-icon-resource-non-existant\"):/' \
+ -e 's/if which(\"xdg-desktop-menu\"):/if which(\"xdg-desktop-menu-non-existant\"):/' \
+ -i postinstall.py || die "sed'ing out the xdg-* setup functions failed"
+
+ # Remove deprecated Encoding key from .desktop file
+ cd "${S}" || die "Cannot cd to work directory."
+ for offendingFile in $(grep -r -l "Encoding=UTF-8" .); do
+ sed -e '/Encoding=UTF-8/d' -i "${offendingFile}" || \
+ die "removing deprecated Encoding key from .desktop files failed"
+ done
+
+ # Remove x-world Media Type
+ cd "${S}/misc" || die "Cannot cd to misc directory."
+ sed -e 's/x\-world\/x\-vrml\;//g' -i "displaycal-vrml-to-x3d-converter.desktop" \
+ || die "removing x-world media type failed"
+
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ distutils-r1_src_install
+ #remove udev files
+ rm -rf "${D}"/etc/udev/rules.d
+}
+
+pkg_postinst() {
+ # Run xdg-* programs the Gentoo way since we removed this
+ # functionality from the original package
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ # Run xdg-* programs the Gentoo way since we removed this
+ # functionality from the original package
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+}
diff --git a/net-nds/389-ds-base/389-ds-base-1.3.5.4.ebuild b/net-nds/389-ds-base/389-ds-base-1.3.5.4.ebuild
new file mode 100644
index 000000000000..36bf84266b2e
--- /dev/null
+++ b/net-nds/389-ds-base/389-ds-base-1.3.5.4.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WANT_AUTOMAKE="1.13"
+
+inherit user eutils multilib flag-o-matic autotools
+
+DESCRIPTION="389 Directory Server (core librares and daemons )"
+HOMEPAGE="http://port389.org/"
+SRC_URI="http://directory.fedoraproject.org/sources/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="autobind auto-dn-suffix debug doc +pam-passthru +dna +ldapi +bitwise +presence kerberos selinux"
+
+# Pinned to db:4.8 as it is the current stable, can change to a later db version < 6 when they stabilize.
+# The --with-db-inc line in econf will need to be updated as well when changing db version.
+COMMON_DEPEND="
+ sys-libs/db:4.8
+ >=dev-libs/cyrus-sasl-2.1.19
+ >=net-analyzer/net-snmp-5.1.2
+ >=dev-libs/icu-3.4:=
+ dev-libs/nss[utils]
+ dev-libs/nspr
+ >=dev-libs/svrcore-4.1.2
+ dev-libs/openssl:0=
+ dev-libs/libpcre:3
+ >=dev-perl/perl-mozldap-1.5.3
+ dev-perl/NetAddr-IP
+ net-nds/openldap
+ sys-libs/pam
+ sys-libs/zlib
+ kerberos? ( >=app-crypt/mit-krb5-1.7-r100[openldap] )"
+
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ sys-devel/libtool
+ doc? ( app-doc/doxygen )
+ sys-apps/sed"
+RDEPEND="${COMMON_DEPEND}
+ selinux? ( sec-policy/selinux-dirsrv )
+ virtual/perl-Time-Local
+ virtual/perl-MIME-Base64"
+
+pkg_setup() {
+ enewgroup dirsrv
+ enewuser dirsrv -1 -1 -1 dirsrv
+}
+
+src_prepare() {
+ # as per 389 documentation, when 64bit, export USE_64
+ use amd64 && export USE_64=1
+
+ eautoreconf
+
+ append-lfs-flags
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable pam-passthru) \
+ $(use_enable ldapi) \
+ $(use_enable autobind) \
+ $(use_enable dna) \
+ $(use_enable bitwise) \
+ $(use_enable presence) \
+ $(use_with kerberos) \
+ $(use_enable debug) \
+ $(use_enable auto-dn-suffix) \
+ --with-initddir=no \
+ --enable-maintainer-mode \
+ --with-fhs \
+ --with-openldap \
+ --sbindir=/usr/sbin \
+ --bindir=/usr/bin \
+ --with-db-inc=/usr/include/db4.8
+
+}
+
+src_compile() {
+ default
+ if use doc; then
+ doxygen slapi.doxy || die "cannot run doxygen"
+ fi
+}
+
+src_install () {
+ emake DESTDIR="${D}" install
+
+ # Install gentoo style init script
+ # Get these merged upstream
+ newinitd "${FILESDIR}"/389-ds.initd-r1 389-ds
+ newinitd "${FILESDIR}"/389-ds-snmp.initd 389-ds-snmp
+
+ # cope with libraries being in /usr/lib/dirsrv
+ dodir /etc/env.d
+ echo "LDPATH=/usr/$(get_libdir)/dirsrv" > "${D}"/etc/env.d/08dirsrv
+
+ if use doc; then
+ cd "${S}" || die
+ docinto html/
+ dodoc -r docs/html/.
+ fi
+}
+
+pkg_postinst() {
+ echo
+ elog "If you are planning to use 389-ds-snmp (ldap-agent),"
+ elog "make sure to properly configure: /etc/dirsrv/config/ldap-agent.conf"
+ elog "adding proper 'server' entries, and adding the lines below to"
+ elog " => /etc/snmp/snmpd.conf"
+ elog
+ elog "master agentx"
+ elog "agentXSocket /var/agentx/master"
+ elog
+ elog "To start 389 Directory Server (LDAP service) at boot:"
+ elog
+ elog " rc-update add 389-ds default"
+ elog
+ echo
+}
diff --git a/net-nds/389-ds-base/389-ds-base-9999.ebuild b/net-nds/389-ds-base/389-ds-base-9999.ebuild
new file mode 100644
index 000000000000..1413b667da06
--- /dev/null
+++ b/net-nds/389-ds-base/389-ds-base-9999.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+WANT_AUTOMAKE="1.13"
+
+inherit user eutils multilib flag-o-matic autotools git-r3
+
+DESCRIPTION="389 Directory Server (core librares and daemons )"
+HOMEPAGE="http://port389.org/"
+SRC_URI=""
+EGIT_REPO_URI="https://git.fedorahosted.org/git/389/ds.git"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE="autobind auto-dn-suffix debug doc +pam-passthru +dna +ldapi +bitwise +presence kerberos selinux"
+
+# Pinned to db:4.8 as it is the current stable, can change to a later db version < 6 when they stabilize.
+# The --with-db-inc line in econf will need to be updated as well when changing db version.
+COMMON_DEPEND="
+ sys-libs/db:4.8
+ >=dev-libs/cyrus-sasl-2.1.19
+ >=net-analyzer/net-snmp-5.1.2
+ >=dev-libs/icu-3.4:=
+ dev-libs/nss[utils]
+ dev-libs/nspr
+ >=dev-libs/svrcore-4.1.2
+ dev-libs/openssl:0=
+ dev-libs/libpcre:3
+ >=dev-perl/perl-mozldap-1.5.3
+ dev-perl/NetAddr-IP
+ net-nds/openldap
+ sys-libs/pam
+ sys-libs/zlib
+ kerberos? ( >=app-crypt/mit-krb5-1.7-r100[openldap] )"
+
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ sys-devel/libtool
+ doc? ( app-doc/doxygen )
+ sys-apps/sed"
+RDEPEND="${COMMON_DEPEND}
+ selinux? ( sec-policy/selinux-dirsrv )
+ virtual/perl-Time-Local
+ virtual/perl-MIME-Base64"
+
+pkg_setup() {
+ enewgroup dirsrv
+ enewuser dirsrv -1 -1 -1 dirsrv
+}
+
+src_prepare() {
+ # as per 389 documentation, when 64bit, export USE_64
+ use amd64 && export USE_64=1
+
+ eautoreconf
+
+ append-lfs-flags
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable pam-passthru) \
+ $(use_enable ldapi) \
+ $(use_enable autobind) \
+ $(use_enable dna) \
+ $(use_enable bitwise) \
+ $(use_enable presence) \
+ $(use_with kerberos) \
+ $(use_enable debug) \
+ $(use_enable auto-dn-suffix) \
+ --with-initddir=no \
+ --enable-maintainer-mode \
+ --with-fhs \
+ --with-openldap \
+ --sbindir=/usr/sbin \
+ --bindir=/usr/bin \
+ --with-db-inc=/usr/include/db4.8
+
+}
+
+src_compile() {
+ default
+ if use doc; then
+ doxygen slapi.doxy || die "cannot run doxygen"
+ fi
+}
+
+src_install () {
+ emake DESTDIR="${D}" install
+
+ # Install gentoo style init script
+ # Get these merged upstream
+ newinitd "${FILESDIR}"/389-ds.initd-r1 389-ds
+ newinitd "${FILESDIR}"/389-ds-snmp.initd 389-ds-snmp
+
+ # cope with libraries being in /usr/lib/dirsrv
+ dodir /etc/env.d
+ echo "LDPATH=/usr/$(get_libdir)/dirsrv" > "${D}"/etc/env.d/08dirsrv
+
+ if use doc; then
+ cd "${S}" || die
+ docinto html/
+ dodoc -r docs/html/.
+ fi
+}
+
+pkg_postinst() {
+ echo
+ elog "If you are planning to use 389-ds-snmp (ldap-agent),"
+ elog "make sure to properly configure: /etc/dirsrv/config/ldap-agent.conf"
+ elog "adding proper 'server' entries, and adding the lines below to"
+ elog " => /etc/snmp/snmpd.conf"
+ elog
+ elog "master agentx"
+ elog "agentXSocket /var/agentx/master"
+ elog
+ elog "To start 389 Directory Server (LDAP service) at boot:"
+ elog
+ elog " rc-update add 389-ds default"
+ elog
+ echo
+}
diff --git a/net-nds/389-ds-base/Manifest b/net-nds/389-ds-base/Manifest
index c2107aa2a64f..65a89e008dd1 100644
--- a/net-nds/389-ds-base/Manifest
+++ b/net-nds/389-ds-base/Manifest
@@ -1,2 +1,3 @@
DIST 389-ds-base-1.3.4.8.tar.bz2 3396105 SHA256 a00468afcfa50de375f921a827a04dd53b6a11b632982bb0db98cafca509e701 SHA512 ac85223cb38d4cebb3ff61b23e3c0312b0cd30a0c6bf0d9644842c6ecfbc9379ea4a639c80b3e78a13a67f273342fec78e9ecf4672cc72e289d72d74c2fa0d8f WHIRLPOOL 4c7645be5b70c108ef437aaf6d50293a99fa6a552c859f649904c6974c8830e5bf96286a0f998c5d187c1f66f3e0922bbe1e756889e6b0a33e8d9db56f0aa005
DIST 389-ds-base-1.3.5.1.tar.bz2 3511066 SHA256 1c4134882cedace6c0f801a3096867ec58436560440ba34934204c18fa3ccbc1 SHA512 b04d0c8f392c71d8aa4c557b0ab49b83a2a711d11c55f8bb486948b2872a2eceb722cd2ac2b4931409cca41d23d85f077122326ea34eb65ece84602d277d931e WHIRLPOOL 8132ac29c89d24378c8fdf2df9a70760afa9a9280e77f71dd97bff054e0c8147e024435061d3203f72cbd44d7a9be3e65a237b911be6448f51e10ec362d5427d
+DIST 389-ds-base-1.3.5.4.tar.bz2 3520056 SHA256 a82f78e56473db4c3aca7a73e012fcd66a508d3b4734bb54936974e4272739b8 SHA512 0cf3a1e403bc6d417525f908263d59689bbee1db887c5ba552fdae28252a59c37ee8e47ec29c48eb18fc1384652b94667f5768df87602f4c37b86d7ef0df284e WHIRLPOOL 1300126fe21c2adcb014364ead33f6766475f2b9dbe43531a11284a0ba21f61e63591804ec227aa118378482e91b34ef44f60f600fa4da5416b68176b2bb1b7b
diff --git a/sys-kernel/rt-sources/Manifest b/sys-kernel/rt-sources/Manifest
index 1290e1ac2193..cf0455a51075 100644
--- a/sys-kernel/rt-sources/Manifest
+++ b/sys-kernel/rt-sources/Manifest
@@ -19,6 +19,8 @@ DIST patch-3.18.29-rt30.patch.xz 166268 SHA256 d75ff961fc5ea4d2d338db1fe9ab31baf
DIST patch-3.18.29.xz 832136 SHA256 c406a8488d8d4d9e11934479b188126bce5dc41477be19a1bb389fd4a94ecb53 SHA512 99e27e64876d1cbdb7ce4f283d70dd81c43ccea859a4779f0095a9168583988cfa15ed500c8d2c603a9a31d3cfd06937685390c76edfb73488cc2a5b7265c984 WHIRLPOOL 486ec464264dbbd6a1153915b36daf41ee299b98f303160c0848cb7b95ef84ad31f85fd48c3111a35838ed9e7cff608fece790295c89d52ff8d3ce2ab2699460
DIST patch-4.1.20-rt23.patch.xz 178388 SHA256 66be26d74f5a5a13c9af87de79b6c54d59e263ac17ced58f8f6bfb5c8643d1c7 SHA512 d1f9cfcc9290bf307cd57e48ef01dd74892310e9e3dee723dd271f8620a150413be6467ff4415b49adbb4836fce0c0575af26dd52dff7c4caa9232efd091bacb WHIRLPOOL 7001c1f4a27ff7c85d0260136cf1869973dd4d591386d9585956ef61366279ed4586ddf47ab2d477ddbef75ca8f454ded225e50517a0a337bd319ae87aaeee5a
DIST patch-4.1.20.xz 615912 SHA256 c9cb7370fe790df645a13967919628e5bcf1ff333f334fedac6a3c474714c45d SHA512 5c919982d33270c75b49e1deda32a9704ac8c68c4f07595471357c6b98694a4429dbd85bb31f662e63150294c031205b2d31426e117d0197ce7afdfd45f1c313 WHIRLPOOL 6edd49f7764b19e792897e6e394dacc27fe183affb494b03cc78ab5a72744e3779613c6ab29aa554248dd258debd91fb766858750e1a9d631cc0d085fd86b495
+DIST patch-4.4.12-rt19.patch.xz 185432 SHA256 0fe3f95956b73d0682c44c0520eef11a9de067739d799c33eaf8bc1130331a1d SHA512 f5572d62d132670e0e42eca4c95bac1ae513dbf47aa5e9f5774ab42b1ae223f7167d544378b2b60149de423a77108dc102c42575f44760876624708ad9f1bb17 WHIRLPOOL 0d77e44071ae7d9ab1887dafb1460480a23ade25c12806e9c42e6736ce0300ba8be756e6f1bf58f1a14ae8af5013287c8e3a4b4f54130e888a6a6b97bd65eac4
+DIST patch-4.4.12.xz 433048 SHA256 1eb89dddd7e89caf2df17470b4b15da451ef1aa97f8e1a88578a8ee2da75729a SHA512 c3aca55f26fc883b489635a90b79c03d7c6d591efddb4e406b5bfe49fc4326ff2a957521b1d8ea126b95f1d0573e5185d96bce10d05eae595a51f8eb27690404 WHIRLPOOL 27a889415e00a0192ad3951604f5d6a2e912e2e83e265e36246d746283cdbe7fe53fb1f47769ed6334443aef51c61b2b63edd5df6f7057d09eb2264167557b40
DIST patch-4.4.7-rt16.patch.xz 185100 SHA256 2ff8616f1fcbf8070650fe0287523c57f556c76c0e8acabd627f4acf2737b387 SHA512 87699fb92cb1d045adb5dbc53e271679a0a8ceea304d2b9a8a90d9f52b3f9cb80d5f51d59e98284a62da4602f38b053b4d1a448649aa900effd8a60ec6a02547 WHIRLPOOL 1b8c14ba8c7bfebfe693a0121acb3d749e068178f2e7b3835f99c45ba458eca06037152d18c81b6309c60d809562e131cfdf624869060b2e26b4cc19353e8143
DIST patch-4.4.7.xz 295220 SHA256 34a0e0bc123fe2224a83e13a4da25f7f816438fd77c58dce19588441f5166f0e SHA512 b88e8fdfcba306b49bb1d6d3e6cf5a97ee47481b0b801c199db9bade4f1298930ae3d1fe36d003a7927867bd5a092eeecdcbd151c9b2e85470c69f99b0d4bcc5 WHIRLPOOL 87e504ece360708c84ca0c69f7dfc4e12d21a3f1bb44f5f718185cc4f9d012b182ac3cc9a50468af132fd6a0512e82ce5082b5814b04da850028ae763a1fe5f1
DIST patch-4.4.9-rt17.patch.xz 184760 SHA256 ed338f3245c51b2e4499f9c705700cf428d57bdf6f255d70739007e337063357 SHA512 a65998402e354b7065b088968b051518da9a2b42c6a84395b9814f30f4340a37c25eb5a3128c28ec2454b1fe603d7026c92694eaa0432d116614cdcf01386416 WHIRLPOOL 405c41ad28315e40d31c34750d35d93b4029d545ae2cf6050f00ec7001e55b4cebdda047f35b199a4880445080e6bfdbfccabfb82915ad771c251bd7b5aa824b
diff --git a/sys-kernel/rt-sources/rt-sources-4.4.12_p19.ebuild b/sys-kernel/rt-sources/rt-sources-4.4.12_p19.ebuild
new file mode 100644
index 000000000000..8352c29f5b71
--- /dev/null
+++ b/sys-kernel/rt-sources/rt-sources-4.4.12_p19.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+ETYPE="sources"
+KEYWORDS="~amd64"
+
+HOMEPAGE="https://www.kernel.org/pub/linux/kernel/projects/rt/"
+
+inherit versionator
+
+CKV="$(get_version_component_range 1-3)"
+K_SECURITY_UNSUPPORTED="yes"
+K_DEBLOB_AVAILABLE="1"
+RT_PATCHSET="${PV/*_p}"
+
+inherit kernel-2
+detect_version
+
+K_BRANCH_ID="${KV_MAJOR}.${KV_MINOR}"
+RT_FILE="patch-${K_BRANCH_ID}.${KV_PATCH}-rt${RT_PATCHSET}.patch.xz"
+RT_URI="mirror://kernel/linux/kernel/projects/rt/${K_BRANCH_ID}/${RT_FILE} \
+ mirror://kernel/linux/kernel/projects/rt/${K_BRANCH_ID}/older/${RT_FILE}"
+
+DESCRIPTION="Full Linux ${K_BRANCH_ID} kernel sources with the CONFIG_PREEMPT_RT patch"
+SRC_URI="${KERNEL_URI} ${RT_URI}"
+
+KV_FULL="${PVR/_p/-rt}"
+S="${WORKDIR}/linux-${KV_FULL}"
+
+UNIPATCH_LIST="${DISTDIR}/${RT_FILE}"
+UNIPATCH_STRICTORDER="yes"
+
+pkg_postinst(){
+
+ ewarn
+ ewarn "${PN} are *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the RT project developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds."
+ ewarn
+}
+
+K_EXTRAEINFO="For more info on rt-sources and details on how to report problems, see: \
+${HOMEPAGE}."