summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2017-07-23 23:03:21 +0900
committerAkinori Hattori <hattya@gentoo.org>2017-07-23 23:03:21 +0900
commitd3620d0162d0783371406756bc90896e9017c1b9 (patch)
tree767eeb0070dfebc4e7b5895814409ac9b828380c
parentx11-libs/libgxim: fix build (diff)
downloadgentoo-d3620d0162d0783371406756bc90896e9017c1b9.tar.gz
gentoo-d3620d0162d0783371406756bc90896e9017c1b9.tar.bz2
gentoo-d3620d0162d0783371406756bc90896e9017c1b9.zip
app-i18n/imsettings: new upstream release
Gentoo-Bug: 587020 Package-Manager: Portage-2.3.6, Repoman-2.3.1
-rw-r--r--app-i18n/imsettings/Manifest1
-rw-r--r--app-i18n/imsettings/imsettings-1.7.2.ebuild71
-rw-r--r--app-i18n/imsettings/metadata.xml7
3 files changed, 77 insertions, 2 deletions
diff --git a/app-i18n/imsettings/Manifest b/app-i18n/imsettings/Manifest
index be2aa02593f6..9085198e8770 100644
--- a/app-i18n/imsettings/Manifest
+++ b/app-i18n/imsettings/Manifest
@@ -1 +1,2 @@
DIST imsettings-1.6.8.tar.bz2 593942 SHA256 2620ffbf9a6dc842dbf994b4773d4fe355eb77076ccf33f726ba63f16c0d08ba SHA512 a15a4824529b16f61653fdf3e149656c7a2ca1384579c755cec6650414499c3d24ac15178971d961f327c5fd8acd7892b9b4f9c60608166c281c11ab3f2b25b0 WHIRLPOOL c39cb54b9be8424dc1d9eceae12f793847585638f29a52282427c3c07ee1bd3e5ed9d67ff73727b055499c3963e106024eb9f164b32ebcf553b2dfccf1114a6d
+DIST imsettings-1.7.2.tar.bz2 595754 SHA256 41addf0458f760212b6b6100835066e16deb3a8a50eb005a0fc17fbac0a2ae66 SHA512 b28d67705d3d6a0ec95babaca616f750b73cdac5e01ed61e25a6527fd7f816a14654cd7233eca56d7427b9395e7ad75757b95cd7bd55c56bbdc145a3f8bfe1f0 WHIRLPOOL 018baea019f67bd19744facd981d5b6154de9ee19fa0565d9d7d11c6de02cfc1e3027424326700078eed979012e51b685abaaac0ae49a773bb9f088197ba6766
diff --git a/app-i18n/imsettings/imsettings-1.7.2.ebuild b/app-i18n/imsettings/imsettings-1.7.2.ebuild
new file mode 100644
index 000000000000..bc89ae3d0896
--- /dev/null
+++ b/app-i18n/imsettings/imsettings-1.7.2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit autotools ltprune xdg-utils
+
+DESCRIPTION="Delivery framework for general Input Method configuration"
+HOMEPAGE="https://tagoh.bitbucket.io/imsettings"
+SRC_URI="https://bitbucket.org/tagoh/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gconf gtk2 qt5 +introspection static-libs xfconf"
+RESTRICT="test"
+
+RDEPEND="dev-libs/glib:2
+ sys-apps/dbus
+ virtual/libintl
+ x11-libs/libX11
+ x11-libs/libgxim
+ x11-libs/libnotify
+ gconf? ( gnome-base/gconf )
+ gtk2? ( x11-libs/gtk+:2 )
+ !gtk2? ( x11-libs/gtk+:3 )
+ introspection? ( dev-libs/gobject-introspection )
+ xfconf? ( xfce-base/xfconf )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/autoconf-archive
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+MY_XINPUTSH="90-xinput"
+
+src_prepare() {
+ sed -i \
+ -e "/PKG_CHECK_MODULES/s/\(gconf-2\.0\)/$(usex gconf '\1' _)/" \
+ -e "/PKG_CHECK_MODULES/s/\(gtk+-2\.0\)/$(usex gtk2 '\1' _)/" \
+ -e "/PKG_CHECK_MODULES/s/\(gtk+-3\.0\)/$(usex !gtk2 '\1' _)/" \
+ -e "/PKG_CHECK_MODULES/s/\(check\)/_/" \
+ -e "/PKG_CHECK_MODULES/s/\(libxfconf-0\)/$(usex xfconf '\1' _)/" \
+ -e "s/use_qt=\"yes\"/use_qt=\"$(usex qt5)\"/" \
+ -e "/^GNOME_/d" \
+ -e "/^CFLAGS/s/\$WARN_CFLAGS/-Wall -Wmissing-prototypes/" \
+ configure.ac
+
+ default
+ eautoreconf
+ xdg_environment_reset
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ --with-xinputsh=${MY_XINPUTSH}
+}
+
+src_install() {
+ default
+ prune_libtool_files --modules
+
+ fperms 0755 /etc/X11/xinit/xinitrc.d/${MY_XINPUTSH}
+}
+
+pkg_postinst() {
+ if [[ ! -e "${EPREFIX}"/etc/X11/xinit/xinputrc ]]; then
+ ln -sf xinput.d/xcompose.conf "${EPREFIX}"/etc/X11/xinit/xinputrc
+ fi
+}
diff --git a/app-i18n/imsettings/metadata.xml b/app-i18n/imsettings/metadata.xml
index 4024cc0e33ad..f3d313f59e1a 100644
--- a/app-i18n/imsettings/metadata.xml
+++ b/app-i18n/imsettings/metadata.xml
@@ -6,9 +6,12 @@
<name>Cjk</name>
</maintainer>
<use>
- <flag name="xfconf">Enable integration in the Xfce desktop environment with <pkg>xfce-base/xfconf</pkg></flag>
- <flag name="gconf">Enable GConf support</flag>
+ <flag name="gconf">Enable support for <pkg>gnome-base/gconf</pkg></flag>
+ <flag name="gtk2">
+ Build with <pkg>x11-libs/gtk+</pkg>:2 instead of <pkg>x11-libs/gtk+</pkg>:3
+ </flag>
<flag name="gtk3">Enable support for <pkg>x11-libs/gtk+</pkg>:3</flag>
+ <flag name="xfconf">Enable support for <pkg>xfce-base/xfconf</pkg></flag>
</use>
<upstream>
<remote-id type="bitbucket">tagoh/imsettings</remote-id>