summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-20 02:51:40 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-20 03:29:18 +0200
commitca5dd70ea8615d674ad09d53795fc4599f5b5d8f (patch)
treef43e82cd9b37d9611971de1fba3c5738a69d07a7
parentdev-python/aiohttp: Bump to 3.10.5 (diff)
downloadgentoo-ca5dd70ea8615d674ad09d53795fc4599f5b5d8f.tar.gz
gentoo-ca5dd70ea8615d674ad09d53795fc4599f5b5d8f.tar.bz2
gentoo-ca5dd70ea8615d674ad09d53795fc4599f5b5d8f.zip
dev-python/pyzmq: Bump to 26.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pyzmq/Manifest1
-rw-r--r--dev-python/pyzmq/pyzmq-26.1.1.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/dev-python/pyzmq/Manifest b/dev-python/pyzmq/Manifest
index aadef1d0e395..22739fe8c035 100644
--- a/dev-python/pyzmq/Manifest
+++ b/dev-python/pyzmq/Manifest
@@ -2,3 +2,4 @@ DIST pyzmq-25.1.2.gh.tar.gz 391272 BLAKE2B 80814704e7ea08d407859c1d71338f6ea283e
DIST pyzmq-26.0.2.gh.tar.gz 267895 BLAKE2B c71a0149cb6c596dfcbc760376aa14afa69bd927fcc739698f7d2ea44579dc8437ae605745b383a9b317ff66c092a4f963671e7933cf19f3f73acac16ac06daa SHA512 5772743e71810f9a0c332dcf16f04237eeb0a34ef2efdd22b63258ebe93e6b493a79845090e677a33582a9a80e7bee773160ec7ecfdaf240b655f3819e5b67a5
DIST pyzmq-26.0.3.gh.tar.gz 268927 BLAKE2B 7504a45776e8c618833702563b50f672a3ecabb3353551ea61d2d2343dd9e955d1d2938046c2f90d115255482b9b6b2c0f1817b238e591b9319ac92a4341c04a SHA512 f4a32164daf9d9521be83008a94089406078779b9e0e56812a826df1fb295cc03781566825697313aa0c2b36b85b0bb760b8fb90959a856a0542b9072cde78c9
DIST pyzmq-26.1.0.gh.tar.gz 272153 BLAKE2B d99bbdabfb93641361daadbe1ee8d4e5c578ef9faabf4c0457078082bb77d094040da43396e34d48cb2341491460ff39ebc8e5f3a19be2172e73df9fe6655e5c SHA512 288b6799cdc2b77f2972e928558ae74871054809075b534f33af876983da3b1cea35d6fd0fbfcb7caa8f3a458ae00da10935e31791c5c650c5589bfd5db577b0
+DIST pyzmq-26.1.1.gh.tar.gz 272236 BLAKE2B 49ec3c97b3d1b3e943522891ef067c6e4fdd1f5a2fd46f8c2927ba529f97ee8d177253f1a76fc1dd45813832827c8b35a1fc8fba42cf53eac37b59ec40a39251 SHA512 6e9ff9c021696935cb0513edc5eef8a130c56f3c95156a9805acfc174438fab5aaa356779308791b53dc01a166d41e094102ff445959515739102258c8d4e0de
diff --git a/dev-python/pyzmq/pyzmq-26.1.1.ebuild b/dev-python/pyzmq/pyzmq-26.1.1.ebuild
new file mode 100644
index 000000000000..7edbff75d517
--- /dev/null
+++ b/dev-python/pyzmq/pyzmq-26.1.1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=scikit-build-core
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Lightweight and super-fast messaging library built on top of the ZeroMQ library"
+HOMEPAGE="
+ https://zeromq.org/languages/python/
+ https://pypi.org/project/pyzmq/
+ https://github.com/zeromq/pyzmq/
+"
+SRC_URI="
+ https://github.com/zeromq/pyzmq/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~x64-macos"
+IUSE="drafts"
+
+# There are additional test failures if zeromq has the draft api enabled, but pyzmq has it disabled.
+DEPEND="
+ >=net-libs/zeromq-4.2.2-r2:=[drafts=]
+"
+# It uses cffi backend for pypy, cython backend for cpython
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/cython-3.0.0[${PYTHON_USEDEP}]
+ ' 'python*')
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ >=dev-python/tornado-5.0.2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+# TODO: Package enum_tools
+# distutils_enable_sphinx docs/source \
+# dev-python/numpydoc \
+# dev-python/sphinx-rtd-theme \
+# dev-python/myst-parser
+
+src_configure() {
+ DISTUTILS_ARGS=(
+ -DZMQ_DRAFT_API="$(usex drafts)"
+ )
+}
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # Avoid dependency on mypy
+ tests/test_mypy.py
+ )
+
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # not implemented in cffi variant?
+ tests/test_draft.py::TestDraftSockets
+ )
+ esac
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ rm -rf zmq || die
+ # avoid large to reduce memory consumption
+ epytest -p asyncio -p rerunfailures tests -m "not large"
+}