summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2022-06-22 04:18:50 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2022-06-22 04:18:50 +0000
commitc1600916a483df9910c667f0caeda9277f1b1166 (patch)
tree97daf22a0c3798d288a04f257f9ea0a83d9c869f
parent2022-06-22 04:02:53 UTC (diff)
parentvirtual/mpi: fix USE="nullmpi", update deps versions (diff)
downloadgentoo-c1600916a483df9910c667f0caeda9277f1b1166.tar.gz
gentoo-c1600916a483df9910c667f0caeda9277f1b1166.tar.bz2
gentoo-c1600916a483df9910c667f0caeda9277f1b1166.zip
Merge updates from master
-rw-r--r--eclass/cmake.eclass15
-rw-r--r--media-video/mpv/mpv-9999.ebuild1
-rw-r--r--sys-devel/clang/clang-12.0.1.ebuild2
-rw-r--r--sys-devel/clang/clang-13.0.1.ebuild2
-rw-r--r--sys-devel/clang/clang-14.0.1-r1.ebuild2
-rw-r--r--sys-devel/clang/clang-14.0.3.ebuild2
-rw-r--r--sys-devel/clang/clang-14.0.4.ebuild2
-rw-r--r--sys-devel/clang/clang-14.0.5.ebuild2
-rw-r--r--sys-devel/clang/clang-15.0.0.9999.ebuild2
-rw-r--r--sys-devel/llvm/llvm-12.0.1.ebuild2
-rw-r--r--sys-devel/llvm/llvm-13.0.1.ebuild2
-rw-r--r--sys-devel/llvm/llvm-14.0.1.ebuild2
-rw-r--r--sys-devel/llvm/llvm-14.0.3.ebuild2
-rw-r--r--sys-devel/llvm/llvm-14.0.4.ebuild2
-rw-r--r--sys-devel/llvm/llvm-14.0.5.ebuild2
-rw-r--r--sys-devel/llvm/llvm-15.0.0.9999.ebuild2
-rw-r--r--virtual/mpi/mpi-2.0-r7.ebuild (renamed from virtual/mpi/mpi-2.0-r6.ebuild)10
17 files changed, 22 insertions, 32 deletions
diff --git a/eclass/cmake.eclass b/eclass/cmake.eclass
index 59e5b60957c2..bd7e64cfe6c7 100644
--- a/eclass/cmake.eclass
+++ b/eclass/cmake.eclass
@@ -136,7 +136,7 @@ case ${CMAKE_MAKEFILE_GENERATOR} in
BDEPEND="sys-devel/make"
;;
ninja)
- BDEPEND="dev-util/ninja"
+ BDEPEND="${NINJA_DEPEND}"
;;
*)
eerror "Unknown value for \${CMAKE_MAKEFILE_GENERATOR}"
@@ -363,13 +363,6 @@ cmake_src_prepare() {
die "FATAL: Unable to find CMakeLists.txt"
fi
- # if ninja is enabled but not installed, the build could fail
- # this could happen if ninja is manually enabled (eg. make.conf) but not installed
- if [[ ${CMAKE_MAKEFILE_GENERATOR} == ninja ]] && ! has_version -b dev-util/ninja; then
- eerror "CMAKE_MAKEFILE_GENERATOR is set to ninja, but ninja is not installed."
- die "Please install dev-util/ninja or unset CMAKE_MAKEFILE_GENERATOR."
- fi
-
local modules_list
if [[ ${EAPI} == 7 && $(declare -p CMAKE_REMOVE_MODULES_LIST) != "declare -a"* ]]; then
modules_list=( ${CMAKE_REMOVE_MODULES_LIST} )
@@ -705,11 +698,7 @@ cmake_src_test() {
cmake_src_install() {
debug-print-function ${FUNCNAME} "$@"
- _cmake_check_build_dir
- pushd "${BUILD_DIR}" > /dev/null || die
- DESTDIR="${D}" ${CMAKE_MAKEFILE_GENERATOR} install "$@" ||
- die "died running ${CMAKE_MAKEFILE_GENERATOR} install"
- popd > /dev/null || die
+ DESTDIR="${D}" cmake_build install "$@"
if [[ ${EAPI} == 7 ]]; then
pushd "${S}" > /dev/null || die
diff --git a/media-video/mpv/mpv-9999.ebuild b/media-video/mpv/mpv-9999.ebuild
index c44511ff2016..647b7976525a 100644
--- a/media-video/mpv/mpv-9999.ebuild
+++ b/media-video/mpv/mpv-9999.ebuild
@@ -106,6 +106,7 @@ COMMON_DEPEND="
x11-libs/libXScrnSaver
x11-libs/libXext
x11-libs/libXinerama
+ x11-libs/libXpresent
x11-libs/libXrandr
opengl? (
x11-libs/libXdamage
diff --git a/sys-devel/clang/clang-12.0.1.ebuild b/sys-devel/clang/clang-12.0.1.ebuild
index 678ea397dc6b..fde58c87f658 100644
--- a/sys-devel/clang/clang-12.0.1.ebuild
+++ b/sys-devel/clang/clang-12.0.1.ebuild
@@ -130,7 +130,7 @@ check_distribution_components() {
all_targets+=( "${l}" )
fi
- done < <(ninja -t targets all)
+ done < <(${NINJA} -t targets all)
while read -r l; do
my_targets+=( "${l}" )
diff --git a/sys-devel/clang/clang-13.0.1.ebuild b/sys-devel/clang/clang-13.0.1.ebuild
index 07606d6b05a0..ad43beaccb8f 100644
--- a/sys-devel/clang/clang-13.0.1.ebuild
+++ b/sys-devel/clang/clang-13.0.1.ebuild
@@ -118,7 +118,7 @@ check_distribution_components() {
all_targets+=( "${l}" )
fi
- done < <(ninja -t targets all)
+ done < <(${NINJA} -t targets all)
while read -r l; do
my_targets+=( "${l}" )
diff --git a/sys-devel/clang/clang-14.0.1-r1.ebuild b/sys-devel/clang/clang-14.0.1-r1.ebuild
index 088a3ff7eb67..56d63fbd72f7 100644
--- a/sys-devel/clang/clang-14.0.1-r1.ebuild
+++ b/sys-devel/clang/clang-14.0.1-r1.ebuild
@@ -120,7 +120,7 @@ check_distribution_components() {
all_targets+=( "${l}" )
fi
- done < <(ninja -t targets all)
+ done < <(${NINJA} -t targets all)
while read -r l; do
my_targets+=( "${l}" )
diff --git a/sys-devel/clang/clang-14.0.3.ebuild b/sys-devel/clang/clang-14.0.3.ebuild
index 8d2757256bed..ed84f3755fa2 100644
--- a/sys-devel/clang/clang-14.0.3.ebuild
+++ b/sys-devel/clang/clang-14.0.3.ebuild
@@ -127,7 +127,7 @@ check_distribution_components() {
all_targets+=( "${l}" )
fi
- done < <(ninja -t targets all)
+ done < <(${NINJA} -t targets all)
while read -r l; do
my_targets+=( "${l}" )
diff --git a/sys-devel/clang/clang-14.0.4.ebuild b/sys-devel/clang/clang-14.0.4.ebuild
index 2c42218462f8..d48c4267822f 100644
--- a/sys-devel/clang/clang-14.0.4.ebuild
+++ b/sys-devel/clang/clang-14.0.4.ebuild
@@ -127,7 +127,7 @@ check_distribution_components() {
all_targets+=( "${l}" )
fi
- done < <(ninja -t targets all)
+ done < <(${NINJA} -t targets all)
while read -r l; do
my_targets+=( "${l}" )
diff --git a/sys-devel/clang/clang-14.0.5.ebuild b/sys-devel/clang/clang-14.0.5.ebuild
index 8d2757256bed..ed84f3755fa2 100644
--- a/sys-devel/clang/clang-14.0.5.ebuild
+++ b/sys-devel/clang/clang-14.0.5.ebuild
@@ -127,7 +127,7 @@ check_distribution_components() {
all_targets+=( "${l}" )
fi
- done < <(ninja -t targets all)
+ done < <(${NINJA} -t targets all)
while read -r l; do
my_targets+=( "${l}" )
diff --git a/sys-devel/clang/clang-15.0.0.9999.ebuild b/sys-devel/clang/clang-15.0.0.9999.ebuild
index 4c8e1d4b50ce..e1960cb92f18 100644
--- a/sys-devel/clang/clang-15.0.0.9999.ebuild
+++ b/sys-devel/clang/clang-15.0.0.9999.ebuild
@@ -127,7 +127,7 @@ check_distribution_components() {
all_targets+=( "${l}" )
fi
- done < <(ninja -t targets all)
+ done < <(${NINJA} -t targets all)
while read -r l; do
my_targets+=( "${l}" )
diff --git a/sys-devel/llvm/llvm-12.0.1.ebuild b/sys-devel/llvm/llvm-12.0.1.ebuild
index e0d7386e7346..3b38dc9ca6f1 100644
--- a/sys-devel/llvm/llvm-12.0.1.ebuild
+++ b/sys-devel/llvm/llvm-12.0.1.ebuild
@@ -141,7 +141,7 @@ check_distribution_components() {
all_targets+=( "${l}" )
fi
- done < <(ninja -t targets all)
+ done < <(${NINJA} -t targets all)
while read -r l; do
my_targets+=( "${l}" )
diff --git a/sys-devel/llvm/llvm-13.0.1.ebuild b/sys-devel/llvm/llvm-13.0.1.ebuild
index d4212f0559bf..9ae168db4cfb 100644
--- a/sys-devel/llvm/llvm-13.0.1.ebuild
+++ b/sys-devel/llvm/llvm-13.0.1.ebuild
@@ -134,7 +134,7 @@ check_distribution_components() {
all_targets+=( "${l}" )
fi
- done < <(ninja -t targets all)
+ done < <(${NINJA} -t targets all)
while read -r l; do
my_targets+=( "${l}" )
diff --git a/sys-devel/llvm/llvm-14.0.1.ebuild b/sys-devel/llvm/llvm-14.0.1.ebuild
index f928830b5fa9..c65be4743574 100644
--- a/sys-devel/llvm/llvm-14.0.1.ebuild
+++ b/sys-devel/llvm/llvm-14.0.1.ebuild
@@ -131,7 +131,7 @@ check_distribution_components() {
all_targets+=( "${l}" )
fi
- done < <(ninja -t targets all)
+ done < <(${NINJA} -t targets all)
while read -r l; do
my_targets+=( "${l}" )
diff --git a/sys-devel/llvm/llvm-14.0.3.ebuild b/sys-devel/llvm/llvm-14.0.3.ebuild
index a8868a3569e1..66789e47a596 100644
--- a/sys-devel/llvm/llvm-14.0.3.ebuild
+++ b/sys-devel/llvm/llvm-14.0.3.ebuild
@@ -142,7 +142,7 @@ check_distribution_components() {
all_targets+=( "${l}" )
fi
- done < <(ninja -t targets all)
+ done < <(${NINJA} -t targets all)
while read -r l; do
my_targets+=( "${l}" )
diff --git a/sys-devel/llvm/llvm-14.0.4.ebuild b/sys-devel/llvm/llvm-14.0.4.ebuild
index 2c44ddd79302..70a8953289ae 100644
--- a/sys-devel/llvm/llvm-14.0.4.ebuild
+++ b/sys-devel/llvm/llvm-14.0.4.ebuild
@@ -142,7 +142,7 @@ check_distribution_components() {
all_targets+=( "${l}" )
fi
- done < <(ninja -t targets all)
+ done < <(${NINJA} -t targets all)
while read -r l; do
my_targets+=( "${l}" )
diff --git a/sys-devel/llvm/llvm-14.0.5.ebuild b/sys-devel/llvm/llvm-14.0.5.ebuild
index 955b7f70d83e..ad91093de640 100644
--- a/sys-devel/llvm/llvm-14.0.5.ebuild
+++ b/sys-devel/llvm/llvm-14.0.5.ebuild
@@ -142,7 +142,7 @@ check_distribution_components() {
all_targets+=( "${l}" )
fi
- done < <(ninja -t targets all)
+ done < <(${NINJA} -t targets all)
while read -r l; do
my_targets+=( "${l}" )
diff --git a/sys-devel/llvm/llvm-15.0.0.9999.ebuild b/sys-devel/llvm/llvm-15.0.0.9999.ebuild
index fd1b0e34a17a..e200d3e34191 100644
--- a/sys-devel/llvm/llvm-15.0.0.9999.ebuild
+++ b/sys-devel/llvm/llvm-15.0.0.9999.ebuild
@@ -139,7 +139,7 @@ check_distribution_components() {
all_targets+=( "${l}" )
fi
- done < <(ninja -t targets all)
+ done < <(${NINJA} -t targets all)
while read -r l; do
my_targets+=( "${l}" )
diff --git a/virtual/mpi/mpi-2.0-r6.ebuild b/virtual/mpi/mpi-2.0-r7.ebuild
index c9a731d9dabb..f6c05af2c2f2 100644
--- a/virtual/mpi/mpi-2.0-r6.ebuild
+++ b/virtual/mpi/mpi-2.0-r7.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit multilib-build
@@ -12,8 +12,8 @@ KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~ppc ppc64 ~riscv sparc x86 ~amd64-
IUSE="cxx fortran romio threads nullmpi"
RDEPEND="|| (
- >=sys-cluster/openmpi-1.10.2-r1[${MULTILIB_USEDEP},cxx?,fortran?,romio?,threads(+)?]
- >=sys-cluster/mpich-3.2-r1[${MULTILIB_USEDEP},cxx?,fortran?,romio?,threads?]
- sys-cluster/nullmpi[${MULTILIB_USEDEP},cxx(-)?,fortran(-)?,romio(-)?,threads(-)?]
- nullmpi? ( sys-cluster/native-mpi )
+ >=sys-cluster/openmpi-4.1.2[${MULTILIB_USEDEP},cxx?,fortran?,romio?,threads(+)?]
+ >=sys-cluster/mpich-3.4.3[${MULTILIB_USEDEP},cxx?,fortran?,romio?,threads?]
+ sys-cluster/native-mpi
+ nullmpi? ( sys-cluster/nullmpi[${MULTILIB_USEDEP},cxx(-)?,fortran(-)?,romio(-)?,threads(-)?] )
)"