summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2022-02-17 07:38:05 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2022-02-17 07:38:05 +0000
commitbffa5747edf9e9be3319882e7dbcc31f0b8522ce (patch)
treef2dff1bf754561072d7254a0a27e5703ff37de57
parent2022-02-17 07:21:57 UTC (diff)
parentapp-emacs/avy: Fix test failure (diff)
downloadgentoo-bffa5747edf9e9be3319882e7dbcc31f0b8522ce.tar.gz
gentoo-bffa5747edf9e9be3319882e7dbcc31f0b8522ce.tar.bz2
gentoo-bffa5747edf9e9be3319882e7dbcc31f0b8522ce.zip
Merge updates from master
-rw-r--r--app-emacs/avy/avy-0.5.0.ebuild5
-rw-r--r--eclass/go-module.eclass8
2 files changed, 12 insertions, 1 deletions
diff --git a/app-emacs/avy/avy-0.5.0.ebuild b/app-emacs/avy/avy-0.5.0.ebuild
index 600a7ba7c2eb..d4250402507e 100644
--- a/app-emacs/avy/avy-0.5.0.ebuild
+++ b/app-emacs/avy/avy-0.5.0.ebuild
@@ -14,10 +14,13 @@ LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-ELISP_REMOVE="avy-test.el"
SITEFILE="50${PN}-gentoo.el"
src_test() {
${EMACS} ${EMACSFLAGS} -l avy.el -l avy-test.el \
-f ert-run-tests-batch-and-exit || die "tests failed"
}
+
+src_install() {
+ elisp-install ${PN} avy.{el,elc}
+}
diff --git a/eclass/go-module.eclass b/eclass/go-module.eclass
index 9fa482405fdd..00f5169ea6e2 100644
--- a/eclass/go-module.eclass
+++ b/eclass/go-module.eclass
@@ -103,6 +103,14 @@ RESTRICT+=" strip"
# You can use some combination of sed/awk/cut to extract the
# contents of EGO_SUM or use the dev-go/get-ego-vendor tool.
#
+# One manual way to do this is the following:
+#
+# @CODE
+#
+# cat go.sum | cut -d" " -f1,2 | awk '{print "\t\"" $0 "\""}'
+#
+# @CODE
+#
# The format of go.sum is described upstream here:
# https://go.dev/ref/mod#go-sum-files
#