summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-09 07:24:50 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-09 07:45:03 +0100
commitb919c8f2b5c9d600cfbdfd65ee433e8e2ef7d4ed (patch)
treef7b61acf0b0ae4d7e1bd00df8c53617b5934a786
parentdev-python/botocore: Bump to 1.35.57 (diff)
downloadgentoo-b919c8f2b5c9d600cfbdfd65ee433e8e2ef7d4ed.tar.gz
gentoo-b919c8f2b5c9d600cfbdfd65ee433e8e2ef7d4ed.tar.bz2
gentoo-b919c8f2b5c9d600cfbdfd65ee433e8e2ef7d4ed.zip
dev-python/boto3: Bump to 1.35.57
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.35.57.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 9fbe0b27f9db..5df15e634903 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -3,3 +3,4 @@ DIST boto3-1.35.49.gh.tar.gz 878577 BLAKE2B 8f9ddf29eaad2f91a9ba670b268ac987f7f8
DIST boto3-1.35.54.gh.tar.gz 882727 BLAKE2B 398e7743d30700856b15440c217d40e88aec4e58669009f68392e108373f2e57ff3c384be9bdc3873b102686df7f0e05f53d4518b149e982e0893473919db3cb SHA512 bfddb7c4b3816edc2b572bd6f412c0d085296df17b552930dfc9bb108c7100190da1f58f5f701d3ec3c36e6deb88c93e5af5bfc68963b76fc7c950d456815ec5
DIST boto3-1.35.55.gh.tar.gz 883345 BLAKE2B 149ad97b6ac52dcc291aeb3300152c247bbbcaa2abb7f73819b11e93f8f55c6866bbd1212fdfd636e862ec48efc27a38787d705820e2dede70ed46568b73fe99 SHA512 3eaff2982947f5b946faf2dfd1d02eba66cf1e93b447baf0d82d72159578efa4c141a841c2eff33cfb6766917cac2c399ba9485c7988f108ab93087459764492
DIST boto3-1.35.56.gh.tar.gz 884221 BLAKE2B 14b6cd1c01cf8ff87691668e7af2d49a7e956c980dd34212a0ba46daf564aae1497f99483da5dcd4d634e0da51d16f0c9f9491b8259ce6720051d2a3d8033e5c SHA512 852722ab8370e8a750fe43c3161b39ebbf399dcaad5967d8bd74f3d452f2be29808d79ef273332bc7288cb647c5559b3bc317e8ff78a2826496c704cdf52012d
+DIST boto3-1.35.57.gh.tar.gz 885077 BLAKE2B 4f3a29db5e76c706fbfd0afb3ec05d5518e69f3fd26d15e79024fb898d874818fa21031187d66078a4ebd107cce9461000e37506886f337049bd821e20933563 SHA512 19f951c04452203c070243bd8c944183221b51d9853efc19d33002af57c7d59c1967e8a7b606e56f772f35576ec6e1b52e2037138ba01a28f13685a49458c7d4
diff --git a/dev-python/boto3/boto3-1.35.57.ebuild b/dev-python/boto3/boto3-1.35.57.ebuild
new file mode 100644
index 000000000000..8cba6d95740e
--- /dev/null
+++ b/dev-python/boto3/boto3-1.35.57.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}