summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2020-09-21 16:06:56 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2020-09-21 16:06:56 +0000
commitb0ca94634642ad24f877f43e71b0a848aec51b29 (patch)
tree8ee068c7dba1eb6102de8fc0b2ccd694da7a2c6b
parent2020-09-21 15:05:37 UTC (diff)
parentdev-python/aiohttp-socks: Bump to 0.5.4 (diff)
downloadgentoo-b0ca94634642ad24f877f43e71b0a848aec51b29.tar.gz
gentoo-b0ca94634642ad24f877f43e71b0a848aec51b29.tar.bz2
gentoo-b0ca94634642ad24f877f43e71b0a848aec51b29.zip
Merge updates from master
-rw-r--r--dev-python/aiohttp-socks/Manifest1
-rw-r--r--dev-python/aiohttp-socks/aiohttp-socks-0.5.4.ebuild32
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-5.35.4.ebuild63
-rw-r--r--dev-python/inflect/inflect-4.1.0.ebuild3
-rw-r--r--dev-python/irc/irc-19.0.1.ebuild3
-rw-r--r--dev-python/jaraco-collections/jaraco-collections-3.0.0.ebuild1
-rw-r--r--dev-python/jaraco-context/jaraco-context-3.0.0.ebuild3
-rw-r--r--dev-python/jaraco-functools/jaraco-functools-3.0.1.ebuild3
-rw-r--r--dev-python/jaraco-itertools/jaraco-itertools-5.0.0.ebuild3
-rw-r--r--dev-python/jaraco-logging/jaraco-logging-3.0.0-r1.ebuild3
-rw-r--r--dev-python/jaraco-stream/jaraco-stream-3.0.0.ebuild3
-rw-r--r--dev-python/node-semver/node-semver-0.8.0.ebuild4
-rw-r--r--dev-python/protobuf-python/protobuf-python-3.13.0.ebuild2
-rw-r--r--dev-python/protobuf-python/protobuf-python-9999.ebuild2
-rw-r--r--dev-python/pycurl/pycurl-7.43.0.6.ebuild2
-rw-r--r--dev-python/python-cstruct/python-cstruct-1.8.ebuild5
-rw-r--r--dev-python/python-socks/Manifest1
-rw-r--r--dev-python/python-socks/metadata.xml7
-rw-r--r--dev-python/python-socks/python-socks-1.1.0.ebuild32
-rw-r--r--dev-python/rst-linker/rst-linker-2.0.0.ebuild3
-rw-r--r--dev-python/voluptuous/Manifest1
-rw-r--r--dev-python/voluptuous/metadata.xml1
-rw-r--r--dev-python/voluptuous/voluptuous-0.12.0.ebuild20
-rw-r--r--dev-python/zipp/zipp-3.1.0.ebuild3
-rw-r--r--eclass/distutils-r1.eclass42
-rw-r--r--metadata/install-qa-check.d/60distutils-use-setuptools60
-rw-r--r--www-misc/urlwatch/urlwatch-2.21.ebuild6
28 files changed, 221 insertions, 89 deletions
diff --git a/dev-python/aiohttp-socks/Manifest b/dev-python/aiohttp-socks/Manifest
index cb53a28f1da5..a4ad837143a4 100644
--- a/dev-python/aiohttp-socks/Manifest
+++ b/dev-python/aiohttp-socks/Manifest
@@ -1 +1,2 @@
DIST aiohttp-socks-0.5.3.tar.gz 1360418 BLAKE2B 7282a4952d5f0301b14291a1892db5ec058af91cf553e4a17ab0e933bb327d1fae9c015d25ff7405ef69cdf56637140fefa9bd1ab1e6f2e224cdc94b9e279159 SHA512 2999f850081d05c31535c24c0fcf0948dbaaec5e421c28ed4ca68b4bfb122f881942e7e829cefc01377212b4579547aafcf273fe5a999acb3d158ee1c3f0a888
+DIST aiohttp-socks-0.5.4.tar.gz 1349276 BLAKE2B 17cfc9a326d45e6af4044ccd0ce56dff3adaddf619118a5a98a6e82c778f5e397780d51924e11ff50d059a60df22cbb1c03b27165042f78d06b242ed95f5f254 SHA512 30ac5544b935f021fbd40aac9df682970a1ed39295dcd64909dce270e66f61fd92933a81a25c79b5063a5b382d412ba7b26def67e1e8c059e8daa2a771342a77
diff --git a/dev-python/aiohttp-socks/aiohttp-socks-0.5.4.ebuild b/dev-python/aiohttp-socks/aiohttp-socks-0.5.4.ebuild
new file mode 100644
index 000000000000..083f5275a69d
--- /dev/null
+++ b/dev-python/aiohttp-socks/aiohttp-socks-0.5.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="SOCKS proxy connector for aiohttp"
+HOMEPAGE="https://pypi.org/project/aiohttp-socks/"
+SRC_URI="https://github.com/romis2012/aiohttp-socks/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# tests require Internet
+RESTRICT="test"
+
+# TODO: optional dep on trio
+# TODO: is attrs actually used?
+RDEPEND="
+ >=dev-python/aiohttp-2.3.2[${PYTHON_USEDEP}]
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ dev-python/python-socks[${PYTHON_USEDEP}]
+"
+#DEPEND="
+# test? (
+# dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+# )"
+
+#distutils_enable_tests pytest
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index e715741c083f..7154242d2999 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -1,3 +1,4 @@
DIST hypothesis-python-5.24.4.tar.gz 9054743 BLAKE2B 5c64c86ed58d8f0e4a07390b1b1b5e405878b9632bf14233e0515ad9d98ec6ddcc57bf39be6b61f53739d34e393b3af64c0d362880019d29a649a9523a0204e3 SHA512 147f4fa47b54bf3ec4dfcebf2a6c98cee26ea6780244ef99e181bada65978375ca7731ed05cb98f1b92f7a44a357faae374d97d489ec6e2318ff94e526cd9a40
DIST hypothesis-python-5.29.4.tar.gz 9071060 BLAKE2B 0668f3c7859fae7024c15f693b1f56ce8d02d6f3b8187d24b2d84e38e7bdb73c0824d2b02cfecc6b40bdfbbb1c91c0aa83d40848c499a97ab7e9223aaa6c78d4 SHA512 9da4b487fd3c56540a20e2fbff635704f0720f422d8a398d0accd24a1fb9517476b0d29135b9113a96e8dc98fcfc31cc53215ad82cb727be54e4e77b44d4c8e4
DIST hypothesis-python-5.35.3.tar.gz 9084707 BLAKE2B ff0638194067a1c52a0297254be572ba66d67afa49c1f2fbcc42bff694ab4fe545d408d9144118314a6decfdffdbe950e2b72e89b689ae99b82ad3d3321e72fd SHA512 d862cba17444b36fa05877419495b5e49e8686980e0203da388e2dc4e528ace928f0bcb244afc8512f97bf466f2e5a2a421a2c873053849af61de71421d5c61a
+DIST hypothesis-python-5.35.4.tar.gz 9084892 BLAKE2B 5545f2b1f3e97eafb4c83d7918f1558124102b1b58854bf0ca3a75fa3f6f08c0cc862c0ec32f5fdcbbf12e6cfc849e7081fe82ab0bb24e6de8fe41108525816b SHA512 db26d0b8d23b753c4880e0ee54ef89957c68c75496847aaefd538196188e7734513d737e2073bdced5eb7a8677b096b2cf9d6d48e572922d8a3e5a5c930bc795
diff --git a/dev-python/hypothesis/hypothesis-5.35.4.ebuild b/dev-python/hypothesis/hypothesis-5.35.4.ebuild
new file mode 100644
index 000000000000..c8d53477c0bc
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-5.35.4.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils multiprocessing optfeature
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="cli test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' python3_{6..9})
+ )
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/pytest-5.3.5[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+python_prepare() {
+ if ! use cli || [[ ${EPYTHON} != python* ]]; then
+ sed -i -e '/console_scripts/d' setup.py || die
+ fi
+}
+
+python_test() {
+ pytest -vv tests/cover tests/pytest tests/quality \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")" ||
+ die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}
diff --git a/dev-python/inflect/inflect-4.1.0.ebuild b/dev-python/inflect/inflect-4.1.0.ebuild
index 505c7b028c66..5ed8ab2d118e 100644
--- a/dev-python/inflect/inflect-4.1.0.ebuild
+++ b/dev-python/inflect/inflect-4.1.0.ebuild
@@ -4,8 +4,6 @@
EAPI=7
PYTHON_COMPAT=( pypy3 python3_{6,7,8,9} )
-# [options.entry_points] is present in setup.cfg but it is empty
-DISTUTILS_USE_SETUPTOOLS=manual
inherit distutils-r1
@@ -23,7 +21,6 @@ RDEPEND="
$(python_gen_cond_dep 'dev-python/importlib_metadata[${PYTHON_USEDEP}]' pypy3 python3_{6,7})
"
BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/setuptools_scm-3.4.1[${PYTHON_USEDEP}]
dev-python/toml[${PYTHON_USEDEP}]
test? ( dev-python/pytest[${PYTHON_USEDEP}] )
diff --git a/dev-python/irc/irc-19.0.1.ebuild b/dev-python/irc/irc-19.0.1.ebuild
index 2d780f0ed7ab..d2b8426c56e7 100644
--- a/dev-python/irc/irc-19.0.1.ebuild
+++ b/dev-python/irc/irc-19.0.1.ebuild
@@ -4,8 +4,6 @@
EAPI=7
PYTHON_COMPAT=( python3_{6,7,8,9} )
-# [options.entry_points] is present in setup.cfg but it is empty
-DISTUTILS_USE_SETUPTOOLS=manual
inherit distutils-r1
@@ -32,7 +30,6 @@ RDEPEND="
>=dev-python/tempora-1.6[${PYTHON_USEDEP}]
"
BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/setuptools_scm-3.4.1[${PYTHON_USEDEP}]
dev-python/toml[${PYTHON_USEDEP}]
test? (
diff --git a/dev-python/jaraco-collections/jaraco-collections-3.0.0.ebuild b/dev-python/jaraco-collections/jaraco-collections-3.0.0.ebuild
index 430a3e4d86e5..6c4405351517 100644
--- a/dev-python/jaraco-collections/jaraco-collections-3.0.0.ebuild
+++ b/dev-python/jaraco-collections/jaraco-collections-3.0.0.ebuild
@@ -4,7 +4,6 @@
EAPI=7
PYTHON_COMPAT=( python3_{6..9} pypy3 )
-DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
MY_PN="${PN/-/.}"
diff --git a/dev-python/jaraco-context/jaraco-context-3.0.0.ebuild b/dev-python/jaraco-context/jaraco-context-3.0.0.ebuild
index cc64921f317b..37dff8f76a75 100644
--- a/dev-python/jaraco-context/jaraco-context-3.0.0.ebuild
+++ b/dev-python/jaraco-context/jaraco-context-3.0.0.ebuild
@@ -3,8 +3,6 @@
EAPI=7
-# upstream uses bad template
-DISTUTILS_USE_SETUPTOOLS=manual
PYTHON_COMPAT=( python3_{6..9} pypy3 )
inherit distutils-r1
@@ -23,7 +21,6 @@ RDEPEND="
>=dev-python/namespace-jaraco-2[${PYTHON_USEDEP}]
"
BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/setuptools_scm[${PYTHON_USEDEP}]
"
diff --git a/dev-python/jaraco-functools/jaraco-functools-3.0.1.ebuild b/dev-python/jaraco-functools/jaraco-functools-3.0.1.ebuild
index 9710b82bb05d..94c723d9061d 100644
--- a/dev-python/jaraco-functools/jaraco-functools-3.0.1.ebuild
+++ b/dev-python/jaraco-functools/jaraco-functools-3.0.1.ebuild
@@ -4,8 +4,6 @@
EAPI=7
PYTHON_COMPAT=( pypy3 python3_{6,7,8,9} )
-# [options.entry_points] is present in setup.cfg but it is empty
-DISTUTILS_USE_SETUPTOOLS=manual
inherit distutils-r1
@@ -26,7 +24,6 @@ RDEPEND="
dev-python/more-itertools[${PYTHON_USEDEP}]
"
BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/toml[${PYTHON_USEDEP}]
dev-python/setuptools_scm[${PYTHON_USEDEP}]
test? (
diff --git a/dev-python/jaraco-itertools/jaraco-itertools-5.0.0.ebuild b/dev-python/jaraco-itertools/jaraco-itertools-5.0.0.ebuild
index 5a1196495f06..79f2924b2f97 100644
--- a/dev-python/jaraco-itertools/jaraco-itertools-5.0.0.ebuild
+++ b/dev-python/jaraco-itertools/jaraco-itertools-5.0.0.ebuild
@@ -4,8 +4,6 @@
EAPI=7
PYTHON_COMPAT=( pypy3 python3_{6,7,8,9} )
-# [options.entry_points] is present in setup.cfg but it is empty
-DISTUTILS_USE_SETUPTOOLS=manual
inherit distutils-r1
@@ -29,7 +27,6 @@ RDEPEND="
>=dev-python/more-itertools-4.0.0[${PYTHON_USEDEP}]
"
BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
test? (
${RDEPEND}
diff --git a/dev-python/jaraco-logging/jaraco-logging-3.0.0-r1.ebuild b/dev-python/jaraco-logging/jaraco-logging-3.0.0-r1.ebuild
index 46c712a12fd2..e90771dce5f8 100644
--- a/dev-python/jaraco-logging/jaraco-logging-3.0.0-r1.ebuild
+++ b/dev-python/jaraco-logging/jaraco-logging-3.0.0-r1.ebuild
@@ -4,8 +4,6 @@
EAPI=7
PYTHON_COMPAT=( pypy3 python3_{6,7,8,9} )
-# [options.entry_points] is present in setup.cfg but it is empty
-DISTUTILS_USE_SETUPTOOLS=manual
inherit distutils-r1
@@ -28,7 +26,6 @@ RDEPEND="
dev-python/tempora[${PYTHON_USEDEP}]
"
BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
test? (
${RDEPEND}
diff --git a/dev-python/jaraco-stream/jaraco-stream-3.0.0.ebuild b/dev-python/jaraco-stream/jaraco-stream-3.0.0.ebuild
index ecdbe10dea62..c50cc19bb17a 100644
--- a/dev-python/jaraco-stream/jaraco-stream-3.0.0.ebuild
+++ b/dev-python/jaraco-stream/jaraco-stream-3.0.0.ebuild
@@ -4,8 +4,6 @@
EAPI=7
PYTHON_COMPAT=( pypy3 python3_{6,7,8,9} )
-# entry_points is present in setup.py but it is empty
-DISTUTILS_USE_SETUPTOOLS=manual
inherit distutils-r1
@@ -22,7 +20,6 @@ RESTRICT="!test? ( test )"
RDEPEND=">=dev-python/namespace-jaraco-2[${PYTHON_USEDEP}]"
BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
test? (
${RDEPEND}
diff --git a/dev-python/node-semver/node-semver-0.8.0.ebuild b/dev-python/node-semver/node-semver-0.8.0.ebuild
index cebf767d37ce..ba58cb573bf8 100644
--- a/dev-python/node-semver/node-semver-0.8.0.ebuild
+++ b/dev-python/node-semver/node-semver-0.8.0.ebuild
@@ -4,8 +4,6 @@
EAPI=7
PYTHON_COMPAT=( pypy3 python3_{6,7,8,9} )
-# entry_points is present in setup.py but it is empty
-DISTUTILS_USE_SETUPTOOLS=manual
inherit distutils-r1
@@ -24,6 +22,4 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
distutils_enable_tests pytest
diff --git a/dev-python/protobuf-python/protobuf-python-3.13.0.ebuild b/dev-python/protobuf-python/protobuf-python-3.13.0.ebuild
index 93da8a7a9f4b..c015427c2d27 100644
--- a/dev-python/protobuf-python/protobuf-python-3.13.0.ebuild
+++ b/dev-python/protobuf-python/protobuf-python-3.13.0.ebuild
@@ -3,7 +3,6 @@
EAPI="7"
PYTHON_COMPAT=(python{2_7,3_6,3_7,3_8,3_9})
-DISTUTILS_USE_SETUPTOOLS="manual"
inherit distutils-r1
@@ -30,7 +29,6 @@ IUSE=""
BDEPEND="${PYTHON_DEPS}
~dev-libs/protobuf-${PV}
dev-python/namespace-google[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]"
DEPEND="${PYTHON_DEPS}
~dev-libs/protobuf-${PV}"
diff --git a/dev-python/protobuf-python/protobuf-python-9999.ebuild b/dev-python/protobuf-python/protobuf-python-9999.ebuild
index 6ea098fc2992..663013686fcf 100644
--- a/dev-python/protobuf-python/protobuf-python-9999.ebuild
+++ b/dev-python/protobuf-python/protobuf-python-9999.ebuild
@@ -3,7 +3,6 @@
EAPI="7"
PYTHON_COMPAT=(python{2_7,3_6,3_7,3_8,3_9})
-DISTUTILS_USE_SETUPTOOLS="manual"
inherit distutils-r1
@@ -30,7 +29,6 @@ IUSE=""
BDEPEND="${PYTHON_DEPS}
~dev-libs/protobuf-${PV}
dev-python/namespace-google[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]"
DEPEND="${PYTHON_DEPS}
~dev-libs/protobuf-${PV}"
diff --git a/dev-python/pycurl/pycurl-7.43.0.6.ebuild b/dev-python/pycurl/pycurl-7.43.0.6.ebuild
index b9e03ef669f6..7da02eb3d53b 100644
--- a/dev-python/pycurl/pycurl-7.43.0.6.ebuild
+++ b/dev-python/pycurl/pycurl-7.43.0.6.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-DISTUTILS_USE_SETUPTOOLS=manual
+DISTUTILS_USE_SETUPTOOLS=no
# The selftests fail with pypy, and urlgrabber segfaults for me.
PYTHON_COMPAT=( python3_{6,7,8,9} )
diff --git a/dev-python/python-cstruct/python-cstruct-1.8.ebuild b/dev-python/python-cstruct/python-cstruct-1.8.ebuild
index a7870977d0da..52f0221f8c6c 100644
--- a/dev-python/python-cstruct/python-cstruct-1.8.ebuild
+++ b/dev-python/python-cstruct/python-cstruct-1.8.ebuild
@@ -4,7 +4,6 @@
EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
-DISTUTILS_USE_SETUPTOOLS=manual
inherit distutils-r1
DESCRIPTION="C-style structs for Python"
@@ -15,10 +14,6 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-# define setuptools dep manually to avoid warning
-# setup.py contains entry_points, but it's an empty string
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
DOCS=( README.md )
distutils_enable_tests setup.py
diff --git a/dev-python/python-socks/Manifest b/dev-python/python-socks/Manifest
new file mode 100644
index 000000000000..1751c8394142
--- /dev/null
+++ b/dev-python/python-socks/Manifest
@@ -0,0 +1 @@
+DIST python-socks-1.1.0.gh.tar.gz 1358296 BLAKE2B c599095a7f687ba1bba6f0ddbbc8ef2e680cb6be4e5d2250fad88c3a3273fb2044712045b20c5a358ed9dcbaef07e5133b6d672698d8caf4b978c9e633a5df70 SHA512 e38594815e5f943f810862dfe5d07a802601e41e879f68b4fa70c8087be0387a91e99e1b0578f2819557832b5e53be9773043a9617c72017c41e9377c4f35ef1
diff --git a/dev-python/python-socks/metadata.xml b/dev-python/python-socks/metadata.xml
new file mode 100644
index 000000000000..266e3f19ca59
--- /dev/null
+++ b/dev-python/python-socks/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/python-socks/python-socks-1.1.0.ebuild b/dev-python/python-socks/python-socks-1.1.0.ebuild
new file mode 100644
index 000000000000..8efe7d9b3616
--- /dev/null
+++ b/dev-python/python-socks/python-socks-1.1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+inherit distutils-r1
+
+DESCRIPTION="SOCKS4, SOCKS5, HTTP tunneling functionality for Python"
+HOMEPAGE="
+ https://pypi.org/project/python-socks/
+ https://github.com/romis2012/python-socks/"
+SRC_URI="
+ https://github.com/romis2012/python-socks/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# tests rely on connecting to Internet
+RESTRICT="test"
+
+# trio, curio are not packaged
+# asyncio is the only backend we have, so dep on its deps unconditionally
+RDEPEND="dev-python/async_timeout[${PYTHON_USEDEP}]"
+#BDEPEND="
+# test? (
+# dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+# dev-python/yarl[${PYTHON_USEDEP}]
+# )"
+
+#distutils_enable_tests pytest
diff --git a/dev-python/rst-linker/rst-linker-2.0.0.ebuild b/dev-python/rst-linker/rst-linker-2.0.0.ebuild
index 5204e241d7e8..0b9231d4e01d 100644
--- a/dev-python/rst-linker/rst-linker-2.0.0.ebuild
+++ b/dev-python/rst-linker/rst-linker-2.0.0.ebuild
@@ -4,8 +4,6 @@
EAPI=7
PYTHON_COMPAT=( pypy3 python3_{6,7,8,9} )
-# [options.entry_points] is present in setup.cfg but it is empty
-DISTUTILS_USE_SETUPTOOLS=manual
inherit distutils-r1
@@ -25,7 +23,6 @@ RDEPEND="
dev-python/python-dateutil[${PYTHON_USEDEP}]
"
BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
test? (
${RDEPEND}
diff --git a/dev-python/voluptuous/Manifest b/dev-python/voluptuous/Manifest
index 50d8067892f3..5badb10b237f 100644
--- a/dev-python/voluptuous/Manifest
+++ b/dev-python/voluptuous/Manifest
@@ -1,2 +1,3 @@
DIST voluptuous-0.11.5.tar.gz 44216 BLAKE2B 921e0f35bd5348f412f0bf20939b3364b0014d3b1d1a7248cd73f2514eef0fb4e5b4b742876dc4606b5619529f1aa96e3577508ed0bf8d1e98b4d8bb88e2b8a2 SHA512 8893434e8e73ebf3682da1970d1d720444de452937ac9123fab53413c88a21d04ad3eb490902d829aa60be6804ff68b8bcf57a1c45807751c3d50be63e9b2551
DIST voluptuous-0.11.7.tar.gz 45262 BLAKE2B 2c4c171ed281bdf799491b0e14f64ff2f4ff73143b1b5498eed0d2d4a148ff0e40392393923f25bbb066a872a81ac753d861640abc8b3d340c4c01ff5e139140 SHA512 bf0ad4684a4da59b3eccb54f6edfa643eb894076fc50d1bfd4c953de15cfd711a70e8aee685497197eaef24897ae55fb5fb2aec5e2fc9dcf344a6f7c6f569b88
+DIST voluptuous-0.12.0.tar.gz 46958 BLAKE2B ec41ea9d5775bdc443153b913bcef7e73f14e29d47c6997e5597958b59c2b1143c83b65ca08d2a06aba3725f76f9168be4f46f68d91d87ceb4e4e3b6643e6800 SHA512 7c72d965f2a2eeb2ad099a19b41e2249b9921e51985ff975ed62fe5a6d5b3f2d5c2a7d6fc2cbe3c80abbea17cfc46c39f1953db5daecc0faafb348c838f80417
diff --git a/dev-python/voluptuous/metadata.xml b/dev-python/voluptuous/metadata.xml
index 89d22de27941..c7e7ebdee23f 100644
--- a/dev-python/voluptuous/metadata.xml
+++ b/dev-python/voluptuous/metadata.xml
@@ -12,6 +12,7 @@
<longdescription lang="en">
Voluptuous, despite the name, is a Python data validation library. It is primarily intended for validating data coming into Python as JSON, YAML, etc.
</longdescription>
+ <stabilize-allarches/>
<upstream>
<remote-id type="github">alecthomas/voluptuous</remote-id>
<remote-id type="pypi">voluptuous</remote-id>
diff --git a/dev-python/voluptuous/voluptuous-0.12.0.ebuild b/dev-python/voluptuous/voluptuous-0.12.0.ebuild
new file mode 100644
index 000000000000..d0c398fb00b3
--- /dev/null
+++ b/dev-python/voluptuous/voluptuous-0.12.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python data validation library."
+HOMEPAGE="https://github.com/alecthomas/voluptuous"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.11.5-fix-doctest.patch )
+
+distutils_enable_tests nose
diff --git a/dev-python/zipp/zipp-3.1.0.ebuild b/dev-python/zipp/zipp-3.1.0.ebuild
index ec24598fd3a3..2de7bedc518e 100644
--- a/dev-python/zipp/zipp-3.1.0.ebuild
+++ b/dev-python/zipp/zipp-3.1.0.ebuild
@@ -4,8 +4,6 @@
EAPI=7
PYTHON_COMPAT=( pypy3 python3_{6..9} )
-# [options.entry_points] is present in setup.cfg but it is empty
-DISTUTILS_USE_SETUPTOOLS=manual
inherit distutils-r1
@@ -19,7 +17,6 @@ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv s390 sparc x8
IUSE="test"
BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/toml[${PYTHON_USEDEP}]
>=dev-python/setuptools_scm-3.4.2[${PYTHON_USEDEP}]
test? ( dev-python/jaraco-itertools[${PYTHON_USEDEP}] )
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index e0e7a945ab87..25cb67b78a31 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -455,47 +455,6 @@ distutils_enable_tests() {
return 0
}
-# @FUNCTION: _distutils-r1_verify_use_setuptools
-# @INTERNAL
-# @DESCRIPTION:
-# Check setup.py for signs that DISTUTILS_USE_SETUPTOOLS have been set
-# incorrectly.
-_distutils_verify_use_setuptools() {
- [[ ${DISTUTILS_OPTIONAL} ]] && return
- [[ ${DISTUTILS_USE_SETUPTOOLS} == manual ]] && return
- [[ ${DISTUTILS_USE_SETUPTOOLS} == pyproject.toml ]] && return
-
- # ok, those are cheap greps. we can try toimprove them if we hit
- # false positives.
- local expected=no
- if [[ ${CATEGORY}/${PN} == dev-python/setuptools ]]; then
- # as a special case, setuptools provides itself ;-)
- :
- elif grep -E -q -s '(from|import)\s+setuptools' setup.py; then
- if grep -E -q -s 'entry_points\s*=' setup.py; then
- expected=rdepend
- elif grep -F -q -s '[options.entry_points]' setup.cfg; then
- expected=rdepend
- elif grep -F -q -s '[entry_points]' setup.cfg; then # pbr
- expected=rdepend
- else
- expected=bdepend
- fi
- fi
-
- if [[ ${DISTUTILS_USE_SETUPTOOLS} != ${expected} ]]; then
- if [[ ! ${_DISTUTILS_SETUPTOOLS_WARNED} ]]; then
- _DISTUTILS_SETUPTOOLS_WARNED=1
- local def=
- [[ ${DISTUTILS_USE_SETUPTOOLS} == bdepend ]] && def=' (default?)'
-
- eqawarn "DISTUTILS_USE_SETUPTOOLS value is probably incorrect"
- eqawarn " value: DISTUTILS_USE_SETUPTOOLS=${DISTUTILS_USE_SETUPTOOLS}${def}"
- eqawarn " expected: DISTUTILS_USE_SETUPTOOLS=${expected}"
- fi
- fi
-}
-
# @FUNCTION: esetup.py
# @USAGE: [<args>...]
# @DESCRIPTION:
@@ -518,7 +477,6 @@ esetup.py() {
[[ ${EAPI} != [45] ]] && die_args+=( -n )
[[ ${BUILD_DIR} ]] && _distutils-r1_create_setup_cfg
- _distutils_verify_use_setuptools
set -- "${EPYTHON:-python}" setup.py "${mydistutilsargs[@]}" "${@}"
diff --git a/metadata/install-qa-check.d/60distutils-use-setuptools b/metadata/install-qa-check.d/60distutils-use-setuptools
new file mode 100644
index 000000000000..db07212cce48
--- /dev/null
+++ b/metadata/install-qa-check.d/60distutils-use-setuptools
@@ -0,0 +1,60 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# QA check: verify correctness of DISTUTILS_USE_SETUPTOOLS
+# Maintainer: Python project <python@gentoo.org>
+
+get_expected_distutils_use_setuptools() {
+ local sitedir=${D}$(python_get_sitedir)
+ local egg new_expected
+ while read -d $'\0' -r egg; do
+ if [[ -f ${egg} ]]; then
+ # if .egg-info is a file, it's plain distutils
+ new_expected=no
+ elif grep -q -s -F '[console_scripts]' "${egg}"/entry_points.txt
+ then
+ # entry_points == we need rdepend
+ new_expected=rdepend
+ else
+ new_expected=bdepend
+ fi
+
+ if [[ ${expected} && ${new_expected} != ${expected} ]]; then
+ expected=integrity-error
+ else
+ expected=${new_expected}
+ fi
+ done < <(find "${sitedir}" -name '*.egg-info' -print0)
+}
+
+distutils_use_setuptools_check() {
+ # applicable only to ebuilds inheriting distutils-r1
+ [[ ${_DISTUTILS_R1} ]] || return
+ # 'manual' means no checking
+ [[ ${DISTUTILS_USE_SETUPTOOLS} == manual ]] && return
+ # pyproject.toml is verified by using it
+ [[ ${DISTUTILS_USE_SETUPTOOLS} == pyproject.toml ]] && return
+
+ local expected
+ _distutils-r1_run_foreach_impl get_expected_distutils_use_setuptools
+
+ if [[ ${expected} == integrity-error ]]; then
+ eerror "DISTUTILS_USE_SETUPTOOLS integrity error!"
+ eerror "expected was: ${expected}"
+ eerror "new_expected is: ${new_expected}"
+ eerror "Please report a bug about this and CC python@"
+ elif [[ ${DISTUTILS_USE_SETUPTOOLS} != ${expected} ]]; then
+ local def=
+ [[ ${DISTUTILS_USE_SETUPTOOLS} == bdepend ]] && def=' (or unset)'
+
+ eqawarn "DISTUTILS_USE_SETUPTOOLS value is probably incorrect"
+ eqawarn " have: DISTUTILS_USE_SETUPTOOLS=${DISTUTILS_USE_SETUPTOOLS}${def}"
+ eqawarn " expected: DISTUTILS_USE_SETUPTOOLS=${expected}"
+ fi
+}
+
+distutils_use_setuptools_check
+
+: # guarantee successful exit
+
+# vim:ft=ebuild
diff --git a/www-misc/urlwatch/urlwatch-2.21.ebuild b/www-misc/urlwatch/urlwatch-2.21.ebuild
index bdfd81f77975..23e7fa4367cd 100644
--- a/www-misc/urlwatch/urlwatch-2.21.ebuild
+++ b/www-misc/urlwatch/urlwatch-2.21.ebuild
@@ -3,10 +3,8 @@
EAPI=7
+DISTUTILS_USE_SETUPTOOLS=rdepend
PYTHON_COMPAT=( python3_{6,7,8,9} )
-# The package uses entry points but setup.py is weird
-# so the eclass doesn't detect it
-DISTUTILS_USE_SETUPTOOLS=manual
inherit distutils-r1
@@ -28,10 +26,8 @@ RDEPEND="
dev-python/minidb[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
"
BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
test? (
${RDEPEND}
dev-python/docutils[${PYTHON_USEDEP}]