summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-18 03:40:57 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-18 03:40:57 +0200
commita7f84c2921a87d8d147c803ef3082e43ab87f7de (patch)
tree5826badf455b160e7d51be41f3649a8a56e5f79c
parentdev-python/uv: Bump to 0.2.26 (diff)
downloadgentoo-a7f84c2921a87d8d147c803ef3082e43ab87f7de.tar.gz
gentoo-a7f84c2921a87d8d147c803ef3082e43ab87f7de.tar.bz2
gentoo-a7f84c2921a87d8d147c803ef3082e43ab87f7de.zip
dev-python/blurb: Bump to 1.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/blurb/Manifest1
-rw-r--r--dev-python/blurb/blurb-1.2.1.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/blurb/Manifest b/dev-python/blurb/Manifest
index 67974539aeb3..a13b03288e3a 100644
--- a/dev-python/blurb/Manifest
+++ b/dev-python/blurb/Manifest
@@ -1,2 +1,3 @@
DIST blurb-1.1.0.tar.gz 25064 BLAKE2B 4fbdd0d068cc7abb1ffa78dff70bd83feccc1bcfbf8ebb085c9f7e77e0f330d3759f10a94a5ca024b465c01f9d659496ae55162a52b7158a06caf2d114d36806 SHA512 9397173e7bf5babf02c96df27983462e7dd2a729e9eb0cacdf23ca3778336902d5c611ab5e2432bbc877344426d7c62ea8ae77719aa08da98f9b44365583b7ee
DIST blurb-1.2.0.tar.gz 23573 BLAKE2B a7a15fed82fca3f13eb840379b186210d6b8a039f61d48c65dce33ab80e970791add63efe9986adb54e7bedd452a3a867791237e250c1949b5b90f06bfac28ae SHA512 ebfe4c84d1f813822d7a583b337460a840235b61257428a47b7b61eb43b4b38fffc84f0fe758c6f61e9ae4b8c9c1affd9038077ddf846f17032e4497f87b78ad
+DIST blurb-1.2.1.tar.gz 23333 BLAKE2B 57374a3c787845a867c77480f1826cc82eae8cbdb659eeff9871cb3cf69f8e040d616cf40f051b63160b209b443dc26113b0d319f810cfe78842a759a139881b SHA512 f2bec26dacaa5f3c2016a4712a693ff483c0765b93f61900e7fa69765908b1c16318791e51778b71ffc222d339b5454603e7baec4a1bdfdd4c0e7b41a095f49c
diff --git a/dev-python/blurb/blurb-1.2.1.ebuild b/dev-python/blurb/blurb-1.2.1.ebuild
new file mode 100644
index 000000000000..ed8b87d5b515
--- /dev/null
+++ b/dev-python/blurb/blurb-1.2.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2018-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Tool to create and manage NEWS blurbs for CPython"
+HOMEPAGE="
+ https://github.com/python/core-workflow/tree/master/blurb
+ https://pypi.org/project/blurb/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pyfakefs[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest